summaryrefslogtreecommitdiff
path: root/dev-python/identify/identify-2.2.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /dev-python/identify/identify-2.2.6.ebuild
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'dev-python/identify/identify-2.2.6.ebuild')
-rw-r--r--dev-python/identify/identify-2.2.6.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/identify/identify-2.2.6.ebuild b/dev-python/identify/identify-2.2.6.ebuild
new file mode 100644
index 000000000000..f4471b5191e4
--- /dev/null
+++ b/dev-python/identify/identify-2.2.6.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="File identification library for Python"
+HOMEPAGE="https://github.com/pre-commit/identify"
+SRC_URI="https://github.com/pre-commit/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/editdistance-s[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest