summaryrefslogtreecommitdiff
path: root/dev-python/identify/identify-2.4.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/identify/identify-2.4.12.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/identify/identify-2.4.12.ebuild')
-rw-r--r--dev-python/identify/identify-2.4.12.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/identify/identify-2.4.12.ebuild b/dev-python/identify/identify-2.4.12.ebuild
new file mode 100644
index 000000000000..ca074bc25eff
--- /dev/null
+++ b/dev-python/identify/identify-2.4.12.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="File identification library for Python"
+HOMEPAGE="https://github.com/pre-commit/identify"
+SRC_URI="
+ https://github.com/pre-commit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="dev-python/ukkonen[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest