summaryrefslogtreecommitdiff
path: root/dev-python/identify/identify-2.5.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-04 01:15:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-04 01:15:40 +0100
commitc1bd8495f43d1e8a084ac779db6e4623aaa8d6ad (patch)
treee149dfa502bb9b798db46039ff95a0ed656a5567 /dev-python/identify/identify-2.5.6.ebuild
parentab6ac5a7942816b5b14186dc53e1b17ea7df200a (diff)
gentoo auto-resync : 04:10:2022 - 01:15:40
Diffstat (limited to 'dev-python/identify/identify-2.5.6.ebuild')
-rw-r--r--dev-python/identify/identify-2.5.6.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/identify/identify-2.5.6.ebuild b/dev-python/identify/identify-2.5.6.ebuild
new file mode 100644
index 000000000000..8ce2bd5b0e7d
--- /dev/null
+++ b/dev-python/identify/identify-2.5.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="File identification library for Python"
+HOMEPAGE="
+ https://github.com/pre-commit/identify/
+ https://pypi.org/project/identify/
+"
+SRC_URI="
+ https://github.com/pre-commit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/ukkonen[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest