summaryrefslogtreecommitdiff
path: root/dev-python/idna-ssl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-02 15:59:12 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-02 15:59:12 +0000
commit06a7b5647e11a8ddf69b1c3d3ded6a8ba28b923e (patch)
tree8d58c1f4b049da677b33209b072f2b3057268fe0 /dev-python/idna-ssl
parent99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (diff)
gentoo resync : 02.03.2018
Diffstat (limited to 'dev-python/idna-ssl')
-rw-r--r--dev-python/idna-ssl/Manifest3
-rw-r--r--dev-python/idna-ssl/idna-ssl-1.0.0.ebuild25
-rw-r--r--dev-python/idna-ssl/metadata.xml12
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/idna-ssl/Manifest b/dev-python/idna-ssl/Manifest
new file mode 100644
index 000000000000..0b7694c89f20
--- /dev/null
+++ b/dev-python/idna-ssl/Manifest
@@ -0,0 +1,3 @@
+DIST idna_ssl-1.0.0.tar.gz 3375 BLAKE2B 28ecee9e271619b7a4f3698aacbdbf0e953ed9b52640818007dc86f34145d8ea000260991d44cfa4cd896b74172b0a32962c3053152558b8d621396df2e248de SHA512 d1f7479cc3edff164bb26deb05af757906ba91241bc668f1b087560087a89f741a0b36e166bfb8142128ceed6008621ab36a2556ed2304ea6374c19982bc663a
+EBUILD idna-ssl-1.0.0.ebuild 596 BLAKE2B 0e1f4a4d737cf5ac8b218fc0848f2c490b00a84cffc05ff9bdc4bce49e91c1521871048c0926b21cd39ed686661dae6769034435dceb7db71071b96f3a4aeeab SHA512 11b2426a043d970e6e250ad4be2facb520ccc64583a92fcf22391ee85a7469212cf01efc411a952a7b88924bbc86f2bb08ca37575fa587ad24b75d1016e145db
+MISC metadata.xml 368 BLAKE2B b2f78fb9dea9edf6f2b2a7fb72412302b014e8b1b536653ae12fcd2bc8fa94bb253ff780aedcfd32fcddfcc2030b363e12440dfa4efef1a886e99b8b0acd8dba SHA512 531bbcdb7ec492aa4c38f4352cb0a93c618c60d9f8920ff476f6f8b7991744ccba2188a9e441e696a02d1c4ef4ea9af3afeb2c81a0d046e700796ee45b7f3888
diff --git a/dev-python/idna-ssl/idna-ssl-1.0.0.ebuild b/dev-python/idna-ssl/idna-ssl-1.0.0.ebuild
new file mode 100644
index 000000000000..d58e5b28fbc8
--- /dev/null
+++ b/dev-python/idna-ssl/idna-ssl-1.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit distutils-r1
+
+MY_PN=${PN/-/_}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Patch ssl.match_hostname for Unicode(idna) domains support"
+HOMEPAGE="https://github.com/aio-libs/idna-ssl https://pypi.python.org/pypi/idna_ssl"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/idna[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${MY_P}
diff --git a/dev-python/idna-ssl/metadata.xml b/dev-python/idna-ssl/metadata.xml
new file mode 100644
index 000000000000..e0f41b17f555
--- /dev/null
+++ b/dev-python/idna-ssl/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">idna_ssl</remote-id>
+ <remote-id type="github">aio-libs/idna-ssl</remote-id>
+ </upstream>
+</pkgmetadata>