summaryrefslogtreecommitdiff
path: root/dev-python/ijson
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-24 15:51:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-24 15:51:56 +0100
commitc7a2fa9581ac6df998adac5277043bb8014861fb (patch)
treea80156553124b4d53199c1bd5b82659ea8d97183 /dev-python/ijson
parent3c4a961cb5e1350d7d40db49eabbcd7ef649306d (diff)
gentoo auto-resync : 24:08:2023 - 15:51:56
Diffstat (limited to 'dev-python/ijson')
-rw-r--r--dev-python/ijson/Manifest4
-rw-r--r--dev-python/ijson/ijson-3.2.2.ebuild48
-rw-r--r--dev-python/ijson/ijson-3.2.3.ebuild2
3 files changed, 2 insertions, 52 deletions
diff --git a/dev-python/ijson/Manifest b/dev-python/ijson/Manifest
index ec27f85ba0c4..320c39ab5780 100644
--- a/dev-python/ijson/Manifest
+++ b/dev-python/ijson/Manifest
@@ -1,5 +1,3 @@
-DIST ijson-3.2.2.gh.tar.gz 127965 BLAKE2B 2e20f7cc822406fe3e7eec99c3ef394e42d90b0b518226a7b8eb078763cb8317acb4a28934301116c32a2a9cc37403c2950b18232800485b1ea1206dace7ff23 SHA512 5935071bd0d3eecc39b3c30ca5cb2a959e4d455c57e36414d5c97ba71bbcf1a0b53c8b8afed7551a3a4ac4595294105566c9d7501b35832dd7e46a1bb2151287
DIST ijson-3.2.3.tar.gz 57596 BLAKE2B e85465829f8319e2e227b7b72633b65e7e77a8cd24fee877aded1f50383ffbbaddd82e5e3942c0b3f637a8e601c5101aa390889e8509ee2c61b6f3c9cf9a7249 SHA512 ca72ed08c7804611d7f9c5218d217087fe17358859d080741726b42072df1407afcf1f701e30d33f3f615e8c78ba247a3cc45e8e7e373f1d3168a63f397fd6eb
-EBUILD ijson-3.2.2.ebuild 935 BLAKE2B e4a37e45dc2ee07cd4e0d6d696dc5100945367924f7f012a60e401151cde91194f05e7250810d76ba3cdc07b7316a4bdc252419de114614a4d13247f3c255a76 SHA512 ee1043315defa9e8a37de6608921fb51cef4831c1a6791f80d2ed45a632786df3b4cb7d1d7414650e9a7227d9a04026d3213403a3135b44329453ea5de460fb1
-EBUILD ijson-3.2.3.ebuild 584 BLAKE2B 2d3751f3be96f8f43a93b97ae2b5238ba85da91d1a93cd3391922873e8343bd4383f5e372b114a6e08e64ec30e8834390b88b6d6fb416e0a8c9fdaee46643a91 SHA512 d353ed8258d1b6af84a8b812e16991acff30c56949ff8f16eaee8e73284c697d3eae3c528ac59a26f370402b305dc1c4d3b4a394012deed4fec18230585cdba5
+EBUILD ijson-3.2.3.ebuild 582 BLAKE2B 665fa80098fec72ab23a70d503d939463526ec3a7e0e97c44226d2d35fdf3ad6789b76083e70bfb759f0a682695fcdbc5c01a8d6b8e5fb77123c89fec64d366a SHA512 27137ea304b014f650ed2e055890380f6e727dd7fe4b20ae42e57d16acbbd84aa29ef2f7542b7050b062ff38c5a0188dce865f0602323299e481396569cf972c
MISC metadata.xml 372 BLAKE2B 9fd70113a6731ca09979bacb2153df2c26db31ef9cb2a95cc2de2201aeb5348a6344fa6dab27a0880a9d70cb4498d39a4ef9cbcff6127932d5af3c534e21b5c2 SHA512 5f3747561e4c802300860b9d2f27b08acea3979e8cac48bf6145c4cbeeb3ec0b3d765399d0ed8fe01947860d78dea0faa0839cb393e066ec0aaffa2ab2661398
diff --git a/dev-python/ijson/ijson-3.2.2.ebuild b/dev-python/ijson/ijson-3.2.2.ebuild
deleted file mode 100644
index 432500824ad1..000000000000
--- a/dev-python/ijson/ijson-3.2.2.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1
-
-MY_P="${P//_p/.post}"
-DESCRIPTION="Iterative JSON parser with a Pythonic interface"
-HOMEPAGE="
- https://github.com/ICRAR/ijson/
- https://pypi.org/project/ijson/
-"
-SRC_URI="
- https://github.com/ICRAR/${PN}/archive/v${PV/_p/.post}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~ppc64 x86"
-
-DEPEND="
- dev-libs/yajl
-"
-RDEPEND="
- ${DEPEND}
-"
-
-distutils_enable_tests pytest
-
-python_compile() {
- local -x IJSON_BUILD_YAJL2C=1
- # The extension is broken on PyPy3, probably a bug in PyPy itself.
- # https://github.com/ICRAR/ijson/issues/101
- [[ ${EPYTHON} == pypy3 ]] && IJSON_BUILD_YAJL2C=0
- distutils-r1_python_compile
-}
-
-python_test() {
- rm -rf ijson || die
- epytest
-}
diff --git a/dev-python/ijson/ijson-3.2.3.ebuild b/dev-python/ijson/ijson-3.2.3.ebuild
index 1cacc738a0c5..1133665c1e15 100644
--- a/dev-python/ijson/ijson-3.2.3.ebuild
+++ b/dev-python/ijson/ijson-3.2.3.ebuild
@@ -17,7 +17,7 @@ HOMEPAGE="
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
+KEYWORDS="amd64 ~ppc64 x86"
DEPEND="
dev-libs/yajl