summaryrefslogtreecommitdiff
path: root/dev-python/imageio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-19 12:25:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-19 12:25:21 +0100
commit1f3e27f8fde0df9246ce9151ced7d2dd4e96cb07 (patch)
tree2ccd1e9121906f2bccf218e14e3ca943a2b84bf3 /dev-python/imageio
parent16be64511bd21e32a29645b49e37611507709790 (diff)
gentoo auto-resync : 19:08:2024 - 12:25:21
Diffstat (limited to 'dev-python/imageio')
-rw-r--r--dev-python/imageio/Manifest2
-rw-r--r--dev-python/imageio/imageio-2.35.1.ebuild103
2 files changed, 105 insertions, 0 deletions
diff --git a/dev-python/imageio/Manifest b/dev-python/imageio/Manifest
index 64de6436afbf..2f463f393ca9 100644
--- a/dev-python/imageio/Manifest
+++ b/dev-python/imageio/Manifest
@@ -1,5 +1,7 @@
AUX imageio-2.22.0-block-download.patch 1211 BLAKE2B c01e3fd7db7463bc11bf331384a21becfc3160d4880a2fd09e47bf0927d97e46787097f50a489b83c2626078b60a0cf8a0d896040981e78c107f1783c8e84c26 SHA512 170261b9fb07ccb7f7a7e058335326df1f72c8d098076bf6ca048a7ca6bac95ddb512b9e41740c385430bc25613249455203addd59931af4e70298e772303964
DIST imageio-2.35.0.gh.tar.gz 415875 BLAKE2B 5fc774c6e48fdd6a4171397cd7c8af8be323886979186507692754bfd439ceaf1434bc3958ec7f55570cb39ae0713d77b6999233339ba20c0f343abd9dd72728 SHA512 707aee7dea36d9292c867e551b0c1dd78e1b52e41c03238f28e77b133bc82c1f0e8de8c25200fefc65c69dbb47720e3878292abc697ed09c9e12dcea09c3da99
+DIST imageio-2.35.1.gh.tar.gz 415944 BLAKE2B 303cc3ab288b184fdbd8b5a1e3cb47308bd96e818793245d84f4bb3fb55f117fb61ae49df80aada8aceb128172d3b47e48fe0a47823a0734847a98983f2ec80c SHA512 7aa486c23179a798b3801a4ea7d71d2a4f81f53a02dcd0f83537bb3b3ce617b02882bb970e45bc390c106b8d7c62822a736f898ff21dac4951963f2cbc899fc4
DIST imageio-test_images-1121036015c70cdbb3015e5c5ba0aaaf7d3d6021.gh.tar.gz 195497374 BLAKE2B 0083212fd63c196dc2e721bff8f89c177b6741317b6b1c6ae9d00a8dd5fb6366efa3f01b9bffafafac7177cfdaa4d700077a2bad42ada735f5553e97f651c4ad SHA512 1bb1f36a069bfaa0d0ffe5258534e02e49237fc6ce85fe3d3648650130165abc9b3d5ff0e7e5861ee1d94add00d4258575f9c2f8556debecf597bdaa5499efe0
EBUILD imageio-2.35.0-r1.ebuild 2872 BLAKE2B 44106866da369eaa86fa6c3e3a9104e2457658573cf21ece7af0794783981fb2384a716268f7a94a005fbdd8d6c7012fdc1d7401fad512ed0e057401f3185e8c SHA512 0156b1c8f8e972924d9d1bce9b90206c74753fe8d5f4be325c66d78aaa23e448592aa6608e47970f5dba04e94da45ab1c1a11cd71b0d3aad44069034809d2f3d
+EBUILD imageio-2.35.1.ebuild 2809 BLAKE2B eefd1ddee17b0066858d61ade38d9fe436c5f00d4d2fde73041c15827ac93f71390c234fa16fcf7cdb00b2e42b5b534feac0341242cbb0efbcaaac40c6bb157d SHA512 ca01c395c9f4ba0191cbf2cb32084684c14fde5b92d867f5a42785027b19a179a1d45e387641c8cb7b3d78291504dd00b4044e6926c84abe34959194b82b7663
MISC metadata.xml 702 BLAKE2B 646c6a83e6d8e345fddb9cbc42a83c1193b9590937cd652e293d03e6e9d4b240a69e6e86399f5edc9ef05f96d1d4c3713dfa65f8b13984f4483b2ce76a239429 SHA512 5e1e4db52fed55ab837c70ddb9ec81a7ce0b062064e2d33cb5771cd81d50a1a2164e446531c32a405bb9319acd736141765dcd00e36d6db770434a656ad925e1
diff --git a/dev-python/imageio/imageio-2.35.1.ebuild b/dev-python/imageio/imageio-2.35.1.ebuild
new file mode 100644
index 000000000000..9f86e40a6cdb
--- /dev/null
+++ b/dev-python/imageio/imageio-2.35.1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+TEST_IMAGES_COMMIT=1121036015c70cdbb3015e5c5ba0aaaf7d3d6021
+DESCRIPTION="Python library for reading and writing image data"
+HOMEPAGE="
+ https://imageio.readthedocs.io/en/stable/
+ https://github.com/imageio/imageio/
+ https://pypi.org/project/imageio/
+"
+SRC_URI="
+ https://github.com/imageio/imageio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ test? (
+ https://github.com/imageio/test_images/archive/${TEST_IMAGES_COMMIT}.tar.gz
+ -> imageio-test_images-${TEST_IMAGES_COMMIT}.gh.tar.gz
+ )
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/numpy-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/pillow-8.3.2[${PYTHON_USEDEP}]
+ media-libs/freeimage
+"
+BDEPEND="
+ test? (
+ >=dev-python/imageio-ffmpeg-0.4.9-r1[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/tifffile[${PYTHON_USEDEP}]
+ || (
+ media-video/ffmpeg[openh264]
+ media-video/ffmpeg[x264]
+ )
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ local PATCHES=(
+ # block silently downloading vulnerable libraries from the Internet
+ "${FILESDIR}/imageio-2.22.0-block-download.patch"
+ )
+
+ if use test; then
+ mv "${WORKDIR}/test_images-${TEST_IMAGES_COMMIT}" .test_images || die
+ # upstream tries to update the image cache, and invalidates it
+ # if "git pull" fails
+ sed -i -e 's:git pull:true:' tests/conftest.py || die
+ # ffmpeg tests expect it there
+ mkdir -p "${HOME}/.imageio/images" || die
+ cp .test_images/cockatoo.mp4 "${HOME}/.imageio/images" || die
+ fi
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # uses fsspec to grab prebuilt .so from GitHub, sigh
+ tests/test_freeimage.py
+ )
+
+ local EPYTEST_DESELECT=(
+ # Note: upstream has a needs_internet marker but it is also
+ # used to mark tests that require test_images checkout that we
+ # supply
+
+ # Tries to download ffmpeg binary ?!
+ tests/test_ffmpeg.py::test_get_exe_installed
+ # blocked by our patch
+ tests/test_core.py::test_fetching
+ tests/test_core.py::test_request
+ # Internet
+ tests/test_bsdf.py::test_from_url
+ tests/test_core.py::test_mvolread_out_of_bytes
+ tests/test_core.py::test_request_read_sources
+ tests/test_pillow.py::test_gif_first_p_frame
+ tests/test_pillow.py::test_png_remote
+ tests/test_pillow.py::test_webp_remote
+ tests/test_pillow_legacy.py::test_png_remote
+ tests/test_swf.py::test_read_from_url
+ # requires pillow-heif, also possibly Internet
+ tests/test_pillow.py::test_avif_remote
+ tests/test_pillow.py::test_heif_remote
+ # not important, requires random system libs
+ tests/test_core.py::test_findlib2
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}