summaryrefslogtreecommitdiff
path: root/dev-python/imdbpy/imdbpy-5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/imdbpy/imdbpy-5.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/imdbpy/imdbpy-5.0.ebuild')
-rw-r--r--dev-python/imdbpy/imdbpy-5.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/imdbpy/imdbpy-5.0.ebuild b/dev-python/imdbpy/imdbpy-5.0.ebuild
new file mode 100644
index 000000000000..1c075afaf2d0
--- /dev/null
+++ b/dev-python/imdbpy/imdbpy-5.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+MY_PN="IMDbPY"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python package to access the IMDb movie database"
+HOMEPAGE="http://imdbpy.sourceforge.net/ https://pypi.python.org/pypi/IMDbPY"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+DOCS=( docs/FAQS.txt docs/imdbpy48.dtd docs/imdbpy.cfg )
+
+PATCHES=( "${FILESDIR}/${PN}-4.6-data_location.patch" )
+
+src_configure() {
+ distutils-r1_src_configure --without-cutils
+}
+
+python_install_all() {
+ local doc
+ for doc in docs/README*
+ do
+ DOCS=( "${DOCS[@]}" $doc )
+ done
+ distutils-r1_python_install_all
+}