summaryrefslogtreecommitdiff
path: root/dev-python/immutables
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/immutables
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/immutables')
-rw-r--r--dev-python/immutables/Manifest6
-rw-r--r--dev-python/immutables/immutables-0.16.ebuild30
-rw-r--r--dev-python/immutables/immutables-0.18.ebuild (renamed from dev-python/immutables/immutables-0.17.ebuild)19
3 files changed, 15 insertions, 40 deletions
diff --git a/dev-python/immutables/Manifest b/dev-python/immutables/Manifest
index 2c99f42b8dca..e487fb8c6d33 100644
--- a/dev-python/immutables/Manifest
+++ b/dev-python/immutables/Manifest
@@ -1,5 +1,3 @@
-DIST immutables-0.16.tar.gz 84916 BLAKE2B e699aaa1135fa9f7db9589276dc0801a67c5f98bd3c5b247913d8263f9baf02a8772d7715cc3eb2c9392694d48d3808d50f45e9fe8e66c4d507586d0e3fdc319 SHA512 5b883cfe43f8a042b617e719dccd3cbdded3b1d1df160ba26b6bb2f0816a7171698bdd2ba3d450e76f135b236e777052a22c09b8bd1a9183227f1ccc90617cf8
-DIST immutables-0.17.gh.tar.gz 84660 BLAKE2B 475042d6342e3ffe5b4aa68e2e8c27a438658214ec2aa6439e077d59d2e2257313f644f535ebfbdb171b0e7dac33cde590f8a84a8da9da717b249e5b2e11ca92 SHA512 d5853de6b7c6064c93b6dbf66819873c982dd2e155ddcbf6b5dd321475374e9f52eb683c853a6944c71ca15fb194ac9480ad2d444407c885ee574c244c4f081a
-EBUILD immutables-0.16.ebuild 808 BLAKE2B e44502bc80f8b03f2028fd527b99691634b2a46162d6985bbf472097155e4720909a508a8e9ba69d0b16cabd36cf28bbe1bc2e52d40c7635b27164915245244d SHA512 a2503b67bbb2d585c91f5aec43d5d984df29db6fd240e501db473b3416d676ef3c83a0eb1f59b5935ca110e5be975b17643a99a639bf61fb3059601d76d1d816
-EBUILD immutables-0.17.ebuild 758 BLAKE2B bf7a904c293767d31dcf56f39f375da291c4d26055e7fab58c97c4a89208e3cb4d905ac0b0619151ca6aed5e672b1b3ac85efb692797cd6c8c98ca4b59c12512 SHA512 d5fed44c4af9e3eb1ed257a074a2a9ebc582e73f02d4c95ff6eec132d1a056f1fecc6bfdcecbaa96192c1a3f6b49065c920ce8eec4c684ce3ff1df1fb0078a8c
+DIST immutables-0.18.gh.tar.gz 84891 BLAKE2B 2e800e1b7b354781ef221315b80877e57ef446753c4a42e411196379e2bc921f71918c5ecd5cc693ca54cb7c401bef31161e9d249407b705626fe95d0e4e9fcc SHA512 1477ff6d9a6c02c3619b209352096abefb913cf53d392748e0940160067ecdcf2b89ad9ce807161ededaa5062105a2e5c5a3303bd02752a5f07b5f68f1c1044c
+EBUILD immutables-0.18.ebuild 811 BLAKE2B 4fa65ad7440492d0113f3801a968af96840cfba36f24f45780c1ac3265184c82b0c3de2948b63886cdb9f63fe87ce18109bdd2eb6011c49a25984334393980af SHA512 d4156d40e6b4fa634d16781aad141b18bb3de8cc85bfcee0537369c76086024dc51dc6004f6dda9b6af0f8ec069c1db17784ff892eba87b997e78dd61787703b
MISC metadata.xml 353 BLAKE2B 5ba3a63b6d65aa989535ec78a5e097fb15e6bcb392e846471fb01efd4a4b546a3ba861cc3829d13e71f1f5c31b582a99e1f5e4adf6b60c2b6fb17bdfb9265c99 SHA512 ede81f3aec8f6ee374c8d39d60f4193cfb701f2561858f2ddfadbe68d531849cec13fb8c13cc671e14d8ab1f18b08759d030c562cc496f959517c6ce67ac9781
diff --git a/dev-python/immutables/immutables-0.16.ebuild b/dev-python/immutables/immutables-0.16.ebuild
deleted file mode 100644
index bff5d2a27f79..000000000000
--- a/dev-python/immutables/immutables-0.16.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 2019-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="A high-performance immutable mapping type for Python"
-HOMEPAGE="https://github.com/MagicStack/immutables"
-SRC_URI="https://github.com/MagicStack/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv sparc x86"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -i -e '/mypy/d' tests/conftest.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- # force running from BUILD_DIR to get the C extension tested
- cp -r tests "${BUILD_DIR}"/lib || die
- cd "${BUILD_DIR}"/lib || die
- epytest tests --ignore tests/test_mypy.py
- rm -r tests || die
-}
diff --git a/dev-python/immutables/immutables-0.17.ebuild b/dev-python/immutables/immutables-0.18.ebuild
index 4e758bdef258..e34f68e5dd8a 100644
--- a/dev-python/immutables/immutables-0.17.ebuild
+++ b/dev-python/immutables/immutables-0.18.ebuild
@@ -4,12 +4,15 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
inherit distutils-r1
DESCRIPTION="A high-performance immutable mapping type for Python"
-HOMEPAGE="https://github.com/MagicStack/immutables"
+HOMEPAGE="
+ https://github.com/MagicStack/immutables/
+ https://pypi.org/project/immutables/
+"
SRC_URI="
https://github.com/MagicStack/${PN}/archive/v${PV}.tar.gz
-> ${P}.gh.tar.gz
@@ -17,7 +20,7 @@ SRC_URI="
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
distutils_enable_tests pytest
@@ -26,7 +29,11 @@ src_prepare() {
distutils-r1_src_prepare
}
-python_test() {
- cd "${T}" || die
- epytest "${S}"/tests --ignore "${S}"/tests/test_mypy.py
+src_test() {
+ local EPYTEST_IGNORE=(
+ tests/test_mypy.py
+ )
+
+ rm -r immutables || die
+ distutils-r1_src_test
}