summaryrefslogtreecommitdiff
path: root/dev-python/immutables
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-python/immutables
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-python/immutables')
-rw-r--r--dev-python/immutables/Manifest4
-rw-r--r--dev-python/immutables/immutables-0.16.ebuild4
-rw-r--r--dev-python/immutables/immutables-0.17.ebuild32
3 files changed, 37 insertions, 3 deletions
diff --git a/dev-python/immutables/Manifest b/dev-python/immutables/Manifest
index 729a9ec24ab2..d3bc6d209f72 100644
--- a/dev-python/immutables/Manifest
+++ b/dev-python/immutables/Manifest
@@ -1,3 +1,5 @@
DIST immutables-0.16.tar.gz 84916 BLAKE2B e699aaa1135fa9f7db9589276dc0801a67c5f98bd3c5b247913d8263f9baf02a8772d7715cc3eb2c9392694d48d3808d50f45e9fe8e66c4d507586d0e3fdc319 SHA512 5b883cfe43f8a042b617e719dccd3cbdded3b1d1df160ba26b6bb2f0816a7171698bdd2ba3d450e76f135b236e777052a22c09b8bd1a9183227f1ccc90617cf8
-EBUILD immutables-0.16.ebuild 802 BLAKE2B b1fa66cd9b5505adca97738b3bcb91e7fce2dbd6054b03a27ae45448888616125b56a8339040a6c4271b4c0cbbcb38281cbc17e6f9cb87fc605eab60a50d5a5a SHA512 c5648301f7b7531c070f57df71d95b79753681ce6b32fd89daa0560a63102ca06c2d19e28576c28a8ab6bb9df757826bd42ea7a2159d647193965525f0272a12
+DIST immutables-0.17.gh.tar.gz 84660 BLAKE2B 475042d6342e3ffe5b4aa68e2e8c27a438658214ec2aa6439e077d59d2e2257313f644f535ebfbdb171b0e7dac33cde590f8a84a8da9da717b249e5b2e11ca92 SHA512 d5853de6b7c6064c93b6dbf66819873c982dd2e155ddcbf6b5dd321475374e9f52eb683c853a6944c71ca15fb194ac9480ad2d444407c885ee574c244c4f081a
+EBUILD immutables-0.16.ebuild 808 BLAKE2B e44502bc80f8b03f2028fd527b99691634b2a46162d6985bbf472097155e4720909a508a8e9ba69d0b16cabd36cf28bbe1bc2e52d40c7635b27164915245244d SHA512 a2503b67bbb2d585c91f5aec43d5d984df29db6fd240e501db473b3416d676ef3c83a0eb1f59b5935ca110e5be975b17643a99a639bf61fb3059601d76d1d816
+EBUILD immutables-0.17.ebuild 738 BLAKE2B af9952ad6f1c59b5d3062a18f803e9208ee4ac13dab705566fda5b4ac6f3debfc87f81874d348dfcdbe709a693da500feef9c163c638c98dfac412dffd9b68c2 SHA512 caf06ed9a9fb2a9a8db201662a81e3e7808dc158e34172061bfb8201b6e12e592a0d9c314fd8d6627a6f24ada4302e70b0d936847b0cc04738551863a6c5735a
MISC metadata.xml 353 BLAKE2B 5ba3a63b6d65aa989535ec78a5e097fb15e6bcb392e846471fb01efd4a4b546a3ba861cc3829d13e71f1f5c31b582a99e1f5e4adf6b60c2b6fb17bdfb9265c99 SHA512 ede81f3aec8f6ee374c8d39d60f4193cfb701f2561858f2ddfadbe68d531849cec13fb8c13cc671e14d8ab1f18b08759d030c562cc496f959517c6ce67ac9781
diff --git a/dev-python/immutables/immutables-0.16.ebuild b/dev-python/immutables/immutables-0.16.ebuild
index 0fba54b02046..bff5d2a27f79 100644
--- a/dev-python/immutables/immutables-0.16.ebuild
+++ b/dev-python/immutables/immutables-0.16.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2019-2021 Gentoo Authors
+# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
inherit distutils-r1
DESCRIPTION="A high-performance immutable mapping type for Python"
diff --git a/dev-python/immutables/immutables-0.17.ebuild b/dev-python/immutables/immutables-0.17.ebuild
new file mode 100644
index 000000000000..02ca6370a27a
--- /dev/null
+++ b/dev-python/immutables/immutables-0.17.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A high-performance immutable mapping type for Python"
+HOMEPAGE="https://github.com/MagicStack/immutables"
+SRC_URI="
+ https://github.com/MagicStack/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/mypy/d' tests/conftest.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ cd "${T}" || die
+ epytest "${S}"/tests --ignore "${S}"/tests/test_mypy.py
+}