summaryrefslogtreecommitdiff
path: root/dev-python/indexed-gzip
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-26 10:30:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-26 10:30:48 +0100
commit96cc0713998c294a9440f03dfa8c4adc9cb71f92 (patch)
treec51c399e2ac466345931e32f9bb465534a74f828 /dev-python/indexed-gzip
parent390bde0d9e0b055c7e87ede2f6b3546ec7da02c7 (diff)
gentoo auto-resync : 26:07:2023 - 10:30:48
Diffstat (limited to 'dev-python/indexed-gzip')
-rw-r--r--dev-python/indexed-gzip/Manifest5
-rw-r--r--dev-python/indexed-gzip/indexed-gzip-1.7.1.ebuild55
-rw-r--r--dev-python/indexed-gzip/indexed-gzip-1.8.3.ebuild56
-rw-r--r--dev-python/indexed-gzip/metadata.xml19
4 files changed, 135 insertions, 0 deletions
diff --git a/dev-python/indexed-gzip/Manifest b/dev-python/indexed-gzip/Manifest
new file mode 100644
index 000000000000..04062104072f
--- /dev/null
+++ b/dev-python/indexed-gzip/Manifest
@@ -0,0 +1,5 @@
+DIST indexed_gzip-1.7.1.tar.gz 74457 BLAKE2B b22d2120adac59e64f5bcf38c831bb54ce5d6c3dd1e959eece9a454908d9ce2aa5dc10557bd63823616bedfe9d0c039a3f1c0512ef1d22a54437353c57e15158 SHA512 fa27e476f115eca1d1d3892c3480de97cb407bd489737bebc44eb28e92be91e14312cde33a67af145b44c7d93ccc706498c2cbfe6cbff5b9b091dd083cde0f7e
+DIST indexed_gzip-1.8.3.tar.gz 74621 BLAKE2B e8092eea93235b7e6a154b34d12194ffbd3ecb88f2891b8b60ab526fa6a9247c78afded19b284b8143981a83333f376e82b65003ada61ce2efe7378fe84749a4 SHA512 f33fb19938ae39e4ede71f3f2a328f56e7fad5ee4872b25c0977ded1819541e9e63d64a1379b022cd82af79a5c0967d8fdde589d2276841a4b0e9d3179229035
+EBUILD indexed-gzip-1.7.1.ebuild 1056 BLAKE2B 0a64c05fc42afc44aba9196e8ebc5b4e7bf682b8d0b2e2557b11a1571c475d26ff158aa304089d5df6ebd775712d5bc40b4d952d433c45c4ec816f45a51cdb51 SHA512 23675c2b76d77068f1520f62a3422dec9145c634631b1f89de9b1365ada1897c77eddfed6192a15c701885170221ac4e07c97fd12a0098aacaf8e9a6f79d3127
+EBUILD indexed-gzip-1.8.3.ebuild 1156 BLAKE2B dd80508aaad954ca02aedf1ad73be96985800f6249f0416a5d7790b02864fafbaa3257f491034a24da6fe93057837e56c4826149908a8e09ba7e2f2fb8d4fc01 SHA512 64ef6ab931a2564098b8583299e14d95b2e095a497c32f370316c705bdec95315cf6c2ad4915df7cf6ea91edd91fee17902e5d07c64ebeaa5e27b2adb71595aa
+MISC metadata.xml 772 BLAKE2B c5788c4748250507ff0c231613f6d143839a48c5afac0d68bb806cb3d24e9119d5d3eae3135ca991dfff5bfc5955ddb545afd6293dd4e0565591fb779b3f88ed SHA512 726c025bb40efe9d30a4c1691df9c1a011684af4b1f56cb5ef6c857ae712807c15857c13934b67586f7141fa4a3f3e548acd6adffe12f6285492e1171c21ac99
diff --git a/dev-python/indexed-gzip/indexed-gzip-1.7.1.ebuild b/dev-python/indexed-gzip/indexed-gzip-1.7.1.ebuild
new file mode 100644
index 000000000000..44aac738ce10
--- /dev/null
+++ b/dev-python/indexed-gzip/indexed-gzip-1.7.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Fast random access of gzip files in Python"
+HOMEPAGE="
+ https://pypi.org/project/indexed-gzip/
+ https://github.com/pauldmccarthy/indexed_gzip/
+"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ sys-libs/zlib:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # strip custom "clean" command that doesn't support "-a"
+ # https://bugs.gentoo.org/838955
+ # TODO: this can be removed once distutils-r1 stops using clean
+ sed -e '/cmdclass/d' -i setup.py || die
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ if use test; then
+ export INDEXED_GZIP_TESTING=1
+ fi
+ distutils-r1_src_compile
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)/indexed_gzip/tests" || die
+ epytest
+}
diff --git a/dev-python/indexed-gzip/indexed-gzip-1.8.3.ebuild b/dev-python/indexed-gzip/indexed-gzip-1.8.3.ebuild
new file mode 100644
index 000000000000..9e9fb985434c
--- /dev/null
+++ b/dev-python/indexed-gzip/indexed-gzip-1.8.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing pypi
+
+DESCRIPTION="Fast random access of gzip files in Python"
+HOMEPAGE="
+ https://pypi.org/project/indexed-gzip/
+ https://github.com/pauldmccarthy/indexed_gzip/
+"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ sys-libs/zlib:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # strip custom "clean" command that doesn't support "-a"
+ # https://bugs.gentoo.org/838955
+ # TODO: this can be removed once distutils-r1 stops using clean
+ sed -e '/cmdclass/d' -i setup.py || die
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ if use test; then
+ export INDEXED_GZIP_TESTING=1
+ fi
+ distutils-r1_src_compile
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)/indexed_gzip/tests" || die
+ epytest -n "$(makeopts_jobs)" --dist=worksteal
+}
diff --git a/dev-python/indexed-gzip/metadata.xml b/dev-python/indexed-gzip/metadata.xml
new file mode 100644
index 000000000000..88a3a568d717
--- /dev/null
+++ b/dev-python/indexed-gzip/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ The indexed_gzip project is a Python extension which aims to provide a
+ drop-in replacement for the built-in Python gzip.GzipFile class,
+ the IndexedGzipFile. This package was written to allow fast random
+ access of compressed NIFTI image files (for which GZIP is the de-facto
+ compression standard), but will work with any GZIP file.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">pauldmccarthy/indexed_gzip</remote-id>
+ <remote-id type="pypi">indexed-gzip</remote-id>
+ </upstream>
+</pkgmetadata>