summaryrefslogtreecommitdiff
path: root/dev-python/inflection
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/inflection
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/inflection')
-rw-r--r--dev-python/inflection/Manifest3
-rw-r--r--dev-python/inflection/inflection-0.3.1.ebuild38
-rw-r--r--dev-python/inflection/metadata.xml13
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/inflection/Manifest b/dev-python/inflection/Manifest
new file mode 100644
index 000000000000..574baba40a11
--- /dev/null
+++ b/dev-python/inflection/Manifest
@@ -0,0 +1,3 @@
+DIST inflection-0.3.1.tar.gz 12943 BLAKE2B cffaba9dc22444abda6cef04bc7dbd420abcdc0edca5c13bb734edd72aab631a2b50d3c37f9bd914cc8956f8afe951734db764bcced9e0837bfe75a90c527f73 SHA512 2a69a6228f2d44a5afecbd3ef51a51b4d5f63f69ddc844f4abfd6f326cb25c518403e8c5b9f98589885777d41d8fea31bacab3a5a3ab80db411960238d2f49ad
+EBUILD inflection-0.3.1.ebuild 875 BLAKE2B 974b235a9206a246c6010c965aaaf78461b124a38c66b9451abd5d915a89851e666fed3fc90bfb36866f9a6b145e194c370506a6f60aaef2b1db39f3816df295 SHA512 5ea377a59db55488dfe09107cc4dc9fbd7f42a96d9230143192747e4cc6284ff6932da7aa64e132fd850ff0c58204beda2285dc3ee2f4fcc01af3b306d1b7f19
+MISC metadata.xml 444 BLAKE2B 8127165e52bc2ba190021733ea594cf8da0bf3f2d878fdc191cda3354d2093c239cd5bd7fffc0c2bfe3055eff103da4bcafefc215576a28cb83e852aeb43cd57 SHA512 2175dadc52b8a381bfcbcd3a390d99f8582aba44870c29f5addf25880df9336d9bd16bd2120ad283359693fef2b0e65b7cae315fe17f042c17a512ea0352c352
diff --git a/dev-python/inflection/inflection-0.3.1.ebuild b/dev-python/inflection/inflection-0.3.1.ebuild
new file mode 100644
index 000000000000..16c59e49ccac
--- /dev/null
+++ b/dev-python/inflection/inflection-0.3.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="A port of Ruby on Rails' inflector to Python"
+HOMEPAGE="https://github.com/jpvanhal/inflection"
+# PyPI tarballs don't include doc
+# https://github.com/jpvanhal/inflection/pull/12
+SRC_URI="https://github.com/jpvanhal/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs docs/_build/html || die
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ py.test || die "Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/inflection/metadata.xml b/dev-python/inflection/metadata.xml
new file mode 100644
index 000000000000..569b904b3f4c
--- /dev/null
+++ b/dev-python/inflection/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sbraz@gentoo.org</email>
+ <name>Louis Sautier</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">inflection</remote-id>
+ <remote-id type="github">jpvanhal/inflection</remote-id>
+ <bugs-to>https://github.com/jpvanhal/inflection/issues</bugs-to>
+ </upstream>
+</pkgmetadata>