summaryrefslogtreecommitdiff
path: root/dev-python/iniparse
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-19 00:01:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-19 00:01:59 +0100
commit9d4810f84de876ec9d0ae03d0d44224500b41188 (patch)
tree1ca0866afdc949e405d20635d3d7f2115abb9ace /dev-python/iniparse
parent075fd1f8cabc5879c6eb42127fb84c3058677fde (diff)
gentoo auto-resync : 19:05:2024 - 00:01:59
Diffstat (limited to 'dev-python/iniparse')
-rw-r--r--dev-python/iniparse/Manifest3
-rw-r--r--dev-python/iniparse/files/iniparse-0.5_p20221102-py3.11.7.patch27
-rw-r--r--dev-python/iniparse/iniparse-0.5_p20221102.ebuild9
3 files changed, 36 insertions, 3 deletions
diff --git a/dev-python/iniparse/Manifest b/dev-python/iniparse/Manifest
index 15740a195a97..7745b89cf9c6 100644
--- a/dev-python/iniparse/Manifest
+++ b/dev-python/iniparse/Manifest
@@ -1,3 +1,4 @@
+AUX iniparse-0.5_p20221102-py3.11.7.patch 930 BLAKE2B e214e94d64e3177143c38d97bd6fdfa94c8708fba9f8a1de28b4237e5e53fc67b5578137b23976888e5d03134400526c33d89a289295cfc630a842d414121b18 SHA512 44821a9a064c28299a4ef30b37f84735317a716b0a2702f6b78991c56e0a7056cb92722c03bd882cc372b82f4e0a096f729cfcd1d5653ad1d324dfd82d80206e
DIST python-iniparse-ab623b0e287a9303bdb0c5213c485110e68dac12.tar.gz 33680 BLAKE2B 66ff134b1df28ae9c3e86110e7f8ad8dc0e24ed48f09db0c7554464e8d919aca49a7e43156c4acb8602af134c2f9d6c046d05cf1764f29285d8586329708a65a SHA512 57c43f7e0d28eab0e41bb819f7c06821d77f9bc5f3d0986f85dd4852b2edd468bb7b2737733e2f00faeac2e1211998d2e99b54ec92959eaf6d7d10897b176eaf
-EBUILD iniparse-0.5_p20221102.ebuild 853 BLAKE2B 68ab1239b654de5dc02f75a3e37b56e6ae659112cdf6c7e89acd5d89beb31f184dc4a56abe1467175c1981a45e9cc220fefb473514a5a2f5d47e7d3b3d93530d SHA512 e377adcf8bd9cd54c82cf26a81a2579bb85b2dbef10e4eb715c6dee5678f263ae558f643c1d2a6c69103c0fd15974bd22b4f9ca479c0c69b9df1d48f2f2ade31
+EBUILD iniparse-0.5_p20221102.ebuild 960 BLAKE2B e6fad58f8bf071f7908b34fae08f66a21322bc0993f4bb6b211227b38943b52d2807614ebc5f328bd8c44a16a43f2aa281d984a80e8ebd61fd9e069253f85b5a SHA512 8de778100ef8068a07cebe2774bbb1f86ec7c4bb2597ba68af562d7fc81b05f48edce380a788755ac34d518a71ca5d9f4b05d2bb5c90371aff06cc9b9ba5994f
MISC metadata.xml 401 BLAKE2B 6dad247b348f1fcf83bc9fc4cb14375004abd1e6c0bfb904925ab085ebd43876cab70dc8e0162ac881d6c16749266fc9fed4196ad9bb5aca0948a018f129f2a5 SHA512 5cc6e050fd3914dbb8206dd8b410b976f4aff0a75cec075554c27ff4af492517fef177663e532dc8a8ced6890710c6cbcc088163113e85d491d07d62812d1bee
diff --git a/dev-python/iniparse/files/iniparse-0.5_p20221102-py3.11.7.patch b/dev-python/iniparse/files/iniparse-0.5_p20221102-py3.11.7.patch
new file mode 100644
index 000000000000..e2c71c0fd582
--- /dev/null
+++ b/dev-python/iniparse/files/iniparse-0.5_p20221102-py3.11.7.patch
@@ -0,0 +1,27 @@
+From 033c0aa3e1a51cb70a97762252059e70cc2f671c Mon Sep 17 00:00:00 2001
+From: Daniel Garcia Moreno <daniel.garcia@suse.com>
+Date: Wed, 20 Dec 2023 12:40:14 +0100
+Subject: [PATCH] Fix tests with python 3.11.7
+
+---
+ tests/test_compat.py | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/tests/test_compat.py b/tests/test_compat.py
+index 8d7c785..86d0524 100644
+--- a/tests/test_compat.py
++++ b/tests/test_compat.py
+@@ -1,3 +1,4 @@
++import os
+ from iniparse import compat as ConfigParser
+ from io import StringIO
+ try:
+@@ -263,6 +264,8 @@ class mystr(str):
+
+ def test_read_returns_file_list(self):
+ file1 = test_support.findfile("cfgparser.1")
++ if not os.path.exists(file1):
++ file1 = test_support.findfile("configdata/cfgparser.1")
+ # check when we pass a mix of readable and non-readable files:
+ cf = self.newconfig()
+ parsed_files = cf.read([file1, "nonexistant-file"])
diff --git a/dev-python/iniparse/iniparse-0.5_p20221102.ebuild b/dev-python/iniparse/iniparse-0.5_p20221102.ebuild
index f6c69f6ad934..ed1508ff92c5 100644
--- a/dev-python/iniparse/iniparse-0.5_p20221102.ebuild
+++ b/dev-python/iniparse/iniparse-0.5_p20221102.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -33,8 +33,13 @@ BDEPEND="
${RDEPEND}
"
+PATCHES=(
+ # https://github.com/candlepin/python-iniparse/pull/29
+ "${FILESDIR}/${P}-py3.11.7.patch"
+)
+
python_test() {
- "${EPYTHON}" runtests.py || die
+ "${EPYTHON}" runtests.py -v || die
}
python_install_all() {