summaryrefslogtreecommitdiff
path: root/dev-python/inline-snapshot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-05 01:46:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-05 01:46:50 +0000
commit77d1bb6f8d47023aa21aaee830bf3229837233d1 (patch)
tree751b6c0d12ed0ed73cc1e3fbca7404072ba6cc7a /dev-python/inline-snapshot
parentd13006cca857323814c09f5123b87c1a005bba74 (diff)
gentoo auto-resync : 05:03:2025 - 01:46:50
Diffstat (limited to 'dev-python/inline-snapshot')
-rw-r--r--dev-python/inline-snapshot/Manifest2
-rw-r--r--dev-python/inline-snapshot/inline-snapshot-0.20.4.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/inline-snapshot/Manifest b/dev-python/inline-snapshot/Manifest
index 209438abe8dc..2bf2f703670c 100644
--- a/dev-python/inline-snapshot/Manifest
+++ b/dev-python/inline-snapshot/Manifest
@@ -1,5 +1,7 @@
DIST inline_snapshot-0.20.2.tar.gz 91060 BLAKE2B dc5dd87a809727f48a2bb376ffb602517c2acfad8ce8738d443f2dcf863b268b9ef1408771bdbfee6ccbb6d25ea3e8afdf2d690df021de196f30514a57ea0fb2 SHA512 e749efea54bdca1f399aa81335e65ab0e48887de6d4a9aa9905086886bdd44ef31eaf95c75edd5ee1e6ee011e31c450fb077d09f49415653e5c8e19a3ad4a944
DIST inline_snapshot-0.20.3.tar.gz 92067 BLAKE2B 594a6a5cda233f960492b5d076189111095a08b4653271713115b6a44cb84aa4a8f0d160ba1de60a0e6fa6f7b1dadcbef34d93d4c4b7e0ad6139552985637b9f SHA512 62484c27b0c08b10f2ce3648e975bab1b0563aa0bb1c471b7052cf94db266877ad21320f963003db9abdfc26a3987f0578052e129ef7448bdecbb3745247247e
+DIST inline_snapshot-0.20.4.tar.gz 92164 BLAKE2B 5c4b105e94304b4bd508ef3d714b84ce4d1b43eb79193551b17c09291c6f86dedcccd75167a5440e972fe4a656f114ea06e584a5a4690d73349ec5625df10414 SHA512 6296336ab569a3e9022ea32c1d8fafa61319f41fd17cb1ce0f9ce6e319998f58a57f423d31579b269bf06e414cb60f388dd06427e4f9b2037af241c68f3c7262
EBUILD inline-snapshot-0.20.2.ebuild 1748 BLAKE2B 1d61251bde5e6a515c6ce3a2901ff43aa5362f359cc4acbfc4da2efb961078e581aaa4d4243299ea3e71bf9e515c19d6f3e665e35ae7aabd001f449feef28c96 SHA512 734750ecfae215988bc6a5a8247253af3eb9fbe538d2c00243fdee8e9cae0696e43c8f35c456cc38fd3289aa815e98508aa45e3ea87dc93151cd870ce360735c
EBUILD inline-snapshot-0.20.3.ebuild 1710 BLAKE2B 40e4dfce9a18869ad55dd0955fbbcf19bf802b2521c4e38c66a1cb655c26fd33da71e5c8aa8b6e1f4f0bdc244b886ae2fc261533a5bcb3cbfcd5d85a441b109b SHA512 a189a0e106097c65ba77ebf51b13e80d969054ea7e78db1a123d537fa03c604c7c52390faa2fe5f57cfb2d3b3e44e9d1fb75d011b1b0107db3b709f6034b4800
+EBUILD inline-snapshot-0.20.4.ebuild 1710 BLAKE2B 40e4dfce9a18869ad55dd0955fbbcf19bf802b2521c4e38c66a1cb655c26fd33da71e5c8aa8b6e1f4f0bdc244b886ae2fc261533a5bcb3cbfcd5d85a441b109b SHA512 a189a0e106097c65ba77ebf51b13e80d969054ea7e78db1a123d537fa03c604c7c52390faa2fe5f57cfb2d3b3e44e9d1fb75d011b1b0107db3b709f6034b4800
MISC metadata.xml 384 BLAKE2B 37af14f95875416431210b572e9c5e96437d773cf53174dec247a9006ad24940f17ae9803a750dd2e1e73f63675f594b326f880bf7d5cb29ff09a8aae4959e60 SHA512 173bd013e023443c9dac349fab3deea6b5e9c2f054052d3362757cc0c46dd89309c509eb6a0f5a5774a7d8acbc55578b629039615a0cb31d74001a8d0db8b680
diff --git a/dev-python/inline-snapshot/inline-snapshot-0.20.4.ebuild b/dev-python/inline-snapshot/inline-snapshot-0.20.4.ebuild
new file mode 100644
index 000000000000..384e7bf42ea4
--- /dev/null
+++ b/dev-python/inline-snapshot/inline-snapshot-0.20.4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 2024-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 pypy3_11 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Create and update inline snapshots in your Python tests"
+HOMEPAGE="
+ https://15r10nk.github.io/inline-snapshot/
+ https://github.com/15r10nk/inline-snapshot/
+ https://pypi.org/project/inline-snapshot/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/asttokens-2.0.5[${PYTHON_USEDEP}]
+ >=dev-python/executing-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/rich-13.7.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ dev-python/attrs[${PYTHON_USEDEP}]
+ >=dev-python/black-23.3.0[${PYTHON_USEDEP}]
+ >=dev-python/dirty-equals-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-6.75.5[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/mypy[${PYTHON_USEDEP}]
+ ' 'python*')
+ >=dev-python/pydantic-2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-freezer-0.4.8[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.14.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-subtests-0.11.0[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires pyright
+ 'tests/test_typing.py::test_typing[pyright]'
+ # TODO
+ tests/test_formating.py::test_format_command_fail
+ )
+
+ local -x COLUMNS=80
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=inline_snapshot.pytest_plugin,pytest_freezer,pytest_subtests.plugin,xdist.plugin
+ local -x PYTHONPATH=${S}/src
+ epytest -p pytest_mock
+}