summaryrefslogtreecommitdiff
path: root/dev-python/inline-snapshot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-06 02:07:39 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-06 02:07:39 +0000
commitd285f0ab4ab38d4ea1cd0757a465db5f06764e06 (patch)
tree1fec673dcd26669902404a2986868912c5b41860 /dev-python/inline-snapshot
parenta6764d56b1c85c8272783500983011c143c72d80 (diff)
gentoo auto-resync : 06:12:2024 - 02:07:38
Diffstat (limited to 'dev-python/inline-snapshot')
-rw-r--r--dev-python/inline-snapshot/Manifest2
-rw-r--r--dev-python/inline-snapshot/inline-snapshot-0.14.1.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/inline-snapshot/Manifest b/dev-python/inline-snapshot/Manifest
index d6cd6948c019..d51a2ec8fc28 100644
--- a/dev-python/inline-snapshot/Manifest
+++ b/dev-python/inline-snapshot/Manifest
@@ -1,3 +1,5 @@
DIST inline_snapshot-0.14.0.tar.gz 209662 BLAKE2B 9bea11df88aab049af61146cb40c8afaa7607f8812c800ee7dffc7de94403029e4ae1d1ed49921f624e5327171650210744962559786e45586ae929830f81819 SHA512 32855dcd098c3e9b6a046752a3fc03c18b0df85e2cf338a928eadcd0e63bb784bdaca6855c954974ec7561e602ff3dd95ccdadb0c4f7dd1075d9d84245c171ef
+DIST inline_snapshot-0.14.1.tar.gz 220919 BLAKE2B 5bcd704ada3e31aad51fb22df3cfb8715580ded679b62205dd151b073428fffd6325b809b1aab4e5aa5d66cb7210b30e99189e72a0e031e98de6498465c5b22b SHA512 74462c7514861c1e1ac33da17b0dd61e77e76a37853fd765dde17233ccd36d11a8d184a9e7da6b855377e96968367ce5b30ca874cd209bb742fb1cdbdf2b0b54
EBUILD inline-snapshot-0.14.0.ebuild 1590 BLAKE2B f046f63ad309d440f36cd62d3d2dc711e60581645f6c8f17d1d82f4b1fc9a90108f5f92b49c04a78fb0184adf81a12588d464a6b27790d2c340081210a91ec7c SHA512 5af2fcc227fa2ffd01fa9bd2c3c9350a63fc809a559369c151c87ba08d447d0fd3f725ddd09997c468f52afa7d1269d88c7d3892bd45f65c0d5b440624776b0d
+EBUILD inline-snapshot-0.14.1.ebuild 1669 BLAKE2B 19dfd2e7526aef66a574fdac4fdcd147b53bb2f7de309dedeb688e82c18040c85523f86848f6b24aa724bf8aab39bafcc16a7fdd1a82fa9085c258fb944ed3c1 SHA512 6cfebd7bb105797a32410d2981ae8556fb86beaa5f24231397db67578b54fabafc204bd652b359149244f3f9b1f59d8be69ac14a14cb0a14c646b495a32cd810
MISC metadata.xml 384 BLAKE2B 37af14f95875416431210b572e9c5e96437d773cf53174dec247a9006ad24940f17ae9803a750dd2e1e73f63675f594b326f880bf7d5cb29ff09a8aae4959e60 SHA512 173bd013e023443c9dac349fab3deea6b5e9c2f054052d3362757cc0c46dd89309c509eb6a0f5a5774a7d8acbc55578b629039615a0cb31d74001a8d0db8b680
diff --git a/dev-python/inline-snapshot/inline-snapshot-0.14.1.ebuild b/dev-python/inline-snapshot/inline-snapshot-0.14.1.ebuild
new file mode 100644
index 000000000000..9be98a99ee7d
--- /dev/null
+++ b/dev-python/inline-snapshot/inline-snapshot-0.14.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Create and update inline snapshots in your Python tests"
+HOMEPAGE="
+ https://15r10nk.github.io/inline-snapshot/
+ https://github.com/15r10nk/inline-snapshot/
+ https://pypi.org/project/inline-snapshot/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/asttokens-2.0.5[${PYTHON_USEDEP}]
+ >=dev-python/black-23.3.0[${PYTHON_USEDEP}]
+ >=dev-python/click-8.1.4[${PYTHON_USEDEP}]
+ >=dev-python/executing-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/rich-13.7.1[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-python/dirty-equals-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-6.75.5[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/mypy[${PYTHON_USEDEP}]
+ ' 'python*')
+ dev-python/pydantic[${PYTHON_USEDEP}]
+ >=dev-python/pytest-freezer-0.4.8[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ >=dev-python/pytest-subtests-0.11.0[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires pyright
+ 'tests/test_typing.py::test_typing[pyright]'
+ )
+
+ local -x COLUMNS=80
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=inline_snapshot.pytest_plugin,pytest_freezer,pytest_subtests.plugin,xdist.plugin
+ local -x PYTHONPATH=${S}/src
+ epytest -p pytest_mock
+}