summaryrefslogtreecommitdiff
path: root/dev-python/installer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-07 21:14:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-07 21:14:14 +0000
commit6d44cd74809cea5f81bf52ff9cd0aa902d6b6866 (patch)
tree4045142b80c7e0479c627a84e3f0de03e574df19 /dev-python/installer
parent8615c518b1f1d03130f21656a1a026959bb1e9c9 (diff)
gentoo auto-resync : 07:12:2022 - 21:14:14
Diffstat (limited to 'dev-python/installer')
-rw-r--r--dev-python/installer/Manifest3
-rw-r--r--dev-python/installer/installer-0.6.0.ebuild42
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/installer/Manifest b/dev-python/installer/Manifest
index c6f5cbd1cfe7..12d0b2561ad3 100644
--- a/dev-python/installer/Manifest
+++ b/dev-python/installer/Manifest
@@ -1,4 +1,7 @@
DIST installer-0.5.1-py3-none-any.whl.zip 452220 BLAKE2B df2d2b351c3ca1e7d5991cebc77035bd8da980d0cd739b11532dac3e1fca4bcf58ebb746b4a3468978f765515ca22d3f777b279174715aaa2838231d4204028b SHA512 50f4778352393ad4d56ce5ccce2f5691df2114ef133b1a614e1c4ec2802261dd4de162fd359f47a51b4195b9b5594f5448591ee80356fd2ddb3221a2e602c797
DIST installer-0.5.1.gh.tar.gz 468433 BLAKE2B 5ba76eb2a576209c2bdf80adfcbd8ea22b55394652640085cf8dd39ded06a0a33ab75f3e4ff73d5de2db028b8c4dac652d631c94e2c9401a825ee75e7b143c01 SHA512 0320c1795c98a593b5da46775465e26bdf8736f59835970517cb02f2756030a3744b9385a9342e8062362d0769d585ff6cce504fdf105e99d27d6ba40281842b
+DIST installer-0.6.0-py3-none-any.whl.zip 452554 BLAKE2B 58a38d07256ed4fde3ab9495d47c117966155067fb6e903e2c1979272055b252e81f514cc67f5d0cda12e870f0a4f68f4c44bbfd6af38628e64726bdbcb17b50 SHA512 eca4f06e078c920085090a24c6083fceba2d52e433b21e1f2fb4d4e2e457f0dcca0e0307fb3239ab6018a92a3cb2e797499f050264ca2918bd268699357140b7
+DIST installer-0.6.0.gh.tar.gz 469015 BLAKE2B c7e297724a634377d312ef408627e40c8a8aa7f67824331b657d13aa2908df2a59b935d7774437aa56b4b41bc7418f6f2e575c1e0fb6b282a124cf0440f74b89 SHA512 0952bbf245359d6f660f98e59096ed3d57facb5bad0e9715fe525bd52f50cce198b481811d2ba4d204776f7ae9bec9c3431ae044d6ef9a8db8d873c170cf13fb
EBUILD installer-0.5.1-r1.ebuild 1091 BLAKE2B 20d2f49569f45f26933e3c0bd07b3c017dd5cb9ab55395e82fadd3afcb853b1c277e43452f35ca39d912da1a50266929998dcdb9f34d034ca505b5641986aa5a SHA512 165bfb0bc4a2ce516cb2035211a0e0ee211c005950d03fea1c62eaa54ccb22fdf566bd7dd4ef47b01e1b5edfcafc8a45a1cf2ad57861e4ac40fa5a5d5853536a
+EBUILD installer-0.6.0.ebuild 1099 BLAKE2B b3ccc637601c4f69868e0a5b48456ea57ada017fb8120e852603073654a2d91043925880105247d5ba310bf2a17a3c9f668ddb44e36fc08349e50ea97f48cc0a SHA512 897a68b9cdd2afb1d27165b01bad3e69e70367cf7ef38ac4371f983ea59e0c7dc7086f52806d3c12ce42fb93d258411469a8489e36e7f13fe3b2459948abad74
MISC metadata.xml 391 BLAKE2B 4dd6c80628cb652a95e1c779b87ccd3503197411b2bbd2bb64b964d57f6af4a60d5ef7f58b0c20a9842f9124e5c2129211a52dbdaa1192c98157de65aea64bd2 SHA512 2c2757ea4c6676a8282983f5b941d9ad6100228b0008bad2b216ade9f5489092c6337de3e43b4930e79c5fb548669eb337861a6cb7aec651986597202b4d1c6e
diff --git a/dev-python/installer/installer-0.6.0.ebuild b/dev-python/installer/installer-0.6.0.ebuild
new file mode 100644
index 000000000000..92f5a8fad5b8
--- /dev/null
+++ b/dev-python/installer/installer-0.6.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=no
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for installing Python wheels"
+HOMEPAGE="
+ https://pypi.org/project/installer/
+ https://github.com/pypa/installer/
+ https://installer.readthedocs.io/en/latest/
+"
+SRC_URI="
+ https://github.com/pypa/installer/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ https://files.pythonhosted.org/packages/py3/${PN::1}/${PN}/${P%_p*}-py3-none-any.whl
+ -> ${P%_p*}-py3-none-any.whl.zip
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+BDEPEND="
+ app-arch/unzip
+"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ python_domodule src/installer "${WORKDIR}"/*.dist-info
+}
+
+python_install() {
+ distutils-r1_python_install
+ python_optimize
+}