summaryrefslogtreecommitdiff
path: root/dev-python/installer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/installer
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/installer')
-rw-r--r--dev-python/installer/Manifest5
-rw-r--r--dev-python/installer/installer-0.5.1.ebuild44
-rw-r--r--dev-python/installer/metadata.xml2
3 files changed, 49 insertions, 2 deletions
diff --git a/dev-python/installer/Manifest b/dev-python/installer/Manifest
index a5778f8ff2f2..fe10f96ad8bb 100644
--- a/dev-python/installer/Manifest
+++ b/dev-python/installer/Manifest
@@ -1,4 +1,7 @@
DIST installer-0.5.0-py3-none-any.whl.zip 452177 BLAKE2B 41bb5929c1bc42afa1e09f366356aa441eb92d258da40421d7f46ceb466ee4604ed96fef0969dcd2fe28e8f4b06c741ac3108000f69ea42b6bb194890102ad71 SHA512 470c4fec8888114af6769db8b8cefa09a376bfcdf0d78320f884a7453a4991765cdf0b9122c74d8e147d193e75ab3e12cc24c3b93c0668956c17f52443833c4e
DIST installer-0.5.0.gh.tar.gz 468351 BLAKE2B 6c258bdaae3351e87a88675fb813bb70611d9188ba16a09ba03de4caa3d79fe32544e229f880338304d00343c2b3121b1948bbef2e27c7255d231a3d5665aa5f SHA512 8731bbf8a51b1094dc87f84575eec07a650988bdeddf205d04cf80a5088eac0d8b2927022864f4011a9562fcaae9f511747e5672f94ec3cce1dccdfa833c4fce
+DIST installer-0.5.1-py3-none-any.whl.zip 452220 BLAKE2B df2d2b351c3ca1e7d5991cebc77035bd8da980d0cd739b11532dac3e1fca4bcf58ebb746b4a3468978f765515ca22d3f777b279174715aaa2838231d4204028b SHA512 50f4778352393ad4d56ce5ccce2f5691df2114ef133b1a614e1c4ec2802261dd4de162fd359f47a51b4195b9b5594f5448591ee80356fd2ddb3221a2e602c797
+DIST installer-0.5.1.gh.tar.gz 468433 BLAKE2B 5ba76eb2a576209c2bdf80adfcbd8ea22b55394652640085cf8dd39ded06a0a33ab75f3e4ff73d5de2db028b8c4dac652d631c94e2c9401a825ee75e7b143c01 SHA512 0320c1795c98a593b5da46775465e26bdf8736f59835970517cb02f2756030a3744b9385a9342e8062362d0769d585ff6cce504fdf105e99d27d6ba40281842b
EBUILD installer-0.5.0.ebuild 1164 BLAKE2B 2056582c7f5133bd4dbf155dd9bb436f5d5a9fe83e930e2491e2384378836036073e9247b365e0461d09eb2294e0402fc7ae26ab1a4b25bf1c22f4fdcc157ea1 SHA512 2922dc55236b6012e2198797006a22a8b26e808ed429595a0fe8bb761cb0aeefd098a72bef0faa33e3e81acdf8722af838e3536ba1772abed87c176294f64baf
-MISC metadata.xml 396 BLAKE2B fafd8a4b677ddf2aac2df9ed3142829bd39eefd12fbdfdd1608a5ed2a299c86b18993440aa9941d609af9b4d34e9166a0464c2b9a06bde9ea08a4b91537b18bc SHA512 d9a031da54c07c60a8edca8df2c9fd1d2d7767e71038b70a0ff46da99005cda63af56cd54247e7eac716cf66cfc3a768edaa62a68c87983c7b5354ee6d8303f9
+EBUILD installer-0.5.1.ebuild 1169 BLAKE2B baad3111a1380f65e24669efca515b30b720eda532618b92a2719ec7dc30365a7bf8103c9acc4eb852efd22dea8461efb8833f57387e5a7dc41a5342f1194d19 SHA512 5fb1ff040cb7be51029385def654ea0946352deb21efa591cb3af68e2b97e4487c364a03ab5fb1b112197ac7c199fe266ec3e56efc209a5e8f541e7816d9898d
+MISC metadata.xml 391 BLAKE2B 4dd6c80628cb652a95e1c779b87ccd3503197411b2bbd2bb64b964d57f6af4a60d5ef7f58b0c20a9842f9124e5c2129211a52dbdaa1192c98157de65aea64bd2 SHA512 2c2757ea4c6676a8282983f5b941d9ad6100228b0008bad2b216ade9f5489092c6337de3e43b4930e79c5fb548669eb337861a6cb7aec651986597202b4d1c6e
diff --git a/dev-python/installer/installer-0.5.1.ebuild b/dev-python/installer/installer-0.5.1.ebuild
new file mode 100644
index 000000000000..ce5ec797e91d
--- /dev/null
+++ b/dev-python/installer/installer-0.5.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=manual
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="A library for installing Python wheels"
+HOMEPAGE="
+ https://pypi.org/project/installer/
+ https://github.com/pypa/installer/
+ https://installer.readthedocs.io/en/latest/
+"
+SRC_URI="
+ https://github.com/pypa/installer/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ https://files.pythonhosted.org/packages/py3/${PN::1}/${PN}/${P%_p*}-py3-none-any.whl
+ -> ${P%_p*}-py3-none-any.whl.zip
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+BDEPEND="
+ app-arch/unzip
+"
+
+distutils_enable_tests pytest
+
+# do not use any build system to avoid circular deps
+python_compile() { :; }
+
+python_test() {
+ local -x PYTHONPATH=src
+ epytest
+}
+
+python_install() {
+ python_domodule src/installer "${WORKDIR}"/*.dist-info
+}
diff --git a/dev-python/installer/metadata.xml b/dev-python/installer/metadata.xml
index 090fe7139f47..29211bd2819d 100644
--- a/dev-python/installer/metadata.xml
+++ b/dev-python/installer/metadata.xml
@@ -8,6 +8,6 @@
<stabilize-allarches/>
<upstream>
<remote-id type="pypi">installer</remote-id>
- <remote-id type="github">pradyunsg/installer</remote-id>
+ <remote-id type="github">pypa/installer</remote-id>
</upstream>
</pkgmetadata>