summaryrefslogtreecommitdiff
path: root/dev-python/ipdbplugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/ipdbplugin
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/ipdbplugin')
-rw-r--r--dev-python/ipdbplugin/Manifest6
-rw-r--r--dev-python/ipdbplugin/ipdbplugin-1.4.ebuild29
-rw-r--r--dev-python/ipdbplugin/ipdbplugin-9999.ebuild29
-rw-r--r--dev-python/ipdbplugin/metadata.xml10
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/ipdbplugin/Manifest b/dev-python/ipdbplugin/Manifest
new file mode 100644
index 000000000000..2015fd4d84f3
--- /dev/null
+++ b/dev-python/ipdbplugin/Manifest
@@ -0,0 +1,6 @@
+DIST ipdbplugin-1.4.tar.gz 2473 SHA256 4778d78b5d0af1a2a6d341aed9e72eb73b1df6b179e145b4845d3a209137029c SHA512 5831d1e9aceb2fe4db272975d4d792622822049813ba76bdc0ee48dee001339084efddf534882775922ec178c1bcd52954bc2df1ce42181cbfdd1c3c4b944365 WHIRLPOOL ebf61a52db5be766a8407a85d8af04667a0818b5e084f762759cc535df8611ff363017961278a8da1bbeaafdb1b5630bbff1ba83475b89cf7f1add683748a79d
+EBUILD ipdbplugin-1.4.ebuild 690 SHA256 baa93f492554342f7317c504500f57886a70e419553619359035aa33dfb26cf7 SHA512 e86522e67bb79235fc8f284c1d67d4667ae277bc8e81a98b3b9a8e238e9df755b76b2a9c0ff62079a11c4d05fae2f2d77aec65e84454f86fcec4494fdc302fa0 WHIRLPOOL ce383480624a1d7ffd8cc90abdd2d3b072f90e085bfb7bcb59a5aee7fb371af27323acad5e035c02b5ff4c61e6688d1ae41ba5704604661322b9c614d36ee802
+EBUILD ipdbplugin-9999.ebuild 690 SHA256 baa93f492554342f7317c504500f57886a70e419553619359035aa33dfb26cf7 SHA512 e86522e67bb79235fc8f284c1d67d4667ae277bc8e81a98b3b9a8e238e9df755b76b2a9c0ff62079a11c4d05fae2f2d77aec65e84454f86fcec4494fdc302fa0 WHIRLPOOL ce383480624a1d7ffd8cc90abdd2d3b072f90e085bfb7bcb59a5aee7fb371af27323acad5e035c02b5ff4c61e6688d1ae41ba5704604661322b9c614d36ee802
+MISC ChangeLog 2394 SHA256 0ee265cf196c20ad5315a83f66708c1e388e26af94434c2ff55ea437a3499d87 SHA512 842daf83b555a55c620dea95da3f7f43f595f54e0e4a45e5c96852f06fb9cb9049e8904f423a09354f800fb3aceb6a15085dc24356bd560d410e4c4e48b8d206 WHIRLPOOL 603ffc3ccd05fd39ecb311f52177f4d6b32119e9a29be642ff18bd536616ba6099a1142e12892b1585d894b57a54fa358e3c30ad1c169b10e934f7e73854c8ed
+MISC ChangeLog-2015 766 SHA256 29d49b7986daa2c67bc254cf07f6501f52928bce70e3a7a748079559e862b43f SHA512 45d843157ed097d9e53f193a7f788b096e4999abcec350e648c09bc71b663d48ab6f1f0fb1bd2c4dd7045b531b697206162fb2fd37bdfde7059deaef2ee7e551 WHIRLPOOL 55e608e535b41b6ae239fdea973b77cd6a95349bbfb4c335ed1d79e154f90a825fac07d8168bdd8a60a9ce2501f280e3e9d109ecc24a70312166938e0aedd360
+MISC metadata.xml 296 SHA256 382ebd4e36d7474dc339c2a71b5949f6e9388b58233bb89a44984f7c81c09a18 SHA512 c64bf334a8ee1242a8f26e916d2d1458b57aabe24890c1e79e2b7fef812a2a2f2ece2ec3d5795ce3838b9a0f27c16a2fa01aa36b12e7c8e69dc1ba2d9e409929 WHIRLPOOL e37dfeaeb6d6be776bfdf5e1f242d5814d3ad29b7b7f38efb5b07500c9a9a840bd63256f4dca0999eaf3152d63f0069c721317647f001da2105912c9c0c50aec
diff --git a/dev-python/ipdbplugin/ipdbplugin-1.4.ebuild b/dev-python/ipdbplugin/ipdbplugin-1.4.ebuild
new file mode 100644
index 000000000000..ecddbd26416e
--- /dev/null
+++ b/dev-python/ipdbplugin/ipdbplugin-1.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Nose plugin to use iPdb instead of Pdb when tests fail"
+HOMEPAGE="https://pypi.python.org/pypi/ipdbplugin"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/flavioamieiro/nose-ipdb.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/ipdb
+ dev-python/nose"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/ipdbplugin/ipdbplugin-9999.ebuild b/dev-python/ipdbplugin/ipdbplugin-9999.ebuild
new file mode 100644
index 000000000000..ecddbd26416e
--- /dev/null
+++ b/dev-python/ipdbplugin/ipdbplugin-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Nose plugin to use iPdb instead of Pdb when tests fail"
+HOMEPAGE="https://pypi.python.org/pypi/ipdbplugin"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/flavioamieiro/nose-ipdb.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/ipdb
+ dev-python/nose"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/ipdbplugin/metadata.xml b/dev-python/ipdbplugin/metadata.xml
new file mode 100644
index 000000000000..50b1d3e8f984
--- /dev/null
+++ b/dev-python/ipdbplugin/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>slis@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">ipdbplugin</remote-id>
+ </upstream>
+</pkgmetadata>