summaryrefslogtreecommitdiff
path: root/dev-python/ipy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-23 03:02:57 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-23 03:02:57 +0000
commit71dd9d29cdaf7cc0ecdb9ea37d128726a941c630 (patch)
tree4eccd905f575579fe47abb8a83bbdb44ceb8c929 /dev-python/ipy
parentc7a7ec40cf928d8fc6a8241aa208272c008c7b4d (diff)
gentoo auto-resync : 23:11:2024 - 03:02:56
Diffstat (limited to 'dev-python/ipy')
-rw-r--r--dev-python/ipy/Manifest3
-rw-r--r--dev-python/ipy/ipy-1.01-r1.ebuild37
-rw-r--r--dev-python/ipy/metadata.xml13
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/ipy/Manifest b/dev-python/ipy/Manifest
new file mode 100644
index 000000000000..5580a02dad8a
--- /dev/null
+++ b/dev-python/ipy/Manifest
@@ -0,0 +1,3 @@
+DIST IPy-1.01.tar.gz 33641 BLAKE2B 10d5ac5c3df00a562393ee762e9ad0f458ecf4745f894ab23e686b7112842adcbb3f25064c0010630745273fa72280ba5ef92a951d687d0f46f341acd6c041ad SHA512 f0983254523025a1819d543877d9651fb6a9e39dabd3b043488495f681b02e43b544a0121658a0430a418a1c39b360a59db1699af87a75a16a2bdc29fcb2b74c
+EBUILD ipy-1.01-r1.ebuild 830 BLAKE2B b435e95dcd6fccfea5d13924e713991d0260e4e9c81f92fc98c5374f1209a398fa1d768d9a0887e1f33d2b97f53ab156cc3b5052195722fa8a03ebb43d2cd796 SHA512 a65610b338d71b5f4916d2a266762433db2fd50e1f42388e07e26c8ba94e1f05ec7a2c7491b22760921f32d59bbf0ee44143e72f2d55b8bb7dafdf214196a75f
+MISC metadata.xml 404 BLAKE2B 9b453bad2b9cc6b6f7b6bca5bd69afbc1c8181f8250d5889b8a192f6a242e94b546b650d0ca05acd7668cee160642d519d2eaa3f3d8755ffa228b43efbd3a6a0 SHA512 fb2d4c33ea00c87f1106ebf2ea4150476c62acd544f9c94cf28d5113cd272179df4710595135f5edd26cded036977fb7253e77c83d34ae362bd4b35eebbe356c
diff --git a/dev-python/ipy/ipy-1.01-r1.ebuild b/dev-python/ipy/ipy-1.01-r1.ebuild
new file mode 100644
index 000000000000..31773ebcc797
--- /dev/null
+++ b/dev-python/ipy/ipy-1.01-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=IPy
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Class and tools for handling of IPv4 and IPv6 addresses and networks"
+HOMEPAGE="
+ https://github.com/autocracy/python-ipy/
+ https://pypi.org/project/IPy/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~mips ~ppc ~ppc64 ~sparc x86"
+IUSE="examples"
+
+python_test() {
+ "${EPYTHON}" test/test_IPy.py || die "Tests fail with ${EPYTHON}"
+ "${EPYTHON}" test_doc.py || die "Doctests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/ipy/metadata.xml b/dev-python/ipy/metadata.xml
new file mode 100644
index 000000000000..29540e39f370
--- /dev/null
+++ b/dev-python/ipy/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">IPy</remote-id>
+ <remote-id type="github">autocracy/python-ipy</remote-id>
+ </upstream>
+</pkgmetadata>