summaryrefslogtreecommitdiff
path: root/dev-python/ipykernel/ipykernel-4.6.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/ipykernel/ipykernel-4.6.1-r2.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/ipykernel/ipykernel-4.6.1-r2.ebuild')
-rw-r--r--dev-python/ipykernel/ipykernel-4.6.1-r2.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/ipykernel/ipykernel-4.6.1-r2.ebuild b/dev-python/ipykernel/ipykernel-4.6.1-r2.ebuild
deleted file mode 100644
index 0b67f85acfe5..000000000000
--- a/dev-python/ipykernel/ipykernel-4.6.1-r2.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="IPython Kernel for Jupyter"
-HOMEPAGE="https://github.com/ipython/ipykernel"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="
- >=dev-python/ipython-4.0.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '<dev-python/ipython-6[${PYTHON_USEDEP}]' 'python2*')
- dev-python/jupyter_client[${PYTHON_USEDEP}]
- >=dev-python/traitlets-4.1.0[${PYTHON_USEDEP}]
- >=www-servers/tornado-4.0[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/nose_warnings_filters[${PYTHON_USEDEP}]
- )
-"
-
-python_install() {
- distutils-r1_python_install
-
- # bug 628222, specify python 2 or 3.
- sed -e "s:python:${EPYTHON%.*}:" \
- -i "${ED}"usr/share/jupyter/kernels/${EPYTHON%.*}/kernel.json || die
-}
-
-python_test() {
- nosetests --verbose ipykernel || die
-}