summaryrefslogtreecommitdiff
path: root/dev-python/ipykernel
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-27 07:43:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-27 07:43:26 +0000
commitd4ce53f1e327bfbbc32e193e0f495b0e826c61e5 (patch)
treeeaee0038a45a76debf2097852b1fb076440f6cbf /dev-python/ipykernel
parenta2210d6624510ad5825191a26603b73bbc096b98 (diff)
gentoo auto-resync : 27:12:2023 - 07:43:26
Diffstat (limited to 'dev-python/ipykernel')
-rw-r--r--dev-python/ipykernel/Manifest2
-rw-r--r--dev-python/ipykernel/ipykernel-6.28.0.ebuild78
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/ipykernel/Manifest b/dev-python/ipykernel/Manifest
index b6ea3212472c..42c902cf7596 100644
--- a/dev-python/ipykernel/Manifest
+++ b/dev-python/ipykernel/Manifest
@@ -1,3 +1,5 @@
DIST ipykernel-6.27.1.tar.gz 157828 BLAKE2B d81c241d55a6b45098bd38805dd8db2dd10c13bd290102f96011fc134b54925218da03ee6bdddd2de137089017e157cd6806ce3884279d3bc00684a357b60c7a SHA512 c4ee96c934e66a1d27d680bb43adb88affb49e605310d4d619cd42b0a294d82ad7884a110998eb3004be4f010d847968694b4c8327efa26976062249895132c6
+DIST ipykernel-6.28.0.tar.gz 157701 BLAKE2B 61b5415e6209cc83ea5f97f7a485489c5338539e711abab0358006835f0cff3d4d3a51b797eaaf44ef4666b225a0b64b9d135b9607a42dcb7d43a9bb38e9155d SHA512 81efbaafc48ad22b54719eebe7564d9d386407272b6c9bad34a2685ec73e1f831a2753251a7ff47c337becad272a39311f15faa7dac331e53272f3ccc975a860
EBUILD ipykernel-6.27.1.ebuild 2280 BLAKE2B b29feaeef6a70361a1367f78bea2ead027faa479dbf7261cb21ac2bf12d997730a471cb5b7f31cecc3cca4fed77a882f57f8103a1c0e418e4941c51540c2b57e SHA512 3eb4ff78bef76b740b5b0c45ecee84626c3c68103594a8d2b4b6c6bd8cef87deb76edb8c3a8186a62904b878808e9b37d68ce7c281f76379a73c71276aa0b0dd
+EBUILD ipykernel-6.28.0.ebuild 2288 BLAKE2B 9de0dceafcb170b58ed3d503309b5fda19ceee25efb967301792c738168a41d59dec62bd9c068c85260df0ddde3341446c5097baeb31087c11f87771b7eeaa68 SHA512 75f6fef1182d849f2aff9e5b73378b976a330843fc1113aeaee3c9d48b586821d5754d92b8125376c5ee48b39abb756d6be34cc43177d4d6eed198a9cddde581
MISC metadata.xml 527 BLAKE2B 4a24cb9d5b801bf94c71c47d0c90b04bc249fb41a794c7b688a5762f08545d1fcfe9e4976aa4f583ecb456458b5f6dfc394349633959444584c0abad0da4be42 SHA512 ed9f0ef12ec5de67a646783243555f1737604a84c78c57b9f7c65137cec8cbc396991411501927f92bd393daad2238c27363ecc9c115031450231c2a4fb2cbb9
diff --git a/dev-python/ipykernel/ipykernel-6.28.0.ebuild b/dev-python/ipykernel/ipykernel-6.28.0.ebuild
new file mode 100644
index 000000000000..04db21f2cbc2
--- /dev/null
+++ b/dev-python/ipykernel/ipykernel-6.28.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi virtualx
+
+DESCRIPTION="IPython Kernel for Jupyter"
+HOMEPAGE="
+ https://github.com/ipython/ipykernel/
+ https://pypi.org/project/ipykernel/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/comm-0.1.1[${PYTHON_USEDEP}]
+ !elibc_Darwin? (
+ $(python_gen_cond_dep '
+ >=dev-python/debugpy-1.6.5[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+ >=dev-python/ipython-7.23.1[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-client-8[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-core-4.12[${PYTHON_USEDEP}]
+ >=dev-python/matplotlib-inline-0.1[${PYTHON_USEDEP}]
+ dev-python/nest-asyncio[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-24[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.1[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.4.0[${PYTHON_USEDEP}]
+"
+# RDEPEND seems specifically needed in BDEPEND, at least jupyter
+# bug #816486
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/ipyparallel[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ distutils-r1_python_compile
+ # Use python3 in kernel.json configuration, bug #784764
+ sed -i -e '/python3.[0-9]\+/s//python3/' \
+ "${BUILD_DIR}/install${EPREFIX}/usr/share/jupyter/kernels/python3/kernel.json" || die
+}
+
+src_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_debugger.py::test_attach_debug
+ tests/test_debugger.py::test_breakpoint_in_cell_with_leading_empty_lines
+ tests/test_debugger.py::test_rich_inspect_at_breakpoint
+ tests/test_debugger.py::test_rich_inspect_not_at_breakpoint
+ tests/test_debugger.py::test_set_breakpoints
+ tests/test_debugger.py::test_stop_on_breakpoint
+ tests/test_debugger.py::test_copy_to_globals
+ # hangs?
+ tests/test_eventloop.py::test_tk_loop
+ # doesn't like pyside2?
+ tests/test_eventloop.py::test_qt_enable_gui
+ )
+
+ virtx distutils-r1_src_test
+}