summaryrefslogtreecommitdiff
path: root/dev-python/ipyparallel
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-08 03:03:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-08 03:03:28 +0000
commit2cd9ff612e84f0c1ef63c9e9e13be53fe576cc2b (patch)
tree6e975e18646dac9f4b55fab980271a027428cc4d /dev-python/ipyparallel
parentabe17cf152eeb7571da8db4b25a30465644a41ba (diff)
gentoo auto-resync : 08:11:2024 - 03:03:27
Diffstat (limited to 'dev-python/ipyparallel')
-rw-r--r--dev-python/ipyparallel/Manifest2
-rw-r--r--dev-python/ipyparallel/ipyparallel-9.0.0.ebuild90
2 files changed, 92 insertions, 0 deletions
diff --git a/dev-python/ipyparallel/Manifest b/dev-python/ipyparallel/Manifest
index d99f73087193..54985595cc94 100644
--- a/dev-python/ipyparallel/Manifest
+++ b/dev-python/ipyparallel/Manifest
@@ -1,4 +1,6 @@
AUX ipyparallel-7.1.0-test-timeouts.patch 2067 BLAKE2B 577b33b730f110775dbd61fe02d06834fe3c4eb3c730d6df16730bbc877402e9f4756b74691bb977c3892ff981d374a4d1b439bf2b682e76c496ce8502f26583 SHA512 2d0f9fb4966be06299b40cd2ad974b4f94cfedea84fcee38b900ce4596b15cd3963068fc374aa1c0e54765b92d68c5233965fd2d3696bba5474da24917d1f009
DIST ipyparallel-8.8.0.tar.gz 6800541 BLAKE2B ae40aa60eec2c07bb1ecce696df9f8429293e1602bced8e6220e6a93b780b44131a4fcbd01c921952cae9945fc509f6084570b96ce0c3da7ce4f0cc1d853db1b SHA512 9b0a03e1f581acbe56e3b51331d9fb97c422469e1d93348e6403d7c95a985f1f5a2a390645222fc4b60c0027ba168933679662561adb618d19ae7d680a2bb680
+DIST ipyparallel-9.0.0.tar.gz 4403287 BLAKE2B 18248d6ee1eda409ff5de54ec7dbcdb75ac4a6dbd7af4fee23ec826d4c179e67454c980c6db00d180ddf078bd802a4b6f2e0245c63cf9bd55c99ead1bf1ba044 SHA512 4c89edba0bbad9ce75deaaa1e2486b1c50ca3f7a1a8f3c22b6dadc72f5b1f86958fe8c559e4548c69518494fd51c4ebe65f6019b154c8ffd3ef51eebb9bf1f03
EBUILD ipyparallel-8.8.0.ebuild 2499 BLAKE2B 9f5e023c80444f046c942493165525f54bb12ce02f832d513d2a6021214eefc8c78101312c014ed1f6a5530aced4fa5329381caf1a9f9d3c8d323da9961135ee SHA512 1078f9a37a0b0ae316f19470f3d261c3d096b02f981ad4a473b6a69eb1863066b6475458fc4423d29b7632ca43d018818a2da81a01e22fd8694388cfdc81f58f
+EBUILD ipyparallel-9.0.0.ebuild 2603 BLAKE2B 4afd88671138e4d57757ab13f1f29335b0d5131c4f13fe6149b9cfa578159639f74c8297f0cb506b4cb1c112bd88839cc5c2e7ba791bc5144e19bdd7e667e731 SHA512 da33d28a3ad66d1933a532a0fe68c1205c0ccfa6c7b4d12994f8b492b62489f0154cc36acbbde8767def27589244774d27b7a03a526f7f0d3ca56c97e3845370
MISC metadata.xml 531 BLAKE2B 92dd755dd3036f653f24eda893979487b8d5bbf3c369f3f10c3fc2e69ad6aef03cb6eca295bcb8c6f89f0838780c20132bfd2a33bb38b56b227e97258447c2e0 SHA512 fcd131d18b012d1511468777dd72e07ed28a514419923911082229c0256b9003d9afe2048b6c339cb5c94307026b52bc4e9b6781d45660178d18385d71af8f21
diff --git a/dev-python/ipyparallel/ipyparallel-9.0.0.ebuild b/dev-python/ipyparallel/ipyparallel-9.0.0.ebuild
new file mode 100644
index 000000000000..cce0734c3953
--- /dev/null
+++ b/dev-python/ipyparallel/ipyparallel-9.0.0.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Interactive Parallel Computing with IPython"
+HOMEPAGE="
+ https://ipyparallel.readthedocs.io/
+ https://github.com/ipython/ipyparallel/
+ https://pypi.org/project/ipyparallel/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/decorator[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-25[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5[${PYTHON_USEDEP}]
+ >=dev-python/ipython-5[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-client-7[${PYTHON_USEDEP}]
+ dev-python/jupyter-server[${PYTHON_USEDEP}]
+ >=dev-python/ipykernel-6.9.1[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/flit-core[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-tornado[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+"
+
+# TODO: package myst_parser
+# distutils_enable_sphinx docs/source
+distutils_enable_tests pytest
+
+src_configure() {
+ export IPP_DISABLE_JS=1
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # we don't run a mongo instance for tests
+ ipyparallel/tests/test_mongodb.py::TestMongoBackend
+ # TODO
+ ipyparallel/tests/test_util.py::test_disambiguate_ip
+ # Gets upset that a timeout _doesn't_ occur, presumably because
+ # we're cranking up too many test timeouts. Oh well.
+ # bug #823458#c3
+ ipyparallel/tests/test_asyncresult.py::AsyncResultTest::test_wait_for_send
+ # We could patch the timeout for these too but they're going to be inherently
+ # fragile anyway based on what they do.
+ ipyparallel/tests/test_client.py::TestClient::test_activate
+ ipyparallel/tests/test_client.py::TestClient::test_lazy_all_targets
+ ipyparallel/tests/test_client.py::TestClient::test_wait_for_engines
+ )
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # pure Python datetime incompatibility? TODO
+ ipyparallel/tests/test_asyncresult.py::TestAsyncResult::test_elapsed_multi
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio -p tornado
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ # move /usr/etc stuff to /etc
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}
+
+pkg_postinst() {
+ optfeature "Jupyter Notebook integration" dev-python/notebook
+}