summaryrefslogtreecommitdiff
path: root/dev-python/ipython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /dev-python/ipython
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'dev-python/ipython')
-rw-r--r--dev-python/ipython/Manifest2
-rw-r--r--dev-python/ipython/ipython-5.8.0.ebuild133
2 files changed, 135 insertions, 0 deletions
diff --git a/dev-python/ipython/Manifest b/dev-python/ipython/Manifest
index 93d85f242bfb..44e8a507e9c1 100644
--- a/dev-python/ipython/Manifest
+++ b/dev-python/ipython/Manifest
@@ -1,6 +1,8 @@
AUX 2.1.0-substitute-files.patch 1017 BLAKE2B 70577eb950a18345804a2a4b750bd233dc6a0b6bbdb524dfc66e0f4a7c69b0eeb2d35efb9d1845d567a11d1afa7881068b4757e42b9baf24dc01ba3026608a38 SHA512 fc4c9e12267ac5f04a2e16ad27334a093638538b8149ff380099fcbeb674a276ab9eb624a508010e37f82c05d5f7ab527a80e386b3e7b61c123ecb8effd9d542
DIST ipython-5.4.1.tar.gz 4973571 BLAKE2B bbda7b5a172ea1e80a9867f036ef68d1d0ec0a7340d77d8b4bbce63c5db7d3aade106ee5a6d59fb7e2b773c37d8263e51e1eaaa81d582849a70de60e93b7205a SHA512 b37dae27a558585ec4f42fa22e86380ac81990207ec680fc7b0e6f97ac81c99d915cfe77488bc0b91a61c34e0c00b323df08aa06b142ce0fc88ce30203102907
+DIST ipython-5.8.0.tar.gz 4977824 BLAKE2B cfa0592e8b71f82d996e6e961c3ac478617132f569799916a8794f1af733f3e40649fea763595b58dd8a10f31869d280338b81d15c3d059707a66ff7dab889f5 SHA512 946afb8f1623c8a7564ba2d782e05f5c961577dfb1e4a0f27e4a10e2932d5d041035c12aea7eb3e1d61af87867fab85a29919499822f93f638634bc343084b3e
DIST ipython-6.1.0.tar.gz 5066094 BLAKE2B 4f68776ba15f50b2f0fcc1503dd5c62ac464d9d0ace0801f572c9cdc1a0ddd7d840369a3df5940551c848376985cc74848002cef53869014adb2fd9714989acd SHA512 6b1d9713b5e8c3870ac8cd8bea9d3a6f0c0302e3983017516128ede9f0baba21372890873df29fbba3f9d2f47ba16bfadb1c611f9de23b71595c0ab8f917695b
EBUILD ipython-5.4.1-r1.ebuild 3663 BLAKE2B 776285cc3a7df3aa10b06c01a5b203a4032593f1857902d239bc7d78a15fb431588c36a3a2128789cbf47c747c1557aaf1f07ce9a1092427ec538e6be4f82945 SHA512 5f2c6c92683cd39ff85e09974d9992f24dd32b9a9651cfd56f7492a12155d251b21a3c3330f9766edf538968a211c6b924faf1dccb79b070a53847c71b3709f8
+EBUILD ipython-5.8.0.ebuild 3747 BLAKE2B cc6b62f3857ae210ae8f406c62129c05c2e460253dc6ed2aa92757860bbffd0b042cece5c7c0863d299bfe53e5cdc6430010904f4b6fe53d7a843f1eca60f55b SHA512 a846dabb6579144bcbaf14b48a6d14d101f8a3a58d005214cd9ea9c0abe6c42856be0aa7a90b5de9b24b1fd01e86a0c61909c7420185c121959ee550559bb216
EBUILD ipython-6.1.0-r1.ebuild 3396 BLAKE2B fb8641c29897a48e799601cf2509ca182835588de1e693393d7ee0a5063aa6ef717aef163ed23d0fba93d919eddc62526f6ecaabef252598809db0d1ab2a1384 SHA512 2de0470c9547819b58e7fbe5a8e030fe83b7a4c18923a711ffca048f37e9efe09b996d9794503b31cfb6e456e6337deb2dd8c1fe3040cc0d6ddec8541ad6e86a
MISC metadata.xml 2857 BLAKE2B 89f6ea04a550e2e590f9e041c435fe578691118e24265d0f3c2465480cb32cbf4f5ca4d6c8fb2a08a665061347e19e361160f73aea080b1f67a4c9c743f6c23c SHA512 6b28c7f0be77e23656df143940074658a71ea872ba12238d3dc206f25662ddd589e3ebee11d5ca06498cfbbc651ae0effc95235feed91e853616706c87ca5bc4
diff --git a/dev-python/ipython/ipython-5.8.0.ebuild b/dev-python/ipython/ipython-5.8.0.ebuild
new file mode 100644
index 000000000000..8f191191e87d
--- /dev/null
+++ b/dev-python/ipython/ipython-5.8.0.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE='readline,sqlite,threads(+)'
+
+inherit distutils-r1 eutils virtualx
+
+DESCRIPTION="Advanced interactive shell for Python"
+HOMEPAGE="http://ipython.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples matplotlib notebook nbconvert qt5 +smp test wxwidgets"
+RESTRICT="!test? ( test )"
+
+CDEPEND="
+ dev-python/decorator[${PYTHON_USEDEP}]
+ >=dev-python/jedi-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pickleshare[${PYTHON_USEDEP}]
+ >=dev-python/prompt_toolkit-1.0.4[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/simplegeneric[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.2.1[${PYTHON_USEDEP}]
+ matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP}] )
+ wxwidgets? ( $(python_gen_cond_dep 'dev-python/wxpython:*[${PYTHON_USEDEP}]' 'python2*') )
+"
+
+RDEPEND="${CDEPEND}
+ virtual/python-pathlib[${PYTHON_USEDEP}]
+ nbconvert? ( dev-python/nbconvert[${PYTHON_USEDEP}] )"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep \
+ 'dev-python/backports-shutil_get_terminal_size[${PYTHON_USEDEP}]' 'python2*')
+ virtual/python-typing[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+ doc? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-websupport[${PYTHON_USEDEP}]
+ )"
+
+PDEPEND="
+ notebook? (
+ dev-python/notebook[${PYTHON_USEDEP}]
+ dev-python/ipywidgets[${PYTHON_USEDEP}]
+ )
+ qt5? ( dev-python/qtconsole[${PYTHON_USEDEP}] )
+ smp? ( dev-python/ipyparallel[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}"/2.1.0-substitute-files.patch )
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ # Remove out of date insource files
+ rm IPython/extensions/cythonmagic.py || die
+ rm IPython/extensions/rmagic.py || die
+
+ # Prevent un-needed download during build
+ if use doc; then
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html_noapi
+ HTML_DOCS=( docs/build/html/. )
+ fi
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ distutils_install_for_testing
+ pushd "${TEST_DIR}" >/dev/null || die
+ "${TEST_DIR}"/scripts/iptest || die
+ popd >/dev/null || die
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ # Create ipythonX.Y symlinks.
+ # TODO:
+ # 1. do we want them for pypy? No. pypy has no numpy
+ # 2. handle it in the eclass instead (use _python_ln_rel).
+ # With pypy not an option the dosym becomes unconditional
+ dosym ../lib/python-exec/${EPYTHON}/ipython \
+ /usr/bin/ipython${EPYTHON#python}
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
+
+pkg_postinst() {
+ optfeature "sympyprinting" dev-python/sympy
+ optfeature "cythonmagic" dev-python/cython
+ optfeature "%lprun magic command" dev-python/line_profiler
+ optfeature "%mprun magic command" dev-python/memory_profiler
+
+ if use nbconvert; then
+ if ! has_version app-text/pandoc ; then
+ einfo "Node.js will be used to convert notebooks to other formats"
+ einfo "like HTML. Support for that is still experimental. If you"
+ einfo "encounter any problems, please use app-text/pandoc instead."
+ fi
+ fi
+}