summaryrefslogtreecommitdiff
path: root/dev-python/ipython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-13 12:26:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-13 12:26:41 +0100
commit482a48c0e1675b1e92663b8b5222bb7261aa7956 (patch)
treeb81e02db1810214fc690a762e3a9c687d0f0c5ab /dev-python/ipython
parent37bccfe5e76c5740c4ef5ba1179e9488d8404075 (diff)
gentoo auto-resync : 13:07:2024 - 12:26:41
Diffstat (limited to 'dev-python/ipython')
-rw-r--r--dev-python/ipython/Manifest2
-rw-r--r--dev-python/ipython/ipython-8.26.0.ebuild14
2 files changed, 12 insertions, 4 deletions
diff --git a/dev-python/ipython/Manifest b/dev-python/ipython/Manifest
index d3db0bf5d4f1..135508ed43f1 100644
--- a/dev-python/ipython/Manifest
+++ b/dev-python/ipython/Manifest
@@ -7,5 +7,5 @@ DIST ipython-8.26.0.tar.gz 5493422 BLAKE2B 2d05630d64d932190bf07c233e4241f5ce483
EBUILD ipython-8.24.0-r1.ebuild 5033 BLAKE2B 411304291881059c87351861c7158db7cd0212b7d30055a5569ba4cbb0880c42062444487626b3f8bbc4edc7b964e12369c8ece6314e0db309af9818943364a0 SHA512 37f45ec0d1093cb27c2f8cb48e61ab9accc1815f4be15a193090cde1e626b238255d73d8902efbbc04b0c42fe2552f3762401d12296b4c9061f9ab871aa019c4
EBUILD ipython-8.24.0.ebuild 4896 BLAKE2B d1bbab9880fe8d356f8d5c753c7f731ecd339272f769d025f7f6f1acc40b9776f612b6586334038ed86334fea8eb8a5f65d9245c9550644a79461f7731a71471 SHA512 aba6aa15e071dbd616f8ada72e0ba68424857b2fe58152e2697d920bfa77036804dda56155cd40bdf11a1aee6ecb29dc05cbc5f22e27d2a4af91a655e3de1e82
EBUILD ipython-8.25.0.ebuild 4239 BLAKE2B 343f5b0e5fd144064cb113717ecb9d070ca776e919e2adf90315fcf3a21b92acd2a4ec0aadb6dd7863da6cadb73eb9695af9f3ed21d59edfc9e19b3709c8ac12 SHA512 799bac0e034193a3be817973a2d469fb37eb3ab685bcfe12761b7d324e3ae8957517cac2ff20b807dc07b337e7a94529190cde82390e6c0e8b69ba3d275c04e4
-EBUILD ipython-8.26.0.ebuild 4286 BLAKE2B 6d4084ac2868b467be8eeefc6bb2b378f5f60dc6422f94650f16e6c5855439ca3e5e0532e45e3a5aaa30ca2461f073b14ff7a23dde142aebe1e08fdc8c0f4d80 SHA512 246a6d8bb6229c7ddc9edb6eb1b4aae4fbdcf6aac9605da4813676501b98083ebe0d56cdc1551da9dab42b865c29e57a0b64661a1d3ba78219a4e35ca3708ede
+EBUILD ipython-8.26.0.ebuild 4491 BLAKE2B 9a75adc5aeeee50a1cbd6315d7b7411b6cdc93fc3802798410449390d1c7f33028d329c9e78168dfb4b3b0104e0eda8952ff9ab01661443987683ee25735cdeb SHA512 a47fa818d2f346d00a3ad6c7373e595679094f0ce2ccfa2eb0073294eeb85b057aa2d52b3fe47e5a38982db48265086c07ea7a53971fbe25f75e8093b31e4183
MISC metadata.xml 2802 BLAKE2B 2fb6773ad4ef10d531f978e3ed40f6d99cf1586ec6d7cf2bf7e60fd5d640d082a0946651e0a066993320ffeaace3426066ca24c325926b62125ae91816707128 SHA512 965c3e36e05475d9454af8219b84e080d4c83d775f8a7e20a4951a82246d672c46fd3cb1fff5f8664d0ce8e8fcb846de6f15abc4575db3a6b7d87209194bcecc
diff --git a/dev-python/ipython/ipython-8.26.0.ebuild b/dev-python/ipython/ipython-8.26.0.ebuild
index c5cb7a5fe775..b492448b16c1 100644
--- a/dev-python/ipython/ipython-8.26.0.ebuild
+++ b/dev-python/ipython/ipython-8.26.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=standalone
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
PYTHON_REQ_USE='readline(+),sqlite,threads(+)'
inherit distutils-r1 optfeature pypi virtualx
@@ -66,13 +66,15 @@ RDEPEND+="
"
PDEPEND="
$(python_gen_cond_dep '
+ qt5? ( dev-python/qtconsole[${PYTHON_USEDEP}] )
+ ' 'python*')
+ $(python_gen_cond_dep '
notebook? (
dev-python/notebook[${PYTHON_USEDEP}]
dev-python/ipywidgets[${PYTHON_USEDEP}]
dev-python/widgetsnbextension[${PYTHON_USEDEP}]
)
- qt5? ( dev-python/qtconsole[${PYTHON_USEDEP}] )
- ' 'python*')
+ ' 3.{10..12})
smp? (
>=dev-python/ipykernel-5.1.0[${PYTHON_USEDEP}]
>=dev-python/ipyparallel-6.2.3[${PYTHON_USEDEP}]
@@ -107,6 +109,12 @@ python_test() {
IPython/lib/tests/test_display.py::TestAudioDataWithoutNumpy
)
;;
+ python3.13)
+ EPYTEST_DESELECT+=(
+ # docstring mismatch?
+ IPython/core/tests/test_debugger.py::IPython.core.tests.test_debugger.test_ipdb_magics
+ )
+ ;;
esac
# nonfatal implied by virtx