summaryrefslogtreecommitdiff
path: root/dev-python/ipython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-20 06:30:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-20 06:30:59 +0000
commit9097a9c06c0b1e11c7f6579f03e3f32948be3f24 (patch)
treeb5f3d3e52bf13944a9db9e3b33ab3e5cabed496e /dev-python/ipython
parentf8bb2d659372d0add11c589dcb006d0b7f8822ae (diff)
gentoo auto-resync : 20:12:2024 - 06:30:59
Diffstat (limited to 'dev-python/ipython')
-rw-r--r--dev-python/ipython/Manifest3
-rw-r--r--dev-python/ipython/files/ipython-8.30.0-python3.13-debugger-pdb-curframe.patch30
-rw-r--r--dev-python/ipython/ipython-8.30.0-r1.ebuild (renamed from dev-python/ipython/ipython-8.30.0.ebuild)2
3 files changed, 34 insertions, 1 deletions
diff --git a/dev-python/ipython/Manifest b/dev-python/ipython/Manifest
index 97e96cd480ee..b8edf0912131 100644
--- a/dev-python/ipython/Manifest
+++ b/dev-python/ipython/Manifest
@@ -1,3 +1,4 @@
+AUX ipython-8.30.0-python3.13-debugger-pdb-curframe.patch 1380 BLAKE2B 7f31588b848719fe44fc4356f368a84b65d8333fc46af269110592af1dd5765fa940070c89c37ff410607db7111f2dadcdd360499667a42da2d918d480ae7340 SHA512 5a6d99e8213af5eaffb0667567f68aa60f35291c6d502584ceff2fd32b58d681ea3d4c766ed35c747a1de8bcc8827b04fb97de3ca13d93f2dea3136aa3af70cf
DIST ipython-8.30.0.tar.gz 5592205 BLAKE2B e935305ce08ba287bb811a3efe7ae88821485f726c4c45815f4c39c1a51bb59ab439d256fbb91ddd71d12512fb58c913e4120663d6035b4644da67b3eee9b91c SHA512 36432ed736ce06f47b3ccb6172e6c03a15bfa51a2e38b80d5b579687abad0c03181684b218750f320b185fe3f96baf159eb9c9184c40ddfca78fdd9683233a9b
-EBUILD ipython-8.30.0.ebuild 4477 BLAKE2B c7a4c98aaf5fc6772a48b9595938eedd71eb556db714f18687e004b248a2e001f5ec7193bfb5e55bd053aee1c362b22dc657cc2cd35b3a01668a5f0aeb7a020d SHA512 0fd135542966e2764d42040f6cae40b973c9612a09fe00c94c68c3bc7eff19011b51e6cb01bce313b680c02fc1a8da75fc7a1700f28588806f650d79dc54c893
+EBUILD ipython-8.30.0-r1.ebuild 4562 BLAKE2B 5539d8d30a6aa356b440c9e501fab1b9720d486b1a76a396ba25b7f395d4196bcab187c2316b245c907ba5e18fc7b871a006a81cef35c4db289af409c71bc884 SHA512 9c0c899132f931a90c5b169c46f67ec11c1ab1ceecd6dd4345dcfaf19e058c1e9a9c8e20e181a2b67a50e913ef366d73dafb2b939401a8f549f8eaad42f275f4
MISC metadata.xml 2802 BLAKE2B 2fb6773ad4ef10d531f978e3ed40f6d99cf1586ec6d7cf2bf7e60fd5d640d082a0946651e0a066993320ffeaace3426066ca24c325926b62125ae91816707128 SHA512 965c3e36e05475d9454af8219b84e080d4c83d775f8a7e20a4951a82246d672c46fd3cb1fff5f8664d0ce8e8fcb846de6f15abc4575db3a6b7d87209194bcecc
diff --git a/dev-python/ipython/files/ipython-8.30.0-python3.13-debugger-pdb-curframe.patch b/dev-python/ipython/files/ipython-8.30.0-python3.13-debugger-pdb-curframe.patch
new file mode 100644
index 000000000000..8e44fd3d0261
--- /dev/null
+++ b/dev-python/ipython/files/ipython-8.30.0-python3.13-debugger-pdb-curframe.patch
@@ -0,0 +1,30 @@
+FAILED IPython/core/tests/test_run.py::TestMagicRunPass::test_run_debug_twice - AttributeError: 'Pdb' object has no attribute 'curframe'. Did you mean: 'botframe'?
+FAILED IPython/core/tests/test_run.py::TestMagicRunPass::test_run_debug_twice_with_breakpoint - AttributeError: 'Pdb' object has no attribute 'curframe'. Did you mean: 'botframe'?
+https://bugs.gentoo.org/946568
+https://github.com/ipython/ipython/pull/14598
+https://github.com/ipython/ipython/commit/c1e945b5bc8fb673109cf32c4f238f6d5e0f5149.patch
+
+From c1e945b5bc8fb673109cf32c4f238f6d5e0f5149 Mon Sep 17 00:00:00 2001
+From: M Bussonnier <bussonniermatthias@gmail.com>
+Date: Sun, 8 Dec 2024 11:37:11 +0100
+Subject: [PATCH] Fix pdb issues in Python 3.13.1
+
+For some reason it is not always set, it was/is a bug in IPython to not
+check.
+---
+ IPython/core/debugger.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/IPython/core/debugger.py b/IPython/core/debugger.py
+index 1f0d7b2fba..76c42e0230 100644
+--- a/IPython/core/debugger.py
++++ b/IPython/core/debugger.py
+@@ -550,7 +550,7 @@ def _get_frame_locals(self, frame):
+ So if frame is self.current_frame we instead return self.curframe_locals
+
+ """
+- if frame is self.curframe:
++ if frame is getattr(self, "curframe", None):
+ return self.curframe_locals
+ else:
+ return frame.f_locals
diff --git a/dev-python/ipython/ipython-8.30.0.ebuild b/dev-python/ipython/ipython-8.30.0-r1.ebuild
index b67d14eb4763..8cae90959a59 100644
--- a/dev-python/ipython/ipython-8.30.0.ebuild
+++ b/dev-python/ipython/ipython-8.30.0-r1.ebuild
@@ -81,6 +81,8 @@ PDEPEND="
)
"
+PATCHES=( "${FILESDIR}"/${P}-python3.13-debugger-pdb-curframe.patch ) # bug #946568
+
python_prepare_all() {
# Rename the test directory to reduce sys.path pollution
# https://github.com/ipython/ipython/issues/12892