summaryrefslogtreecommitdiff
path: root/dev-python/ipython
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-07 11:18:59 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-07 11:18:59 +0100
commita2810985afabcc31d3eace5e61d8ea25b852ba17 (patch)
treed254e77a7aeadd875db2dc73532da78094238ffd /dev-python/ipython
parenteab5731cdf11d4ae8cdf111461d46fd96c5bdd37 (diff)
gentoo resync : 07.05.2019
Diffstat (limited to 'dev-python/ipython')
-rw-r--r--dev-python/ipython/Manifest2
-rw-r--r--dev-python/ipython/ipython-7.5.0.ebuild30
2 files changed, 8 insertions, 24 deletions
diff --git a/dev-python/ipython/Manifest b/dev-python/ipython/Manifest
index 5787383edd84..214f7750fb79 100644
--- a/dev-python/ipython/Manifest
+++ b/dev-python/ipython/Manifest
@@ -4,5 +4,5 @@ DIST ipython-5.8.0.tar.gz 4977824 BLAKE2B cfa0592e8b71f82d996e6e961c3ac478617132
DIST ipython-7.5.0.tar.gz 5118610 BLAKE2B 3f89babc292ea55724c2333076a673ef7fcd0a7a468e972a50c962194a71a0bc3cc9bdea4f96db4c21fe475b4d79dc87c124bcde53e1bc3ae7066a3c0c136e0d SHA512 564027879e53b3716ebe8cb1ed4b516835c15f326c865fd664aa7a4e5f26e1a78a329ff8e19d4acf6249e2acf7382501114cd2258c38bba89f0f382f7dcda09b
EBUILD ipython-5.4.1-r2.ebuild 3708 BLAKE2B ca51fda923be3b4165303f6828b786f1b30403a9333ef47a56184eaa5d2ba175050247e2c8cbc8a68793642e3f60afe9927141722e6d0e84c7b46399c3f52d1c SHA512 fd3b5f5bb71a40960725e467fa69de0671d14d4f946d2acd272fe140da9bede8499454a6b932760f334c89a86ac06bab28e8feeb5eae892fbaab6981ca4c8aba
EBUILD ipython-5.8.0-r1.ebuild 3792 BLAKE2B bf4657c93f27d988da7af429cb7eede7d7e0e6717d358bfebcf3f8ae01b0b16ac9d55e8c0718478cc49153c604a32d652461f942262554eb183bb329aaca86d2 SHA512 0c0ce13cc6e73182d631ff29fa93803e8a5152b1ef44fbf6f50b38ded551944ce7c9c14f45a73ccd7b8dfe2136947cbd0f37f68aa6eba9880341bdca78836461
-EBUILD ipython-7.5.0.ebuild 4674 BLAKE2B 699809fee7070140e17c0bc04aaa01a0b73ea66589d1607e6aa7bcc3fea2f07da2031a34e34540f5a2295bc487ecfc8cd2410675cefa9a1df80bb9920e04c504 SHA512 5f5df0e61b71f0bca5632181cdea5d9fee26f7c98f455153a0bbd7ea8fb11dbcc36a657bfc7da29f55f57faf48f6fd37c48d63f7beefd7de14ed27b2b3853ef1
+EBUILD ipython-7.5.0.ebuild 3539 BLAKE2B db87c7f6eeffc4e8692451ff57d05874e5c754fb7006ee173365ca7c36ede16d220220b30fce0d4e84fb7b9ee7881a218228468cc95e42949553c0d259fa89a4 SHA512 c20b5dee2b8a1f8ad18fc58263e1a97fe86475f9babf3f7f65cafba1a5c086802c0a3b5a543c3d33c250919b263adb14cd5d1c82f84a385873190b67b2b6ec31
MISC metadata.xml 2857 BLAKE2B 89f6ea04a550e2e590f9e041c435fe578691118e24265d0f3c2465480cb32cbf4f5ca4d6c8fb2a08a665061347e19e361160f73aea080b1f67a4c9c743f6c23c SHA512 6b28c7f0be77e23656df143940074658a71ea872ba12238d3dc206f25662ddd589e3ebee11d5ca06498cfbbc651ae0effc95235feed91e853616706c87ca5bc4
diff --git a/dev-python/ipython/ipython-7.5.0.ebuild b/dev-python/ipython/ipython-7.5.0.ebuild
index 2a20f1205ac3..75c58af6c00d 100644
--- a/dev-python/ipython/ipython-7.5.0.ebuild
+++ b/dev-python/ipython/ipython-7.5.0.ebuild
@@ -18,21 +18,6 @@ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc examples matplotlib notebook nbconvert qt5 +smp test"
RESTRICT="!test? ( test )"
-# About "-python_targets_python2_7":
-# The ipython stack is in a tricky transition to py3-only. It has many circular
-# dependencies which causes a chicken-and-egg problem because for Portage to
-# properly handle dependency resolution on a system with
-# python_targets_python2_7 all members of the circular dependency must go
-# py3-only at the same time. If they don't, the dependency that requires py2
-# will seek older ipython releases for resolution. This is why, for members
-# of the circular dependency, we force -python_targets_python2_7. This way, the
-# circle stays firmly in py3-only land. This only affects members of the
-# circular dependency. Other dependencies can be on py2 without problem.
-#
-# This situation also require us to explicitly depend on transitive dependencies
-# that are part of the circular dependecy so that we preserve "circle
-# integrity". It's a bit ugly, but temporary.
-
CDEPEND="
dev-python/backcall[${PYTHON_USEDEP}]
dev-python/decorator[${PYTHON_USEDEP}]
@@ -43,17 +28,17 @@ CDEPEND="
<dev-python/prompt_toolkit-2.1[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
dev-python/traitlets[${PYTHON_USEDEP}]
- matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP},-python_targets_python2_7] )
+ matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP}] )
"
RDEPEND="${CDEPEND}
- nbconvert? ( dev-python/nbconvert[${PYTHON_USEDEP},-python_targets_python2_7] )"
+ nbconvert? ( dev-python/nbconvert[${PYTHON_USEDEP}] )"
DEPEND="${CDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
>=dev-python/ipykernel-5.1.0[${PYTHON_USEDEP}]
- dev-python/nbformat[${PYTHON_USEDEP},-python_targets_python2_7]
+ dev-python/nbformat[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
@@ -66,15 +51,14 @@ DEPEND="${CDEPEND}
PDEPEND="
notebook? (
- dev-python/notebook[${PYTHON_USEDEP},-python_targets_python2_7]
- >=dev-python/ipykernel-5.1.0[${PYTHON_USEDEP}]
- dev-python/ipywidgets[${PYTHON_USEDEP},-python_targets_python2_7]
- dev-python/widgetsnbextension[${PYTHON_USEDEP},-python_targets_python2_7]
+ dev-python/notebook[${PYTHON_USEDEP}]
+ dev-python/ipywidgets[${PYTHON_USEDEP}]
+ dev-python/widgetsnbextension[${PYTHON_USEDEP}]
)
qt5? ( dev-python/qtconsole[${PYTHON_USEDEP}] )
smp? (
>=dev-python/ipykernel-5.1.0[${PYTHON_USEDEP}]
- >=dev-python/ipyparallel-6.2.3[${PYTHON_USEDEP},-python_targets_python2_7]
+ >=dev-python/ipyparallel-6.2.3[${PYTHON_USEDEP}]
)"
PATCHES=( "${FILESDIR}"/2.1.0-substitute-files.patch )