summaryrefslogtreecommitdiff
path: root/dev-python/ipywidgets
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-04-11 08:43:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2025-04-11 08:43:59 +0100
commitbb59556b3302a941db4630613c604644d5f7a617 (patch)
tree42e60b7ae227b0fe3af52dfac08d59653066a2db /dev-python/ipywidgets
parent3cd09a18bad26aad2645241b868755cfdf41b6ae (diff)
gentoo auto-resync : 11:04:2025 - 08:43:58HEADmaster
Diffstat (limited to 'dev-python/ipywidgets')
-rw-r--r--dev-python/ipywidgets/Manifest2
-rw-r--r--dev-python/ipywidgets/ipywidgets-8.1.6.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/ipywidgets/Manifest b/dev-python/ipywidgets/Manifest
index 4892ef20d0bf..8190e00613af 100644
--- a/dev-python/ipywidgets/Manifest
+++ b/dev-python/ipywidgets/Manifest
@@ -1,3 +1,5 @@
DIST ipywidgets-8.1.5.tar.gz 116723 BLAKE2B fb616c368e75efd6a88dc1c586f16a33a0a725193e0765b0b0ec4a24764b1e8eb33e85b439a33716806e6eda4038674be8059f450695c87a88c5283d425d80b6 SHA512 b4030cc511f759db75417139575f85a797588fe48e17e7ac7debe7bff3f62ebe14dca86a21599be52b7cc6622fe7bb8e8a3dc41d0fffcabe7f77f15735cd5629
+DIST ipywidgets-8.1.6.tar.gz 116764 BLAKE2B 74e3b82cfdbeec3da00acf1fc55f4351975f431e7b62fabaa9871d9240880aec77c28e67d79cc17ca01e3f979ee6a7a4be1f1fe22be4a5d72c8d118af8e43ce5 SHA512 4997cf17a99dad022e3f625a1392db3f6edd82e829c0aa6eeb140a8554f8ba5e53a6ba745d70a117ab25577a085d3fe103b4cec022a24618b862b89e508ebe71
EBUILD ipywidgets-8.1.5.ebuild 1306 BLAKE2B 14e968b344130670a07829fbdd7b9eab8322bc118ac6cddc5e8cda5496f41347dd183b34e0a62f1bb9dbab0514ea02f35dc8d93f399b91b0d24571d3e4a48f0d SHA512 9974951edb03870c4b0a3fa9c317ad588d9f385b35119c33b3b50b78a99f9eaaa5a70bde561f372f2f72861451f24f09c815f8aaf55cf5470512e3151a4846c9
+EBUILD ipywidgets-8.1.6.ebuild 1311 BLAKE2B e7c0e469cae906f7e111546b01f9f15525371df55650a7af0b269ef3d6ece40637deaa43692cbaa22564269d766035eb0de95fb08c697231f692c91337f24dc1 SHA512 84c2515e6c93f640902726a2ef4d07ba105bfeef3ed5f30ab2a143df3089f63fcd2f474bddddc7e65b601e5bcaf6007bd14d9d7a6bb50df756ddd9a025c90b65
MISC metadata.xml 537 BLAKE2B 1f3b91be328b958870a72b5ce438c3e5bf67efd072b59dcb5ae77a9b89334e726af4fe8771221a7b728905cef4175cf7e0a49b11c651a7c0520b5cb032085985 SHA512 cb8092ea7a06e309a26abb78f5ddfd4a91f416e15374d2b59fb5086a64cc13f3dd408e18caa6719d12b1f18f762469a72a1027b2a047db626c51d22a5f304e54
diff --git a/dev-python/ipywidgets/ipywidgets-8.1.6.ebuild b/dev-python/ipywidgets/ipywidgets-8.1.6.ebuild
new file mode 100644
index 000000000000..5e1aeb52b59f
--- /dev/null
+++ b/dev-python/ipywidgets/ipywidgets-8.1.6.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 pypy3_11 python3_{10..13} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="IPython HTML widgets for Jupyter"
+HOMEPAGE="
+ https://ipywidgets.readthedocs.io/
+ https://github.com/jupyter-widgets/ipywidgets/
+ https://pypi.org/project/ipywidgets/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/comm-0.1.3[${PYTHON_USEDEP}]
+ >=dev-python/ipython-genutils-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/widgetsnbextension-4.0.14[${PYTHON_USEDEP}]
+ >=dev-python/jupyterlab-widgets-3.0.14[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND="
+ >=dev-python/ipython-6.1.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+
+ case ${EPYTHON} in
+ pypy3*)
+ EPYTEST_DESELECT+=(
+ # https://github.com/pypy/pypy/issues/4892
+ ipywidgets/widgets/tests/test_interaction.py::test_interact_noinspect
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}