summaryrefslogtreecommitdiff
path: root/dev-python/ipywidgets
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/ipywidgets
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/ipywidgets')
-rw-r--r--dev-python/ipywidgets/Manifest3
-rw-r--r--dev-python/ipywidgets/ipywidgets-7.0.0.ebuild36
-rw-r--r--dev-python/ipywidgets/metadata.xml15
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/ipywidgets/Manifest b/dev-python/ipywidgets/Manifest
new file mode 100644
index 000000000000..0142fa3a893b
--- /dev/null
+++ b/dev-python/ipywidgets/Manifest
@@ -0,0 +1,3 @@
+DIST ipywidgets-7.0.0.tar.gz 1006851 BLAKE2B 2ee86d0459b6c88b351994dcb4385d31378235a0be157387d90a476e49958bde25df941aa92068266df377c75dac13925d15ba2f8da0987d70adca3e726fa1a7 SHA512 39219478c12f26a2bab0e975b6fb53a7f9ee92b10fa05bd885b21c7c981a4402ad65f497223a4a2c30a7d6d18bb56bec715a20659926075f2e3730e72022ade6
+EBUILD ipywidgets-7.0.0.ebuild 922 BLAKE2B 969e60264bbccf53c4938c14fb968b39e0ac717fd82d844c14b0fb0a6935a4f3ca2fca6a5765f8c23374476696f284ed2103340d361b94add8ee10436ecb2ec0 SHA512 7e885fe4844671d12606ff3cc52d9560bb168e3aae2d07db1275070cb5e37e8210166dc3f4371fe144c25fefea634d5e7ac1ed8e7a2dab9086c9290205e4a39b
+MISC metadata.xml 520 BLAKE2B f8892f1fa8cc869c859fddedb9aa976d5a564586d23d30b758301810ab21bab4b28067c7411de000ee16312b3c12d16ef9fcd927c42601cf4d4560dbcc242cb9 SHA512 2072af0fb3f92af2e73edc7d2e69b9773325ce5c1bb8046496fbeb4908789ad2896126c78c5bbccc475e57cd78385ea15c03e4c4318325912cb23babff45b10c
diff --git a/dev-python/ipywidgets/ipywidgets-7.0.0.ebuild b/dev-python/ipywidgets/ipywidgets-7.0.0.ebuild
new file mode 100644
index 000000000000..108a75b21277
--- /dev/null
+++ b/dev-python/ipywidgets/ipywidgets-7.0.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="IPython HTML widgets for Jupyter"
+HOMEPAGE="https://ipywidgets.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/ipykernel-4.5.1[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-4.2.0[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/widgetsnbextension-3.0.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' 'python2*')
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ nosetests --with-coverage --cover-package=ipywidgets ipywidgets || die
+}
diff --git a/dev-python/ipywidgets/metadata.xml b/dev-python/ipywidgets/metadata.xml
new file mode 100644
index 000000000000..26b1e54ce025
--- /dev/null
+++ b/dev-python/ipywidgets/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription>
+ Interactive HTML widgets for Jupyter notebooks and the IPython kernel.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">ipywidgets</remote-id>
+ <remote-id type="github">jupyter-widgets/ipywidgets</remote-id>
+ </upstream>
+</pkgmetadata>