summaryrefslogtreecommitdiff
path: root/dev-python/isort
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-10 11:20:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-10 11:20:21 +0000
commit92e45d8c110d3b9403a141d225037f2c8ed90450 (patch)
tree550e556281d9240286506408de04a62012fd3c5e /dev-python/isort
parent8b5117492cefbaa1f87e1d83af097fd82c768674 (diff)
gentoo auto-resync : 10:12:2023 - 11:20:21
Diffstat (limited to 'dev-python/isort')
-rw-r--r--dev-python/isort/Manifest2
-rw-r--r--dev-python/isort/isort-5.13.0.ebuild74
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/isort/Manifest b/dev-python/isort/Manifest
index 18879d7f9bff..690f62ebfc48 100644
--- a/dev-python/isort/Manifest
+++ b/dev-python/isort/Manifest
@@ -1,4 +1,6 @@
AUX isort-5.12.0-py312.patch 1563 BLAKE2B 719905427e91895261aa7282cc9f56759b47ec71f8459d3959dfff1f9e254ae7a906d4fc1bfdb241bc20249cd45563854496f6bf1efd1a9cfb74203dc7ba137d SHA512 ecd2b1cb734cfea8a169b5412f221279c226938ec9d18b98b81b6f3fbf122124875236a46f0ac8bb3213f4331c888553d036e6835b826be78fe9dc300bfa1fdb
DIST isort-5.12.0.gh.tar.gz 743141 BLAKE2B a7f8deef02b57162eebe15b35e71382c654372a80dedba7eee63d0c9b0899c053fb517401585af17014db3cf9ed44089f6cbd1e2b0ed17393cc667de06bfbddd SHA512 ceb861d1a077be6fecd82fde775bded1fb676c77135e2004c92a6221762e0b3ff6c1071d17957e1add4062ec26ba6c9264e4905724f2c659339cbd0601f4b45e
+DIST isort-5.13.0.gh.tar.gz 753826 BLAKE2B 074e8b762b304618a2291d96dc9e18061e5303f3e6772479e8eda42c687cf289c12c73ce585c869df754b244bf14d59c6d2eba10877756287d88f27a3d470939 SHA512 3c5a170b1526ec58f1c774e4b55e2227df0af23eebd7a387d61cd3eaa0a698b5ad22a0be81a87d4e6a026030ffbdaea0f23331a43e28b5df98bf33b7afe2a42d
EBUILD isort-5.12.0.ebuild 1691 BLAKE2B 9899ef315fca3c2d591f6b99ce9d84230690631f873216bea8fa5d36b51d2fbb7f813cffc7efe1d7bbefb947b14a6ae1049cc3914e7da8a6cd2f22582283ae91 SHA512 dae89599e7f4ca3e3056411f0435ae5fe84c90dd7f0c9f8554032bc8d98567972c82be70f1abc180e4a1342d776330423606af83b3e04c42b89403739a325c44
+EBUILD isort-5.13.0.ebuild 1608 BLAKE2B 4055fe5a915f48ec2f8b2a045cc998cca196ea6a6e055fec328197357fe1fef176675052e843b72b51af8f8408f6d2f5d7be2e27ea2b4053c71c939fc57148d4 SHA512 624a284ece8bacf394976ea6b8749cf2ef4d9f6ca9104c2bc30fbc7051659053ee5bc440fc8152eb3131375a902eabe0f6fb20ee3566be463bd016ff200c7ce6
MISC metadata.xml 574 BLAKE2B db8aac55351f15190d9b71508268f26b12a781b3b4f0f6836a30efc954b46b71da496129a9641655db483730435b44a5c5283132521dc3cc93279c57735a1ba4 SHA512 c8116bf66155ffeb7ac8d68822559e18252210dae604b4984aa5e6a3fb7161d785cbd235dc6f656513b5bab326f6e579489245bcef9d0a5dfadc34d7477758fb
diff --git a/dev-python/isort/isort-5.13.0.ebuild b/dev-python/isort/isort-5.13.0.ebuild
new file mode 100644
index 000000000000..219f0a3f4657
--- /dev/null
+++ b/dev-python/isort/isort-5.13.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A python utility/library to sort imports"
+HOMEPAGE="
+ https://github.com/PyCQA/isort/
+ https://pypi.org/project/isort/
+"
+SRC_URI="
+ https://github.com/PyCQA/isort/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/tomli[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/black[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.4.6[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/natsort[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unbundle tomli
+ sed -i -e 's:from ._vendored ::' isort/settings.py || die
+ rm -r isort/_vendored || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ cp -a "${BUILD_DIR}"/{install,test} || die
+ local -x PATH=${BUILD_DIR}/test/usr/bin:${PATH}
+
+ # Install necessary plugins
+ local p
+ for p in example*/; do
+ pushd "${p}" >/dev/null || die
+ distutils_pep517_install "${BUILD_DIR}"/test
+ popd >/dev/null || die
+ done
+
+ local EPYTEST_IGNORE=(
+ # Excluded from upstream's test script
+ tests/unit/test_deprecated_finders.py
+ )
+
+ if ! has_version "dev-python/pylama[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=(
+ tests/unit/test_importable.py
+ tests/unit/test_pylama_isort.py
+ )
+ fi
+
+ epytest tests/unit
+}