summaryrefslogtreecommitdiff
path: root/dev-python/isort
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-29 08:54:36 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-29 08:54:36 +0000
commitcd1445321d1a6609cc7215588a79b2232c8a9bd3 (patch)
treefb9d68dde365101c0774ba4166a38ab3afa0e362 /dev-python/isort
parentb8ec9071f5d20d8518b02d0077428b2c9f88861b (diff)
gentoo auto-resync : 29:01:2023 - 08:54:36
Diffstat (limited to 'dev-python/isort')
-rw-r--r--dev-python/isort/Manifest2
-rw-r--r--dev-python/isort/isort-5.12.0.ebuild69
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/isort/Manifest b/dev-python/isort/Manifest
index 7ee1023f8a40..8c8c9fa2ceb6 100644
--- a/dev-python/isort/Manifest
+++ b/dev-python/isort/Manifest
@@ -1,3 +1,5 @@
DIST isort-5.11.4.gh.tar.gz 733368 BLAKE2B 82a9738cf48fd662c6128c7f58766e6b204d93fee73cbdd0d84850a62a1a714322dc6c31429a3b043401a963178c4aa3120e98c8f590f24799b75a92f9427798 SHA512 fd7dd8938cc700fa4a295bf1aabb9dc479e1b837e443e3210e4f2234316e207293eeb6f666b49ed2bc4f92942b3185de64439ce86ece201093072fee905766a8
+DIST isort-5.12.0.gh.tar.gz 743141 BLAKE2B a7f8deef02b57162eebe15b35e71382c654372a80dedba7eee63d0c9b0899c053fb517401585af17014db3cf9ed44089f6cbd1e2b0ed17393cc667de06bfbddd SHA512 ceb861d1a077be6fecd82fde775bded1fb676c77135e2004c92a6221762e0b3ff6c1071d17957e1add4062ec26ba6c9264e4905724f2c659339cbd0601f4b45e
EBUILD isort-5.11.4.ebuild 1591 BLAKE2B e58efc33beb1fa1c34919e803082b3a17c090de3772e2c0d3a30ff56c5a0b36c65bfdfa893336673593550b183e156310f30cdae278749a7f5d1ec92249f457d SHA512 072ed6e6b60b235dfdc200e4a44046d2248d02aa017eb8b4d31e5b5277ad3fcd422758c7d75aa1148c4e90a39a2b1fdc13dbfde30c5bbc884875a024cb02dc94
+EBUILD isort-5.12.0.ebuild 1599 BLAKE2B edfe274b4c72c8727caf423ccaface9fdb8375289fb1d9ced425d29f3eea2ee652358c462078f4ef2b602533f5564b850bbb0d4049e686fcf1a97cf7a513eb01 SHA512 4a1be6daf58cb7c2a49c2357b7f1bcef9b453911f10ae69680e48478fc2570e1ccd574d4902b0a5a03441d59490db909a6464def6ba37229f6db75f09a7a5e7b
MISC metadata.xml 574 BLAKE2B db8aac55351f15190d9b71508268f26b12a781b3b4f0f6836a30efc954b46b71da496129a9641655db483730435b44a5c5283132521dc3cc93279c57735a1ba4 SHA512 c8116bf66155ffeb7ac8d68822559e18252210dae604b4984aa5e6a3fb7161d785cbd235dc6f656513b5bab326f6e579489245bcef9d0a5dfadc34d7477758fb
diff --git a/dev-python/isort/isort-5.12.0.ebuild b/dev-python/isort/isort-5.12.0.ebuild
new file mode 100644
index 000000000000..1c237256715b
--- /dev/null
+++ b/dev-python/isort/isort-5.12.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python utility/library to sort imports"
+HOMEPAGE="
+ https://github.com/PyCQA/isort/
+ https://pypi.org/project/isort/
+"
+SRC_URI="
+ https://github.com/PyCQA/isort/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/tomli[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/natsort[${PYTHON_USEDEP}]
+ dev-python/pylama[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unbundle tomli
+ sed -i -e 's:from ._vendored ::' isort/settings.py || die
+ rm -r isort/_vendored || die
+ # leftover toml import used to determine .toml support
+ sed -i -e 's:import toml:toml = True:' tests/unit/test_isort.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ cp -a "${BUILD_DIR}"/{install,test} || die
+ local -x PATH=${BUILD_DIR}/test/usr/bin:${PATH}
+
+ # Install necessary plugins
+ local p
+ for p in example*/; do
+ pushd "${p}" >/dev/null || die
+ distutils_pep517_install "${BUILD_DIR}"/test
+ popd >/dev/null || die
+ done
+
+ local EPYTEST_IGNORE=(
+ # Excluded from upstream's test script
+ tests/unit/test_deprecated_finders.py
+ )
+ epytest tests/unit
+}