summaryrefslogtreecommitdiff
path: root/dev-python/jaconv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-30 02:06:22 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-30 02:06:22 +0000
commit080d89feff80cae2fc974ff2f24d463141c20635 (patch)
tree53d0a66fabd88f847940192be8163c5f3291d434 /dev-python/jaconv
parent2a3c08f4647671d17f534a5dbd8bd45e11c90ea2 (diff)
gentoo auto-resync : 30:11:2024 - 02:06:22
Diffstat (limited to 'dev-python/jaconv')
-rw-r--r--dev-python/jaconv/Manifest4
-rw-r--r--dev-python/jaconv/jaconv-0.4.0.ebuild41
-rw-r--r--dev-python/jaconv/metadata.xml16
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/jaconv/Manifest b/dev-python/jaconv/Manifest
new file mode 100644
index 000000000000..4d16102920a7
--- /dev/null
+++ b/dev-python/jaconv/Manifest
@@ -0,0 +1,4 @@
+DIST jaconv-0.4.0-nose-to-pytest.patch 9718 BLAKE2B 3c8386357c2a1359cd7885f9070138aaa743cda747869c0a4af60888def9804f0a2c57d7dc808096f3acb79bfc5ce7c7c45c3da9e9e683e597c3168c1650b1ef SHA512 4d0abc1e26f8d0652114cdd0a7bf6bd30acea5be2e8f21a956a0305ae8363d4e7734d6c082a801b5ef3d83892d53ff709737e587c5e983be76c8dfab068868ca
+DIST jaconv-0.4.0.gh.tar.gz 22876 BLAKE2B b37723afdf8516398608919ee5058dae9a99c4f0b258eb0a570b2f4f472637b6cd2e97c6f076b2d42cf74c0f1c1dce852f24a7effde79e8808b6f4e8b55020d8 SHA512 f435f1f61fef2ed36ee387138c767f88bf40dfb9d607b2b8bf9f88b1bbfd969d71c03464ce5b2adba2a65b5441eff6a0b88629cdff415366c2f1b8e6ea510bdf
+EBUILD jaconv-0.4.0.ebuild 997 BLAKE2B 0945a27a2a09ddced5aa19c70d78d79d67731dfe274bc137509a15fa7cc1266ff2da7b73db4a80b77987ac0d8114480653f21b36ef3163d05e1ab34a39297403 SHA512 e1fe1a7cbe0f1ec615e9a2422769fb5632536619e59fb8c4741dcdbc7fe8e249cd1fa783f20b69e1b312cfcc2e34e82947f5a9b6de80e9a4d9d68ee70fff67e6
+MISC metadata.xml 480 BLAKE2B e4332125eb3848844af1dbffb78c5bb83fe5e4fa62e01e22cc6ef8412d794d118496385b8140d1ee16868f2e9a7dc66caa0d1104565ee7765e13ca795d43a0e5 SHA512 c4a8f2a498bea2c1251be572db465d27c3dd5ec97c81eae8db656cce48bb439060b5cade498583a5bc211585312b2c486745ae759152047e4948e472f8b88765
diff --git a/dev-python/jaconv/jaconv-0.4.0.ebuild b/dev-python/jaconv/jaconv-0.4.0.ebuild
new file mode 100644
index 000000000000..8a9bfed0bcf4
--- /dev/null
+++ b/dev-python/jaconv/jaconv-0.4.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+# no tags on github, no tests on PyPI
+MY_PV=1d8aca73a72a4615b165602af9890517444e45d9
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pure-Python Japanese character interconverter"
+HOMEPAGE="
+ https://pypi.org/project/jaconv/
+ https://github.com/ikegami-yukino/jaconv
+"
+SRC_URI="
+ https://github.com/ikegami-yukino/jaconv/archive/${MY_PV}.tar.gz -> ${P}.gh.tar.gz
+ https://github.com/eli-schwartz/jaconv/commit/4f4160d33267ee7b6ff7386cdcdc6064a315b82a.patch?full_index=1
+ -> ${P}-nose-to-pytest.patch
+"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ # https://github.com/ikegami-yukino/jaconv/pull/36
+ "${DISTDIR}"/${P}-nose-to-pytest.patch
+)
+
+src_prepare() {
+ default
+ # tries to add README as data to install to sys.prefix
+ sed -i '/data_files/d' setup.py
+}
diff --git a/dev-python/jaconv/metadata.xml b/dev-python/jaconv/metadata.xml
new file mode 100644
index 000000000000..f8fee96e79ae
--- /dev/null
+++ b/dev-python/jaconv/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>eschwartz@gentoo.org</email>
+ <name>Eli Schwartz</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">jaconv</remote-id>
+ <remote-id type="github">ikegami-yukino/jaconv</remote-id>
+ </upstream>
+</pkgmetadata>