summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-collections
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-26 12:00:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-26 12:00:09 +0100
commitf300354de9fe5d997850456a9e1f400193e6544f (patch)
tree402fd6a7727db790bf57f683894052e8791d389e /dev-python/jaraco-collections
parent5c42677148c717eb9f4673237db807f74740b4e9 (diff)
gentoo auto-resync : 26:08:2024 - 12:00:09
Diffstat (limited to 'dev-python/jaraco-collections')
-rw-r--r--dev-python/jaraco-collections/Manifest2
-rw-r--r--dev-python/jaraco-collections/jaraco-collections-5.1.0.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/jaraco-collections/Manifest b/dev-python/jaraco-collections/Manifest
index 92a0aa06bb41..54ae1d765d73 100644
--- a/dev-python/jaraco-collections/Manifest
+++ b/dev-python/jaraco-collections/Manifest
@@ -1,3 +1,5 @@
DIST jaraco.collections-5.0.1.tar.gz 17990 BLAKE2B a78de1a3222492dde34271edd8032dc5b8737dc428c1aa6b55ebda799ef4ff986cb0cf495bdbc35f9c776e1d576c2970ae6736ba8d8aa7f2fcc2e6766aefbbc3 SHA512 88b0f261acd91d585e643b810818762af7165eaf505099701b99ee3be6955eebcfd1c95690faa3ecb56b25f6982a8cee242e687e50ead56a557a5b2b72ec6dfe
+DIST jaraco_collections-5.1.0.tar.gz 19026 BLAKE2B b0ecae5ddfabe22aca0fb0cb4ef6c07dd0c6b56cfd6920787779eb47631c3b4001f35a97f040a71495975fce40d5ec509799d19e23b81ccbf4afbae461cf0624 SHA512 b03b247657ad25df0b86ad125728e37c8123fdd1834adfc16c7e41fb9c31b9d4c1b168ed40614b965caafc7dd55fd14bba8c355648c8b5cca13b50736bc32883
EBUILD jaraco-collections-5.0.1.ebuild 779 BLAKE2B 13efae989208e426d953786e73b80b4975621e197ed84108e409819ada0bedcd273720d6f1cd1519a9dc1e667faf7e30dab9e4c556e69c43bdf68f7b5ba126d8 SHA512 50ef6284d6a89da1a62d4891e1c14a77af272df1ccdb87875bdfd98b678e6d9e2d5fcfa3cbfb09b1de09e8228c78c55e1022d47e49ce7c7ba871f85c2d9ceaf0
+EBUILD jaraco-collections-5.1.0.ebuild 767 BLAKE2B 3c3fd522f4c4c2eb85b7ccc5cc532eb7fddb99b4b103edfb30175370ebcbb1606ae968f7fb60e6092ec2d618f21958d30a1cf8d7052c02ca268ffb6fb74f114a SHA512 4bdd311209e01653b19e6911fa26e883aff626cf3fc3de54986dd48440e8d60fa9c288c8ebbc9b872b0d610b42985092fe8555ce103fa3ab4917bbfd39f68367
MISC metadata.xml 484 BLAKE2B 4914c8b3242714bea9e288990484336d645e7a20c7cdc3d6f8018c5bf4771e29a1dadc96e08cb4df6e421273ddd24111c0eaf367209d6dec504589ccb6da0bfd SHA512 f4b097fd1d2d25f31d102c38894ac0e083af00bfcaae986bfc5c93cf634229bcf8015a556b6eb8401b0c1e7f5e0cac619f0b75ef19195cbbf3b8d2128743202f
diff --git a/dev-python/jaraco-collections/jaraco-collections-5.1.0.ebuild b/dev-python/jaraco-collections/jaraco-collections-5.1.0.ebuild
new file mode 100644
index 000000000000..c19508cdbc4c
--- /dev/null
+++ b/dev-python/jaraco-collections/jaraco-collections-5.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Models and classes to supplement the stdlib collections module"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.collections/
+ https://pypi.org/project/jaraco.collections/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/jaraco-text[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-1.15.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}