summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-env/jaraco-env-1.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-30 09:20:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-30 09:20:33 +0100
commit70e4bd5c8f26b1f2baeb5146a841273b2cb15179 (patch)
tree82c39dda2ba79ec0993746bf42651c18a4beb137 /dev-python/jaraco-env/jaraco-env-1.0.0.ebuild
parent37c470b10802509995e7ae6a6886506f79540dd8 (diff)
gentoo auto-resync : 30:05:2023 - 09:20:33
Diffstat (limited to 'dev-python/jaraco-env/jaraco-env-1.0.0.ebuild')
-rw-r--r--dev-python/jaraco-env/jaraco-env-1.0.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/jaraco-env/jaraco-env-1.0.0.ebuild b/dev-python/jaraco-env/jaraco-env-1.0.0.ebuild
new file mode 100644
index 000000000000..0ffb98b5fc45
--- /dev/null
+++ b/dev-python/jaraco-env/jaraco-env-1.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Facilities for environment variables"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.env/
+ https://pypi.org/project/jaraco.env/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest