summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-functools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-27 09:09:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-27 09:09:50 +0100
commit2be230a2a252e8e744f11a8b38e9a0097ddc9b25 (patch)
treec7c6cd81169223a110c28f74dfc1b82b3f52bcb1 /dev-python/jaraco-functools
parent8d3ae5c288a62253ed3bc3d71336bf2061cfdb51 (diff)
gentoo auto-resync : 27:09:2022 - 09:09:50
Diffstat (limited to 'dev-python/jaraco-functools')
-rw-r--r--dev-python/jaraco-functools/Manifest2
-rw-r--r--dev-python/jaraco-functools/jaraco-functools-3.5.2.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/jaraco-functools/Manifest b/dev-python/jaraco-functools/Manifest
index 534a1ae952d5..e9f9dfca717b 100644
--- a/dev-python/jaraco-functools/Manifest
+++ b/dev-python/jaraco-functools/Manifest
@@ -1,3 +1,5 @@
DIST jaraco.functools-3.5.1.tar.gz 14516 BLAKE2B d58ca0e51767278988f418a5b1b736dd56da2c0ed214fa9b9b2a8b5e4ae77fcdedd431e444d1d2c3359b52a648ec85d01b8b7a2db872bb27d9bf24484347b7a0 SHA512 4496c80eae72834e5bc214f40de91a6aa603ce296b3866e0b363014c2919843f515efe9b314f18667e6b09d183a0985760e47f3340aed42dfbdba01884896df5
+DIST jaraco.functools-3.5.2.tar.gz 14650 BLAKE2B 63db54c5f3dea7b0ce939ad51fc4c4f5831a620a37a47d416079d4c9ad30cb3d401567a8da036178122431cafd8dc18e4a9b59241cd1fc0b8bd1c057dfb8a034 SHA512 3f67d151f4f6553b3e560b0e6ab71cf726d6c8f36ef5e9f69b6325605547797e19a3f9eb1331cf332db498538953ccaeb75820528e6599fd7cf125abdc073e69
EBUILD jaraco-functools-3.5.1.ebuild 1576 BLAKE2B 336a1679f662443c131639e84910f5dbbe5eab37349e0b77e55f9b3bf40931baaa09671a7a1e7687759093d91c0153587f37a1cc9a11d457284f5688616f5376 SHA512 9fb408c1e66711c7ba73e8d34ccc29c18f5329dcaf87d6f2a7dce7038339623429477444887cb09207d1f3f486ab280b9adfed61efe4844e6b2c91ce8852f90a
+EBUILD jaraco-functools-3.5.2.ebuild 1584 BLAKE2B 98ce14b5b093e6e56075e97717cffa9435c2583d3ab8b5fd9ef76d84f0d5f5c8a2a8d3bbf9e6ba16fa33aea6d30092380b70e383054d5f7a9483744ed1478c93 SHA512 d98856fd7baa11413f44c391f2d79fbbcad30f3f0ea0b59eb31ce35e2c9c97cd447f8dce452b84ac3c81454bda9c69cfd19ad65bb095590b25d78b59c6cedfd1
MISC metadata.xml 676 BLAKE2B b437d010c92db7c16013c9e2dbdb0071c793900189cdd0ec1918abc587ea5fcff10f36b5822e0912797fd2baf3aab5e8a25cf30ad8bb7f3e8e65608a52cd41cc SHA512 95fbff54e3f761dc323dd6c590ad093d301f5438db7a46c90be8a22ab59e1531ea1785317c764e98e278629ff8cd4db976ff1e25d00de46fe741c65ff655201d
diff --git a/dev-python/jaraco-functools/jaraco-functools-3.5.2.ebuild b/dev-python/jaraco-functools/jaraco-functools-3.5.2.ebuild
new file mode 100644
index 000000000000..623bd91af000
--- /dev/null
+++ b/dev-python/jaraco-functools/jaraco-functools-3.5.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=${P/-/.}
+DESCRIPTION="Additional functions used by other projects by developer jaraco"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.functools/
+ https://pypi.org/project/jaraco.functools/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN/-/.}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ >=dev-python/more-itertools-0.12.0-r1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "jaraco.functools"
+ version = "${PV}"
+ description = "Functools like those found in stdlib"
+ EOF
+}
+
+python_install() {
+ distutils-r1_python_install
+ # rename to workaround a bug in pkg_resources
+ # https://bugs.gentoo.org/834522
+ mv "${D}$(python_get_sitedir)"/jaraco{_,.}functools-${PV}.dist-info || die
+}