summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-logging/jaraco-logging-3.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-07 15:25:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-07 15:25:19 +0000
commit54ef05621701a320a71e56f68a0a942bc53ae0e9 (patch)
tree1137ddce6287c914945a29436a5741aee8f7fea5 /dev-python/jaraco-logging/jaraco-logging-3.1.2.ebuild
parent077e0e831423827ec97c98a46b5f2cc03fb4a6ea (diff)
gentoo auto-resync : 07:02:2023 - 15:25:18
Diffstat (limited to 'dev-python/jaraco-logging/jaraco-logging-3.1.2.ebuild')
-rw-r--r--dev-python/jaraco-logging/jaraco-logging-3.1.2.ebuild12
1 files changed, 3 insertions, 9 deletions
diff --git a/dev-python/jaraco-logging/jaraco-logging-3.1.2.ebuild b/dev-python/jaraco-logging/jaraco-logging-3.1.2.ebuild
index 9a59eed8640b..fc057468aa67 100644
--- a/dev-python/jaraco-logging/jaraco-logging-3.1.2.ebuild
+++ b/dev-python/jaraco-logging/jaraco-logging-3.1.2.ebuild
@@ -6,19 +6,15 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( pypy3 python3_{9..11} )
-inherit distutils-r1
+inherit distutils-r1 pypi
-MY_P="${P/-/.}"
DESCRIPTION="Additional facilities to supplement Python's stdlib logging module"
HOMEPAGE="
https://github.com/jaraco/jaraco.logging/
https://pypi.org/project/jaraco.logging/
"
-SRC_URI="
- https://github.com/jaraco/jaraco.logging/archive/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
+SRC_URI="$(pypi_sdist_url "${PN/-/.}")"
+S=${WORKDIR}/${P/-/.}
LICENSE="MIT"
SLOT="0"
@@ -33,8 +29,6 @@ BDEPEND="
distutils_enable_tests pytest
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
python_test() {
# create a pkgutil-style __init__.py in order to fix pytest's
# determination of package paths