summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-stream
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/jaraco-stream
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/jaraco-stream')
-rw-r--r--dev-python/jaraco-stream/Manifest6
-rw-r--r--dev-python/jaraco-stream/jaraco-stream-1.1.1.ebuild52
-rw-r--r--dev-python/jaraco-stream/jaraco-stream-1.1.ebuild49
-rw-r--r--dev-python/jaraco-stream/metadata.xml20
4 files changed, 127 insertions, 0 deletions
diff --git a/dev-python/jaraco-stream/Manifest b/dev-python/jaraco-stream/Manifest
new file mode 100644
index 000000000000..b8f06672f6d8
--- /dev/null
+++ b/dev-python/jaraco-stream/Manifest
@@ -0,0 +1,6 @@
+DIST jaraco.stream-1.1.1.tar.gz 6115 SHA256 f111cbb2a04063bcb1675a31a633c1a0f1b879a3f46c2ea8e71c7dc1242d8f47 SHA512 65c8d1652a0d63506cc3cadee590664e6a99e2f770d26f0cea1dce07c54ffe308e1df8619bc728ea81c5ac43c9c6731fe9f71e5d38d2674c4e0d63d635bb5112 WHIRLPOOL 808c4c854eea1f06bd8b06cdf31497876ccfeb939beb1c785408d83255774fd304d355e97ea7c4ff6794d7609a945f903926ab3d8bd55fe70c8651093578a62c
+DIST jaraco.stream-1.1.tar.gz 4887 SHA256 8f1e4aaea35728da594d1430772b85be098a919bf316be721045beb4377526a9 SHA512 5af385084623fbdfe86e9fb620f49b097dee164638bc99622ba557a26cda591e856f1fc4134bc7b73b8f7b61afaf2607686fe20c59c582324a65c22f39d74a13 WHIRLPOOL 5c91d24f8007041cbe76c4ab371776bc1058c714e991eb346ac0c846eda7ead0a532028ed5bc51f8618ee2b7061b5ee6a2e70915c292e4441eb5b5324cfb967f
+EBUILD jaraco-stream-1.1.1.ebuild 1199 SHA256 cdb37083a7b868d6003a60ebd4f226d07203dfb7e50fbb189178cd1950943f28 SHA512 3cc3a43091ee01b0ed72f510378f7de528f3ad3a4a44a8b90ad8d4cef87c8e954e2c3a7338fa132b52c5e3ca196b11c8853a9a63cc849aac3ccd0649816110d7 WHIRLPOOL ddcd4424d574696289605288649922186adf48e596bef9178b4bb2bf0cd19df67ae808d504cfb595ed02b8dea0fa4e75f23302d53b649a04baf50b7d184329ce
+EBUILD jaraco-stream-1.1.ebuild 1140 SHA256 fa228f988a94896fd9f2622a7dec5c22050a5f37be1ec41d2e799c09cf129def SHA512 9d67cc8e9ec8fa2b39a421f8a87ae5b0a7561d7555b00531ad6ac1fab470d9190bd104b5bac066aad8b5e1db0db53f7da13086986c5f34b83436547a522df599 WHIRLPOOL 7ebd20fda0d73b5a483b0ba4fde5d3f2ac3f150d67b3a75c28535408c9316eb390a34c8945b5c0b8492a527e013efa29a53a2770922473e0070a820022bd4c0c
+MISC ChangeLog 645 SHA256 e85a316e0d3f56101ffd7d68df6a968f6cfda4f426c1d92883b76c0f6ffdfd5d SHA512 44dedee178049d02d8f27281095082c394e835cc47b856de9289ffbf11853e0702ebafdc346e96529ebda48f3415513b235d4b48afc363439772c7ca64699906 WHIRLPOOL b4b9d0f574beb1d00ae9f46a0ee8b296f3649de8b62e31a183954a8b913eba47f08416b7995f2ad25054d87ccb66a3654fae9e0529e337653dab9ac2dac0cdbe
+MISC metadata.xml 726 SHA256 54b64b1c70ec94ff4a9fa9fa874cc92c7a2ed18f04d6d0ea6011699a830503aa SHA512 70852c5c0af30b62e142d05e75f241deff9ec67e47bf27d5a9fda28e88df3baefdf2d76bab43629b83237330668772f7c5cbb7242b0d168a8429659c4d3920da WHIRLPOOL de300d0d62885e006733cbd5f01bdc489550522c7e0ba60c1cc718b4f55ad98c715eead2d765a9fcdd1c600396ca10dcde287df34969c3aae0dd9f53eff06912
diff --git a/dev-python/jaraco-stream/jaraco-stream-1.1.1.ebuild b/dev-python/jaraco-stream/jaraco-stream-1.1.1.ebuild
new file mode 100644
index 000000000000..628b500250d4
--- /dev/null
+++ b/dev-python/jaraco-stream/jaraco-stream-1.1.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Routines for handling streaming data"
+HOMEPAGE="https://github.com/jaraco/jaraco.stream"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/rst-linker[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ # Skip one test which requires network access
+ PYTHONPATH=. py.test --ignore=jaraco/stream/test_gzip.py \
+ || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/jaraco-stream/jaraco-stream-1.1.ebuild b/dev-python/jaraco-stream/jaraco-stream-1.1.ebuild
new file mode 100644
index 000000000000..d9f68a120781
--- /dev/null
+++ b/dev-python/jaraco-stream/jaraco-stream-1.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Routines for handling streaming data"
+HOMEPAGE="https://github.com/jaraco/jaraco.stream"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/rst-linker[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ # Skip one test which requires network access
+ py.test --ignore=jaraco/stream/test_gzip.py \
+ || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/jaraco-stream/metadata.xml b/dev-python/jaraco-stream/metadata.xml
new file mode 100644
index 000000000000..778d6071842a
--- /dev/null
+++ b/dev-python/jaraco-stream/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sautier.louis@gmail.com</email>
+ <name>Louis Sautier</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">jaraco.stream</remote-id>
+ <remote-id type="github">jaraco/jaraco.stream</remote-id>
+ <bugs-to>https://github.com/jaraco/jaraco.stream/issues</bugs-to>
+ </upstream>
+ <longdescription lang="en">
+ Routines for handling streaming data, including a set of generators for loading gzip data on the fly.
+ </longdescription>
+</pkgmetadata>