summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-test
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-19 12:11:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-19 12:11:50 +0100
commitfe0961fc9674dd24a017f474a34c1edbbd005965 (patch)
treedfdf05888e0f5fff9c1faafe6eb0dd5d827b63e5 /dev-python/jaraco-test
parentbcd00c826070701606b0ccebf46234dfc792d3e9 (diff)
gentoo auto-resync : 19:09:2024 - 12:11:50
Diffstat (limited to 'dev-python/jaraco-test')
-rw-r--r--dev-python/jaraco-test/Manifest2
-rw-r--r--dev-python/jaraco-test/jaraco-test-5.5.1.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/jaraco-test/Manifest b/dev-python/jaraco-test/Manifest
index 4afbf784b65e..008e30c37704 100644
--- a/dev-python/jaraco-test/Manifest
+++ b/dev-python/jaraco-test/Manifest
@@ -1,3 +1,5 @@
DIST jaraco.test-5.4.0.tar.gz 8838 BLAKE2B 3abdff298a61015363bda3e52d3b5226993169128386dbb620487dcf8b29926c9be0415a2a263ad311db04a591d446b9e6efaece2ab2bfbe7b2781ee2e6dcdd6 SHA512 ab260c3c5ef16e83e8be0821cb735941764c06bb414c3f913bf337b62267b177f3102f7a87241b182ef20760fdcce98f4f9c705335b0744b69f9a296d5215b1b
+DIST jaraco_test-5.5.1.tar.gz 10018 BLAKE2B 09562269a1fd14e099e8bca484f4def00986aa3999134f51f875a026fd5b2832979533e91fcff651d938cbe5c302377152e8bf2288b0afd61ef0a52644c65c92 SHA512 09b3303657ccd6882835e3c0c8e27a03f7c5cfc923318e7c4736eded0a0aa3461f043ab595af82a0bb0de33381924415fd382706ab0af6cea80554ca74873ee1
EBUILD jaraco-test-5.4.0.ebuild 1210 BLAKE2B fe9ab05e00a8f3d125bc816a66b75933d799f81dfa2ff6204fde87712c1810255b35c7f00d54f00fe4ef7e54b2b44966132acef06ed3b0cef677e0f579ea6c10 SHA512 10dd26bcef2c6342c85cafc9a2430da162826eee45c077259af02891a272e191d3277ad5a6d841a4656c46dd9646def3a811bfea5bfa95d6b1165f02a4b2ea25
+EBUILD jaraco-test-5.5.1.ebuild 1198 BLAKE2B aff95f2384b06bc6f84294ebeff879bd93b642e2a77b87a8f3f6a3719e2e8e8a8ed91149babbb61b3780db1e1a47a7e1532aedb719f5632091944170f2b75712 SHA512 ab2f5d6d79a91228d21907472f0e9bee90634015ed32f76093352e1779a0d08220e999ce63d7ed9abc418ad7d5bd08a883b704da39e36a0f5f69728e5350dc02
MISC metadata.xml 397 BLAKE2B 24c07f0efc966e9d4445968ba639a5476a24a0885051e4eab17075ea9b7b6369fe9ed919ccdc0b51a1e667c8d327428caac2196c2a3e087d8b36176e7b4b2c81 SHA512 4fce74bc524dc018611c219b86b87b7643fe5d133309a00dd5ade217895165f85cfbe26b686c79fc4dd8b1e016b07c83c25afa1c015fc240ffa0ac75e4c17159
diff --git a/dev-python/jaraco-test/jaraco-test-5.5.1.ebuild b/dev-python/jaraco-test/jaraco-test-5.5.1.ebuild
new file mode 100644
index 000000000000..d1ca70fa02ec
--- /dev/null
+++ b/dev-python/jaraco-test/jaraco-test-5.5.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Testing support by jaraco"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.test/
+ https://pypi.org/project/jaraco.test/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/jaraco-collections[${PYTHON_USEDEP}]
+ dev-python/jaraco-context[${PYTHON_USEDEP}]
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+ dev-python/test[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ # workaround namespaces blocking test.support import (sigh!)
+ mv jaraco/test jaraco_test || die
+ rmdir jaraco || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ # while technically these tests are skipped when Internet is
+ # not available (they test whether auto-skipping works), we don't
+ # want any Internet access whenever possible
+ local EPYTEST_DESELECT=(
+ tests/test_http.py::test_needs_internet
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -m "not network"
+}