summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-text
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-28 08:51:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-28 08:51:03 +0000
commit21dbcce41990b13f301240313be05c8d013a9258 (patch)
tree933b3c51d46dc15fefe62b03a4f41c85b7e9bb44 /dev-python/jaraco-text
parente53aa6b4fbe5a0c6db75d893829f7a6a37a14180 (diff)
gentoo auto-resync : 28:01:2023 - 08:51:03
Diffstat (limited to 'dev-python/jaraco-text')
-rw-r--r--dev-python/jaraco-text/Manifest2
-rw-r--r--dev-python/jaraco-text/jaraco-text-3.11.1.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/jaraco-text/Manifest b/dev-python/jaraco-text/Manifest
index ee69e3fe119c..d0c68d13aa95 100644
--- a/dev-python/jaraco-text/Manifest
+++ b/dev-python/jaraco-text/Manifest
@@ -1,3 +1,5 @@
DIST jaraco.text-3.11.0.tar.gz 15883 BLAKE2B f0f3fe33901a68741cb26270384750f070476ef921bf2822f81dddfc1c66e41016757579e310bd20fc8a7f02b188de96f07bf58db41cca51252e46ebbbddcff9 SHA512 ad3ac412df5e21cef86dc56cdc869a93a660a103a676c1d187e5ea762690b89d61c8f68994e6a891e3d98071b440a052fad60a37f71066e4e11a2cfaf45ae009
+DIST jaraco.text-3.11.1.tar.gz 16083 BLAKE2B f7268128209fbdc849a745595339f4dc9a097f3f4f8f0cdcb05ca3106ed5a45460126fbb2b7d9c3b01b63aa3f750175e8cd366034183b7d8804a1650fe493e4b SHA512 b4066589e9d4c9a2a82ae2b0825d34b22b93ee179d29c3666e9b978390121520afcb8fc5ffa6457022d2e8477f4cf2b76485d9896438ee46275326577609f201
EBUILD jaraco-text-3.11.0.ebuild 1860 BLAKE2B 87ad59442da69a059c8acd9cb1438276e184d3e3d9864e6b1d5bc70cb6e6d35f804a0f40fca70ca6a16ff862a130813622f41543ae70cf48272745a069bd042e SHA512 962b38a5b0c619d55a70e3e5d1c5673096ab1cef597b50997f793fec7fb1718b72c7ee5908ba2ada46d384b599ddf2fde8e9e6dd76758f6ef3c3fe9406db5522
+EBUILD jaraco-text-3.11.1.ebuild 1868 BLAKE2B 4b72186540529177fe7c1019696cc12964291cca1497e821f22ca6d30b05b15e12f26f2397c7f51d7c9024b08e45631127683adfda2fc39acca77b16bf651898 SHA512 dbe570588a7bd68e46b59876ddc357b58814f9b5cc7bf354a963527767da2e424ea40d1db43339edcf9b3497a977720be92f5f23dfc314ad2cb022f3a82e4c58
MISC metadata.xml 550 BLAKE2B 147f1a6d5bb65e6ca4a29de497742b1cc69da4f46111512c05518c54c8fc351c12aeb452cc12c0a70974094ddead7014f58a5a2fb546173334ce282e218b8c9f SHA512 fd3bf89a43ca3ebf4be15c1cff79ebc70085b0fa0192fc9a44e6e1e799044ab9935545d4722d3bc6a3989d2a3199432a47f64876ea5b822e8e46fc3c41acd005
diff --git a/dev-python/jaraco-text/jaraco-text-3.11.1.ebuild b/dev-python/jaraco-text/jaraco-text-3.11.1.ebuild
new file mode 100644
index 000000000000..befb604a10f1
--- /dev/null
+++ b/dev-python/jaraco-text/jaraco-text-3.11.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P=${P/-/.}
+DESCRIPTION="Text utilities used by other projects by developer jaraco"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.text/
+ https://pypi.org/project/jaraco.text/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN/-/.}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/jaraco-context-4.1.1-r1[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-functools-3.5.0-r1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_resources-5.4.0-r3[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+# needed only for CLI tool, make it PDEPEND to reduce pain in setuptools
+# bootstrap
+PDEPEND="
+ dev-python/autocommand[${PYTHON_USEDEP}]
+ dev-python/inflect[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${PDEPEND}
+ $(python_gen_cond_dep '
+ dev-python/pathlib2[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "jaraco.text"
+ version = "${PV}"
+ description = "Module for text manipulation"
+ EOF
+}
+
+python_install() {
+ distutils-r1_python_install
+ # rename to workaround a bug in pkg_resources
+ # https://bugs.gentoo.org/834522
+ mv "${D}$(python_get_sitedir)"/jaraco{_,.}text-${PV}.dist-info || die
+}