summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-text
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-08 22:23:22 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-08 22:23:22 +0100
commit99b2c44c1425c7b2925846d4c44b2bf2f78dc786 (patch)
tree9bf7a2d385aace0ea5f3f8d3e3657168b758fdaa /dev-python/jaraco-text
parent39bccce90513402ec93bb0fde30678f16b07a9cc (diff)
gentoo auto-resync : 08:07:2023 - 22:23:22
Diffstat (limited to 'dev-python/jaraco-text')
-rw-r--r--dev-python/jaraco-text/Manifest3
-rw-r--r--dev-python/jaraco-text/jaraco-text-3.11.1-r1.ebuild64
-rw-r--r--dev-python/jaraco-text/metadata.xml1
3 files changed, 66 insertions, 2 deletions
diff --git a/dev-python/jaraco-text/Manifest b/dev-python/jaraco-text/Manifest
index 195b84839e74..3ed91cddb263 100644
--- a/dev-python/jaraco-text/Manifest
+++ b/dev-python/jaraco-text/Manifest
@@ -1,3 +1,4 @@
DIST jaraco.text-3.11.1.tar.gz 16083 BLAKE2B f7268128209fbdc849a745595339f4dc9a097f3f4f8f0cdcb05ca3106ed5a45460126fbb2b7d9c3b01b63aa3f750175e8cd366034183b7d8804a1650fe493e4b SHA512 b4066589e9d4c9a2a82ae2b0825d34b22b93ee179d29c3666e9b978390121520afcb8fc5ffa6457022d2e8477f4cf2b76485d9896438ee46275326577609f201
+EBUILD jaraco-text-3.11.1-r1.ebuild 1728 BLAKE2B c46d5d09daef7b72b11fde203f9907fe8d947fe366f7e4a2a3be4d449ec4cecf3641d5fd5c25140536ddab329b4bead8d733020669210e78c78081313a84ba21 SHA512 427307b7d0e72e82b8c1af21fb082d16de963ac6683bdaef2ea247e119176b2c8f9e3628287aa1306aeed524ed87be63590d0f8e1ebfdb796e874c5f12c1b4cb
EBUILD jaraco-text-3.11.1.ebuild 2143 BLAKE2B 4e8c943d028ae83a7c5957b0fa10557548ff2e361b37a27bd6e6aec6ca92ae028d67681dffd6483162c23f887ab8036d84c74c0effb2f61b3e88c9b0ff9b6782 SHA512 da749abc50bdafd88c841149a5ac15859f09390e76dfab36d8d859be002a0f7e5830df5cbdfb076f71103427d8f98a3da6c84ecb8e1f3d632a895bd302eac7ff
-MISC metadata.xml 656 BLAKE2B f801288ddad8d0a8ca1ae4683df60e718512bc13b6be2f79b4c67d03632d87d38844c43d08d3f16b16b21f1da02112e164ec72777bf6e31cbcc967fff01ff9da SHA512 62d5f23d2bc836afe3d1a86c541dd0c562849dc481bed6024901595ebd341e2f4d7fc17427a8416a8b6a330928fdd7a44a5c53370d19d6f6781a9ff77531c503
+MISC metadata.xml 569 BLAKE2B 93d693cf06e08ecb9a3647f207ff2942ac9e3908635442281f6ff73ee3ef0329868969820ed8a1d90b3840bb1a85742c6cc09d1a8e4ff4613917ab61d6ce7acf SHA512 9b11125d60fada5d7ccd5308fd31dee3c8f46d484097663c23790edf93eb39cc9a1434b44f2a72ec596d2d3a36fde16311e744534b61170bdac764a791cf685e
diff --git a/dev-python/jaraco-text/jaraco-text-3.11.1-r1.ebuild b/dev-python/jaraco-text/jaraco-text-3.11.1-r1.ebuild
new file mode 100644
index 000000000000..31140137334d
--- /dev/null
+++ b/dev-python/jaraco-text/jaraco-text-3.11.1-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Text utilities used by other projects by developer jaraco"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.text/
+ https://pypi.org/project/jaraco.text/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ >=dev-python/jaraco-context-4.1.1-r1[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-functools-3.5.0-r1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/pathlib2[${PYTHON_USEDEP}]
+ ' 3.9)
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "jaraco.text"
+ version = "${PV}"
+ description = "Module for text manipulation"
+ EOF
+
+ # remove CLI tools, they have annoying deps, no entry points
+ # and since there are dashes in their names, they can't be imported
+ # anyway
+ rm jaraco/text/*-*.py || die
+}
+
+python_install() {
+ distutils-r1_python_install
+ # rename to workaround a bug in pkg_resources
+ # https://bugs.gentoo.org/834522
+ mv "${D}$(python_get_sitedir)"/jaraco{_,.}text-${PV}.dist-info || die
+}
diff --git a/dev-python/jaraco-text/metadata.xml b/dev-python/jaraco-text/metadata.xml
index 7d0942d6335b..0cc9650b316b 100644
--- a/dev-python/jaraco-text/metadata.xml
+++ b/dev-python/jaraco-text/metadata.xml
@@ -10,7 +10,6 @@
<remote-id type="pypi">jaraco.text</remote-id>
<remote-id type="github">jaraco/jaraco.text</remote-id>
<bugs-to>https://github.com/jaraco/jaraco.text/issues</bugs-to>
- <changelog>https://github.com/jaraco/jaraco.text/blob/master/CHANGES.rst</changelog>
</upstream>
<use>
<flag name="cli">