summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-text
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-21 08:02:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-21 08:02:07 +0100
commitf1269e587f3d88b85f72a6fbaf727da5d6c9af90 (patch)
treeec99a8c7cdea447c38d3015894c269b8bc1e95af /dev-python/jaraco-text
parent3518f21ee7106f4268edf4404299dda157795e3c (diff)
gentoo auto-resync : 21:10:2022 - 08:02:07
Diffstat (limited to 'dev-python/jaraco-text')
-rw-r--r--dev-python/jaraco-text/Manifest2
-rw-r--r--dev-python/jaraco-text/jaraco-text-3.10.0.ebuild71
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/jaraco-text/Manifest b/dev-python/jaraco-text/Manifest
index 187739f4ae25..e297f8101ad4 100644
--- a/dev-python/jaraco-text/Manifest
+++ b/dev-python/jaraco-text/Manifest
@@ -1,3 +1,5 @@
+DIST jaraco.text-3.10.0.tar.gz 15588 BLAKE2B af615a481c21cfb3d0aa7824ad4a657dc2b629912f9772d25a9930891c222bea1205f1badcfd77502cfe84953873be55006eb6a1e475417296df821aadd94b63 SHA512 1c83dc9247e8c55ed20d8768abcb66c3fb4cdfb9ade3744f3d3c3e705b94e376c7b44fdfe242189001d69fbf28fdb5601ff33b1874495b3c2ad9bdd781265f43
DIST jaraco.text-3.9.1.tar.gz 14859 BLAKE2B 39fad64b85c8c1ea7b5bdac963b972b93ddb632940fe873fd0a646ca02d1e3a177742db9099cbbcd07dace1450c23a2e994c36f304a819e98e1c78907af975bd SHA512 f850125c7612342772d5a4a68076ea53a8cad6015c8bbe7e2923b034f8f601c8ff974eec0069b1bacba115d0aa43a948aea3b79f61d773464c823aac1880bbf1
+EBUILD jaraco-text-3.10.0.ebuild 1868 BLAKE2B 79fe03327d6da2721e38cadb289e03d7db72b14f2e88e9577ab701ff09a1b9523d645d3676742de2dce4bffa68be3637e4a28ca876a13c71a4ec468bb6df84f8 SHA512 ab8274d66dd3cece6c31f44fc137aa56c6f352108a2b57230320ab6366c9760006fa6f7a58131d04baf68f2677b868f6e4e0b3768371a11ac5c9263396f81ab6
EBUILD jaraco-text-3.9.1.ebuild 1860 BLAKE2B 5e90d080ce2ae213022d4f32b77a9447b9ba38b900934b621a8d2cbdbf951980d6f733efce854425af1751fd7527706a9cb5e42ba790cc214143341798494b85 SHA512 0358f92c9e361e6dc4a95018d5f0bb3f06afa2128a9c1eeadc2a9e96c4d2eedbaced7d26a88d92c426830184478647f726df691c3b341c85d3549927db53e03d
MISC metadata.xml 550 BLAKE2B 147f1a6d5bb65e6ca4a29de497742b1cc69da4f46111512c05518c54c8fc351c12aeb452cc12c0a70974094ddead7014f58a5a2fb546173334ce282e218b8c9f SHA512 fd3bf89a43ca3ebf4be15c1cff79ebc70085b0fa0192fc9a44e6e1e799044ab9935545d4722d3bc6a3989d2a3199432a47f64876ea5b822e8e46fc3c41acd005
diff --git a/dev-python/jaraco-text/jaraco-text-3.10.0.ebuild b/dev-python/jaraco-text/jaraco-text-3.10.0.ebuild
new file mode 100644
index 000000000000..8c1cfbc650dd
--- /dev/null
+++ b/dev-python/jaraco-text/jaraco-text-3.10.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P=${P/-/.}
+DESCRIPTION="Text utilities used by other projects by developer jaraco"
+HOMEPAGE="
+ https://github.com/jaraco/jaraco.text/
+ https://pypi.org/project/jaraco.text/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN/-/.}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/jaraco-context-4.1.1-r1[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-functools-3.5.0-r1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_resources-5.4.0-r3[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+# needed only for CLI tool, make it PDEPEND to reduce pain in setuptools
+# bootstrap
+PDEPEND="
+ dev-python/autocommand[${PYTHON_USEDEP}]
+ dev-python/inflect[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${PDEPEND}
+ $(python_gen_cond_dep '
+ dev-python/pathlib2[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "jaraco.text"
+ version = "${PV}"
+ description = "Module for text manipulation"
+ EOF
+}
+
+python_install() {
+ distutils-r1_python_install
+ # rename to workaround a bug in pkg_resources
+ # https://bugs.gentoo.org/834522
+ mv "${D}$(python_get_sitedir)"/jaraco{_,.}text-${PV}.dist-info || die
+}