summaryrefslogtreecommitdiff
path: root/dev-python/jeepney
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-python/jeepney
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-python/jeepney')
-rw-r--r--dev-python/jeepney/Manifest2
-rw-r--r--dev-python/jeepney/jeepney-0.8.0.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/jeepney/Manifest b/dev-python/jeepney/Manifest
index 712d63e8f20d..a990a08acad2 100644
--- a/dev-python/jeepney/Manifest
+++ b/dev-python/jeepney/Manifest
@@ -1,5 +1,7 @@
DIST jeepney-0.6.0.tar.gz 49513 BLAKE2B e5f9b5104cf07dbcd2d40c2d22b690dfd56c456ab56daf44f4abee83f0bfe7e1dfbad797348044d51e3dc20fbc6ce68bf8df54f9c1e46d7a86ceb22d3ab30f8d SHA512 140be9dd28ed853d2d41b6a8bbeb2f22c0270ce7bf33b943ec2ac010db17d4f06e253fa8637fbbb3044fe9ffdbfa1e15f0c663eb44bdd538f8c47c2e7dab3ca5
DIST jeepney-0.7.1.tar.gz 61833 BLAKE2B 626d4c921d0548ea898197ac5459f20b4c73fd52d3579c5b74f257158c82803011655c1d418d7d10afe8ba803100530bc08dbcce41e12727888de5be5995adb3 SHA512 f0af5a18a669f1a6322925201cad83ee01bc5a1b91577565042fd8a18b506a3650ff67b0ba333c8fb3b179f43ef243d16b07a9a1f7a7e5baec825dda0e6b0571
+DIST jeepney-0.8.0.tar.gz 106005 BLAKE2B 23dbd876915ca364202b6e1888d5b6892c56020a492f9dbdd22c1e04f40c2627bfb90ce209c69be000e176cc6b144b6c2232a21ce1ab089971911ffa2c22cd2c SHA512 823675f262c2c9778ccf9c1083601d936cca534fc0d2d9309b52aa6beeb7f73d225a37c5f18f6b0683c4829a93b1299a2cb4f8f341e55b92bedf58c8dce0aa75
EBUILD jeepney-0.6.0.ebuild 1038 BLAKE2B 2c7df2b5380f85a8f19645135db863eac3038e58a031065d2a5f491fd5327651a774e37e7e434f1846bbe49abeeec90229c6874081b6c39a5116b08860f4b1b3 SHA512 f6143bbffb239ff02ee46ef558ae5296b98abb3e0a8387abf49a8776d7acf131ec348ba98ae63bfc83b9bb0cc454e0637eeb8e5bd435533edb9277fbf87de9f7
EBUILD jeepney-0.7.1-r1.ebuild 1410 BLAKE2B c5106644e6f757020ea05da966c9fb6a233c0214c25f955e506f346647a57fe81c29c33fe34a3bcd6992b00c547b1886b9c1eba9cf29f0f7f1199e2f799c9a19 SHA512 a4a29104012412528195fbf48302cfc96c22eed701dd52a2f5f0d5093480dd215f7e04bde33918c0f3a5f1e65f6c2070ab6f8109dfefaace0949ce9a820ae737
+EBUILD jeepney-0.8.0.ebuild 1427 BLAKE2B 14708ee6deb8d7183774963c53e6cefed40a9e2291cb6dd692386d3ffb3f17972d33843b6e77ba3763077e772e8ad0147cd2ffa57a9b565c2f68bd9a6219f267 SHA512 433aa4b287035dfab31a66519e7946ecd5dbdaceba851f97df9e9935fc73bcfe23525426a196d456debfe588d23c3f44b998fc5643eff8913fd12546367569d6
MISC metadata.xml 457 BLAKE2B 8128c212049aa1ed733a297b9b0d36ada9bf76f6e88fdd87207f3f8c7b71b96733bc080746795088e30a8238f6381951e0be72af28ce82bf4b99e41275c71d7b SHA512 2ce1e347f419b0047615eed4be61962c18b325c75a7ee98feac55b8372ffbc04a9290ca7d1426b5fdf8286f3130ac9712277d510b1a4a35471e3b6542bd5c2b9
diff --git a/dev-python/jeepney/jeepney-0.8.0.ebuild b/dev-python/jeepney/jeepney-0.8.0.ebuild
new file mode 100644
index 000000000000..18ca1de03898
--- /dev/null
+++ b/dev-python/jeepney/jeepney-0.8.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, pure Python DBus protocol wrapper"
+HOMEPAGE="https://gitlab.com/takluyver/jeepney/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="examples"
+
+BDEPEND="
+ test? (
+ dev-python/async_timeout[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.7.1[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ sys-apps/dbus
+ $(python_gen_cond_dep '
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ ' 'python3*')
+ )
+"
+
+distutils_enable_tests pytest
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
+
+src_test() {
+ local dbus_params=(
+ $(dbus-daemon --session --print-address --fork --print-pid)
+ )
+ local -x DBUS_SESSION_BUS_ADDRESS=${dbus_params[0]}
+
+ distutils-r1_src_test
+
+ kill "${dbus_params[1]}" || die
+}
+
+python_test() {
+ local EPYTEST_IGNORE=()
+ # keep in sync with python_gen_cond_dep!
+ if [[ ${EPYTHON} != python3* ]]; then
+ EPYTEST_IGNORE+=( jeepney/io/tests/test_trio.py )
+ fi
+ epytest
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}