summaryrefslogtreecommitdiff
path: root/dev-python/jpype/jpype-0.6.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/jpype/jpype-0.6.2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/jpype/jpype-0.6.2.ebuild')
-rw-r--r--dev-python/jpype/jpype-0.6.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/jpype/jpype-0.6.2.ebuild b/dev-python/jpype/jpype-0.6.2.ebuild
new file mode 100644
index 000000000000..0f2b62316720
--- /dev/null
+++ b/dev-python/jpype/jpype-0.6.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit java-pkg-2 distutils-r1
+
+DESCRIPTION="JPype is an effort to allow Python programs full access to Java class librairies"
+HOMEPAGE="https://github.com/originell/jpype"
+SRC_URI="https://github.com/originell/${PN}/archive/v${PV}.zip -> ${P}.zip"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc examples"
+
+S="${WORKDIR}/${P}"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=virtual/jdk-1.6"
+
+PATCHES=( "${FILESDIR}"/${PN}-gcc6-noexcept.patch )
+
+python_compile() {
+ if ! python_is_python3; then
+ local CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"
+ export CXXFLAGS
+ fi
+ distutils-r1_python_compile
+}
+
+python_install() {
+ use doc && local DOCS=( doc/* )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install
+}