summaryrefslogtreecommitdiff
path: root/dev-python/js2py/js2py-0.74.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-04 15:02:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-04 15:02:51 +0000
commit5565fb7867ee9faddf046e42a0a3a1a207803938 (patch)
tree4ef17bc3c9c8058e033b4f7452064b3f9657e023 /dev-python/js2py/js2py-0.74.ebuild
parentacf34cb86be38d3601273c231058d3fda627e618 (diff)
gentoo auto-resync : 04:12:2022 - 15:02:50
Diffstat (limited to 'dev-python/js2py/js2py-0.74.ebuild')
-rw-r--r--dev-python/js2py/js2py-0.74.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/js2py/js2py-0.74.ebuild b/dev-python/js2py/js2py-0.74.ebuild
new file mode 100644
index 000000000000..f29185793ec4
--- /dev/null
+++ b/dev-python/js2py/js2py-0.74.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN=Js2Py
+MY_P=${MY_PN}-${PV}
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="JavaScript to Python Translator & JavaScript interpreter in Python"
+HOMEPAGE="http://piter.io/projects/js2py/
+ https://github.com/PiotrDabkowski/Js2Py/
+ https://pypi.org/project/Js2Py/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pyjsparser-2.5.1[${PYTHON_USEDEP}]
+ >=dev-python/tzlocal-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ pushd ./tests >/dev/null || die
+
+ # Tests require "node_failed.txt" file where the logs are kept
+ if [[ -f ./node_failed.txt ]] ; then
+ rm ./node_failed.txt || die
+ fi
+
+ touch ./node_failed.txt || die
+ "${EPYTHON}" ./run.py || die "tests failed with ${EPYTHON}"
+
+ popd >/dev/null || die
+}