summaryrefslogtreecommitdiff
path: root/dev-python/json-rpc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/json-rpc
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/json-rpc')
-rw-r--r--dev-python/json-rpc/Manifest3
-rw-r--r--dev-python/json-rpc/json-rpc-1.10.1.ebuild38
-rw-r--r--dev-python/json-rpc/metadata.xml19
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/json-rpc/Manifest b/dev-python/json-rpc/Manifest
new file mode 100644
index 000000000000..52fca2e0cbfb
--- /dev/null
+++ b/dev-python/json-rpc/Manifest
@@ -0,0 +1,3 @@
+DIST json-rpc-1.10.1.tar.gz 25410 BLAKE2B bb543dc9987d7aa4880d1981fad888ae9374f51958a2b7934e2779fc835705c03946cb3378ca60a914a130ae78741cda75da40ee8ce76e6b4af17a2e98498089 SHA512 bb69cbb12c0a64286fb1e98db21ca75cb19daf20c6d6f5721f82891a17e44d2cda172e73bd389a02077d094b8f6deb0959952b0498b0c1b4a0acfaa5e3ba3922
+EBUILD json-rpc-1.10.1.ebuild 809 BLAKE2B 42983942abd2fc960871292c0f87553ebb53d0f0ca34ab25b55d6bc32e66770f8767d06efb75b64ae8f9d2ff730daedf05fd7fc98a65e309221fa90811ec5f42 SHA512 9ce22bc24d9211288274e21aea3a987b333215cf25db80626e77a626fa86a8fac06a76857edfcd8e060df306702c7ccce4af3b7402ca384163ee21adbf8e92d7
+MISC metadata.xml 794 BLAKE2B c3611b6095ddf17e030c993775e3fb0b9a7c2c7ac22f5486151f2b9ad03f73bf6b0f6e467cd6440e4a6b726f4cef597cc48dd35d8973c4be941f2615b9c2b208 SHA512 68c309e9fcd29a2182d6eba1e9e758971edc2293cd3c044852de9c938ae0bdbe6ea8805b32e76656d809d6ab3d636a274cd2e65dfd21ce3f026bde5e9ae02266
diff --git a/dev-python/json-rpc/json-rpc-1.10.1.ebuild b/dev-python/json-rpc/json-rpc-1.10.1.ebuild
new file mode 100644
index 000000000000..857752944190
--- /dev/null
+++ b/dev-python/json-rpc/json-rpc-1.10.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="JSON-RPC transport implementation for python"
+HOMEPAGE="https://github.com/pavlov99/json-rpc"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ cat > jsonrpc/six.py <<- EOF
+ from __future__ import absolute_import
+ from six import *
+ EOF
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/json-rpc/metadata.xml b/dev-python/json-rpc/metadata.xml
new file mode 100644
index 000000000000..300f5e2ad4bd
--- /dev/null
+++ b/dev-python/json-rpc/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ JSON-RPC is a stateless, light-weight remote procedure call (RPC) protocol.
+ Primarily this specification defines several data structures and the rules
+ around their processing. It is transport agnostic in that the concepts can
+ be used within the same process, over sockets, over http, or in many various
+ message passing environments. It uses JSON (RFC 4627) as data format.
+</longdescription>
+ <upstream>
+ <remote-id type="pypi">json-rpc</remote-id>
+ <remote-id type="github">pavlov99/json-rpc</remote-id>
+ </upstream>
+</pkgmetadata>