summaryrefslogtreecommitdiff
path: root/dev-python/jsondiff/jsondiff-1.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/jsondiff/jsondiff-1.2.0.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/jsondiff/jsondiff-1.2.0.ebuild')
-rw-r--r--dev-python/jsondiff/jsondiff-1.2.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/jsondiff/jsondiff-1.2.0.ebuild b/dev-python/jsondiff/jsondiff-1.2.0.ebuild
new file mode 100644
index 000000000000..29227333f395
--- /dev/null
+++ b/dev-python/jsondiff/jsondiff-1.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Diff JSON and JSON-like structures in Python"
+HOMEPAGE="https://github.com/xlwings/jsondiff https://pypi.org/project/jsondiff/"
+SRC_URI="https://github.com/fzumstein/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ dev-python/nose-random[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # Avoid file collision with jsonpatch's jsondiff cli.
+ sed -e "/'jsondiff=jsondiff.cli/ d" -i setup.py || die
+ distutils-r1_python_prepare_all
+}