summaryrefslogtreecommitdiff
path: root/dev-python/jsondiff
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-30 12:00:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-30 12:00:55 +0100
commit2e8abb8c82f14dd064991a1afd337b2f022b37f6 (patch)
treed600b9d779be602cd4b6e93bf715ec8fba07624c /dev-python/jsondiff
parentadcf4f8116a4a850dae301fb4dbcd7b71cb35975 (diff)
gentoo auto-resync : 30:08:2024 - 12:00:55
Diffstat (limited to 'dev-python/jsondiff')
-rw-r--r--dev-python/jsondiff/Manifest2
-rw-r--r--dev-python/jsondiff/jsondiff-2.2.1.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/jsondiff/Manifest b/dev-python/jsondiff/Manifest
index bb72ef438bbb..60e16610490e 100644
--- a/dev-python/jsondiff/Manifest
+++ b/dev-python/jsondiff/Manifest
@@ -1,3 +1,5 @@
DIST jsondiff-2.2.0.gh.tar.gz 22672 BLAKE2B 64af3c3f0aa9c7c6380af30ae303c230a04ba02d9e97d25b46348134312ea53d869e74c24a1b0d72983d731dda6d74a3fee3d89df6e9a6ef083321fe9b501ec3 SHA512 a1da92a1a38047947c2ee6057c641930c1b141889f992723c250a4444871170e2b10c892595a3bce026339b1d03c91d157cdf918fb36d4b916131bee5db969e5
+DIST jsondiff-2.2.1.gh.tar.gz 22715 BLAKE2B 598d999d6d2dd9a3a6abd8b34145420b2ee9c6b5bf4a686e1c4fe605d68c3ee588efda4db0a0127a13f10e4639b43661f297e83a314ee8a0c12e9408c8dfdcbb SHA512 e10ed1f1b11b877223936586c1805cb8b8ae3f487f913f4d33030ae6e87a06a54f1f9adfb2b50485d72123f2feb6b40aa019851a6c9fd83575cc0f0b814484f7
EBUILD jsondiff-2.2.0.ebuild 827 BLAKE2B 7eb175b25ddd85feec668edfd93ad3f639c5f795ad279700531e98c2027e76aaf9bb98e202c31272af2a91aff3a82641da842b9279dee83dd53f144ac6029d00 SHA512 08bf3da86c1f7ad683963cdfe2f9dab04cc958cd07249216061f650bd146a189275203d6d2960ead9ec14cdd1cb7a9fa2e3a929c5d639942dbc77814f76417d1
+EBUILD jsondiff-2.2.1.ebuild 830 BLAKE2B 06855c48602171ab6a48d8e40fac0615d30274401c2c284b7454307bb71dc7dc8cb0c8f7bbbe957fe3a86b6608485e0b0a3e88a2bca0978a5d5a3a1462632bea SHA512 de41c4a480a657b920151e8f60f7d9730298092596cdd7aaf9e07ae442bb5d80d497383b1096f372aa006e0a4f280176d3b885e15cc15cc9288139e0490c1758
MISC metadata.xml 561 BLAKE2B f11baa5f35a81e4fd69adde15b5a39d728e8137a112ef7c794e8d008d5de829ab5a333fcfdc2e1dd2156d91bb779db204a21c73eaad424e983c7865b33a81785 SHA512 238d5cedd70a0fd887f6007cbee0e11faf4b574b346fa91c66ee6d93e06571364fb80a0fbc13fe347f34e217e7589f5b61984c5ab0ead465d5e725d1792af4c5
diff --git a/dev-python/jsondiff/jsondiff-2.2.1.ebuild b/dev-python/jsondiff/jsondiff-2.2.1.ebuild
new file mode 100644
index 000000000000..1f6ddda4fc90
--- /dev/null
+++ b/dev-python/jsondiff/jsondiff-2.2.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Diff JSON and JSON-like structures in Python"
+HOMEPAGE="
+ https://github.com/xlwings/jsondiff/
+ https://pypi.org/project/jsondiff/
+"
+SRC_URI="
+ https://github.com/xlwings/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+}