summaryrefslogtreecommitdiff
path: root/dev-python/jsondiff
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/jsondiff
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/jsondiff')
-rw-r--r--dev-python/jsondiff/Manifest2
-rw-r--r--dev-python/jsondiff/jsondiff-1.3.1.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/jsondiff/Manifest b/dev-python/jsondiff/Manifest
index dd67b98d5573..f49f25d45067 100644
--- a/dev-python/jsondiff/Manifest
+++ b/dev-python/jsondiff/Manifest
@@ -1,3 +1,5 @@
DIST jsondiff-1.3.0.tar.gz 15283 BLAKE2B 408070816a4b21a3f11f5b039464ba276fb253f712f29930454167d3aff22f78b4d828aba5e28cf05587c8a296b908fd1945a65958244a1093279bff5e3a555c SHA512 512e34d1a0673ed785f066c284c09412a3590ad916913ae1885ac567795cc73e2adf30596b60b64b6b379954e6cb82d5174e80dd9cf40ed53f6968bec8a3d8f2
+DIST jsondiff-1.3.1.gh.tar.gz 15457 BLAKE2B f3896c85b601ac32859e59f2a5a29b51f124a1dd27fa2b0da40e44c4b776bbba933043fb7334e5ec20833eea25143d40cc7988a8308f56eff20510db982688b0 SHA512 cbbed17bf00f1757d81477e02435c3f5a9a3246774f3fd9a433be31de1617525acfe33d6790be33dcf9b5da5ef3d6910d13958fb7b8ea4fbd802c74485a9dc6f
EBUILD jsondiff-1.3.0.ebuild 752 BLAKE2B fb4c89332171d77250c713c0c4ce47f93327fdb3cdfc098b9bce0a94fbb1a7b1a2ab3721f690c5aaeee92d10b7ad822b2cd1350c76fdd081fc794636812be58d SHA512 5acf09fc1b4b3795306a33aa9d2231572bb21e0294c38e59679f74ebf754958fcfdb2570e8e4ed4396bfe3e7f6cb1e252889a07759cefd7dd736c9c55ffe6a63
+EBUILD jsondiff-1.3.1.ebuild 796 BLAKE2B 8a490c2c1921afdda000ca1be23a6e0f4b97f4614c91823b4be1f7fe6bee31ca7695265878f363c4e61e78f798c7d08b98284501e01dc5e5e7723bd3c9266629 SHA512 ebdd698607d264d2169a9ffa785158260c87ed37e1406fc1e4f720dabcce07cbc894848a701bb9bada77df95b1b90ddfd76e0e037b3df8f583bf5f113aba5203
MISC metadata.xml 537 BLAKE2B 833afe4569e5eda33f07635fb89b9ea478e135f5b22a706d6a914f3aaa5bfb070136265a710a445d81568e908c898f6a8227ce6da427eebf73b73315349df9e4 SHA512 b7879e874f1f8abdd9d87ab9996a01fe67fa6a10cdb60bc09e15fc77ca6d3bdffe6ae676e451fc4122a6776ac49cfbf95c48929095e21eec99a031fbebee4174
diff --git a/dev-python/jsondiff/jsondiff-1.3.1.ebuild b/dev-python/jsondiff/jsondiff-1.3.1.ebuild
new file mode 100644
index 000000000000..f80d37ac5faf
--- /dev/null
+++ b/dev-python/jsondiff/jsondiff-1.3.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Diff JSON and JSON-like structures in Python"
+HOMEPAGE="
+ https://github.com/xlwings/jsondiff/
+ https://pypi.org/project/jsondiff/"
+SRC_URI="
+ https://github.com/xlwings/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ dev-python/nose-random[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # Avoid file collision with jsonpatch's jsondiff cli.
+ sed -e "/'jsondiff=jsondiff.cli/ d" -i setup.py || die
+ distutils-r1_python_prepare_all
+}