summaryrefslogtreecommitdiff
path: root/dev-python/jsonpickle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/jsonpickle
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/jsonpickle')
-rw-r--r--dev-python/jsonpickle/Manifest4
-rw-r--r--dev-python/jsonpickle/jsonpickle-1.3.ebuild49
-rw-r--r--dev-python/jsonpickle/jsonpickle-1.4.1-r1.ebuild2
3 files changed, 2 insertions, 53 deletions
diff --git a/dev-python/jsonpickle/Manifest b/dev-python/jsonpickle/Manifest
index 3f6aa7f2709d..116e7ea7419d 100644
--- a/dev-python/jsonpickle/Manifest
+++ b/dev-python/jsonpickle/Manifest
@@ -1,5 +1,3 @@
-DIST jsonpickle-1.3.tar.gz 76571 BLAKE2B 797ac90d1aacb620d9917bd2a34dbc960739b29f64d7bc003c934333fc0d836657a4907a965725248b2f9489876ae251440eab3888112f158c28f19e33efe036 SHA512 5e7faa32f4fd2da88d9cfea8c0355121ece12aa1b4434845e6bd679718f433e5c27835b405f833a31d69d09d7a6ae6c3d5e4bf1f6dc9c50c7ff1690cf82271b0
DIST jsonpickle-1.4.1.tar.gz 104564 BLAKE2B a3ad6f9c712f39153186b6ccdef515581012ad4ba1251dcb094074f2093eb4b158b9357bdf2e8668073cb21dc3bf6dd2fc3a0058c8597252c558a797432068b9 SHA512 ed6bf3472c59ba907a973c5c6f05de13dbfc75eef103796b8f8a63d388f769527f22667ca8761092d1649ff2caf5a73de0593e370df3e7fcabe06e73b265da35
-EBUILD jsonpickle-1.3.ebuild 1464 BLAKE2B c296889e4932cb48a7e07ceb4480280c5f751eac869c0d70923a79758ca407fa0e2432212d269e692164a981c2745e40b097d32fb7042b9d86ec9f25c018fd66 SHA512 5bd82786b9e4260caa244bf9280300069b569eea5765eae0c9a381d3c804da2d4a882cc726a163f97bd8ff205e446f115e5bab896917aefb1c25e63f1a6788f2
-EBUILD jsonpickle-1.4.1-r1.ebuild 1290 BLAKE2B 40850b13753a047e8bfa80939df7733a863c0aaca17efb6c92f7e6449c010448bb12fe8e60e7d09d3df5b48e34f9e9587d010e0f4557bb63b53a500d79bbc6eb SHA512 9545f7bffd34dd158721c952619a406179156f9a354268efd44b71fcd468f91e301705d2806cba70ff85e63369f5dc733198a632b5ff06b91d1da9d5820e2ab4
+EBUILD jsonpickle-1.4.1-r1.ebuild 1297 BLAKE2B 4c1395725496b24e16429333a0aaa7d726a52b8155a8abb29748fad2362bb797b33ea9bf847df689ff7eb638de138740a4551f28f82fe7b7d211e74a92f60474 SHA512 10537693574be37f87edbe02657c3c97984e7df5d33e76270c774cfc6e2862173efea9aaae6f1bf500c790b395cbe1e995fc6fefd6c7c066b786fd534e335655
MISC metadata.xml 386 BLAKE2B 486aa3823ac1ae6b816068ae775da293fedab7120df504f2bb64cbbd026e1ad4ac2041acfb48035b5816616dedd46a5f4bedf8c63daad2315727cdbaedcd15ad SHA512 12590542127c674ae6c8123b20ce5c7ed6815f9129eefb95ef3a8c064fdc25477765d397cb7d7e62772475306c0ac7389a7155655576845b936866470302b759
diff --git a/dev-python/jsonpickle/jsonpickle-1.3.ebuild b/dev-python/jsonpickle/jsonpickle-1.3.ebuild
deleted file mode 100644
index f27e26fe6319..000000000000
--- a/dev-python/jsonpickle/jsonpickle-1.3.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python library for serializing any arbitrary object graph into JSON"
-HOMEPAGE="https://github.com/jsonpickle/jsonpickle/ https://pypi.org/project/jsonpickle/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-# There are optional json backends serializer/deserializers in addition to those selected here
-# jsonlib, yajl.
-RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]
- dev-python/feedparser[${PYTHON_USEDEP}]
- dev-python/ujson[${PYTHON_USEDEP}]
- "
-DEPEND="test? ( ${RDEPEND} )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # Prevent un-needed d'loading during doc build
- sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/source/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && { python_setup python2_7 && sphinx-build -b html -c docs/source/ docs/source/ docs/source/html || die; }
-}
-
-python_test() {
- # An apparent regression in tests
- # https://github.com/jsonpickle/jsonpickle/issues/124
- einfo "testsuite has optional tests for package demjson"
- ${PYTHON} tests/runtests.py || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/source/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/jsonpickle/jsonpickle-1.4.1-r1.ebuild b/dev-python/jsonpickle/jsonpickle-1.4.1-r1.ebuild
index fa56bf7fde12..c990ed01191f 100644
--- a/dev-python/jsonpickle/jsonpickle-1.4.1-r1.ebuild
+++ b/dev-python/jsonpickle/jsonpickle-1.4.1-r1.ebuild
@@ -13,7 +13,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 ~arm ~arm64 x86 ~amd64-linux ~x86-linux"
IUSE="doc test"
RESTRICT="!test? ( test )"