summaryrefslogtreecommitdiff
path: root/dev-python/jsonpickle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/jsonpickle
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/jsonpickle')
-rw-r--r--dev-python/jsonpickle/Manifest5
-rw-r--r--dev-python/jsonpickle/jsonpickle-0.9.3.ebuild50
-rw-r--r--dev-python/jsonpickle/metadata.xml12
3 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/jsonpickle/Manifest b/dev-python/jsonpickle/Manifest
new file mode 100644
index 000000000000..5e1220d29645
--- /dev/null
+++ b/dev-python/jsonpickle/Manifest
@@ -0,0 +1,5 @@
+DIST jsonpickle-0.9.3.tar.gz 60489 SHA256 54569ebd2aa042529966d45d46be9eac6dd9852150dcee01bb61499d884f23fa SHA512 38de2ab2c15e0e28323a8cc83b0c0b0631f2f678f620e8738fee19c71492f011aa7eec428b859574a0066b9e24a08bde911a283736757964035befe3042f2e06 WHIRLPOOL 3a30037709d93c03930b686f1ba63f17059b1e162564b14ec302a2d87796faf45ea36b8b9acf03538f577e12a8dbabb4e8ca9064a3b9018f18f7edbfbc29e849
+EBUILD jsonpickle-0.9.3.ebuild 1546 SHA256 c7c2a1b9d45b6c35e1a6e02766dd4430466b654bade067e2086d20bd9ad0fcb9 SHA512 6d881de6f98d84e965d267b5cab19e1bb5bb31f0005efe7c798fb99ff916f336942d564c4553977926a0130f91a0e16249904d44f99ba01db46704a14b435d27 WHIRLPOOL 752c2e047c98b8ae06e1bf221f8028e51bfc7189670466a8e6ae0a9d3b64b580761ac9a195bdbf0b021b61ef41db7284bc7d7a46ef0a5c12043e5ac562790779
+MISC ChangeLog 3440 SHA256 c986cb01f2e84cae46c238c9767e48e1b467f44f79515ec2d15500fe22e72f32 SHA512 2fa776d35dca336c7ef3a08ad5edb395a26e4f8084541a09be69d94ab158a608c95f7f5f49b0b0d0a028bbfb14c624bbc2f6faefaeba7c252fd45274e6b7cffe WHIRLPOOL 99c03f5649a3035656648bc4b06a58b8c7fa04bf661b6ac2041d933b5b0208a1b808631db6e41a895008b1c01fc25df47a9573810338b6e22e7e32fd64246db6
+MISC ChangeLog-2015 4852 SHA256 901f4dc3c46db890d0618574c62fa47cc799da0bff2e5012e1ea4f36789b4c76 SHA512 e9c86a7353d6991e8ab49a373e6cec4cc04b142d8a9cf6fecdcf2dbc8b75612e16c338cd7ae76b1c1539224d5ebf9435e1f041b8246b0209709a4cb786845cf9 WHIRLPOOL 4ccc9996e6f8e1c2b5c25f13bf777e4148b604b96a612c5ff41d5d7e2926fe939374e0ee3110b697b813e01537ec8638e798a7665b6b893f5b57b3c853a2aa14
+MISC metadata.xml 386 SHA256 783b69bf72bf59908b06da5255db4626ef1376fbcfe39cbd0da49ed67feb78ba SHA512 12590542127c674ae6c8123b20ce5c7ed6815f9129eefb95ef3a8c064fdc25477765d397cb7d7e62772475306c0ac7389a7155655576845b936866470302b759 WHIRLPOOL b8651b9a69d139008ad1b2e776f1694ec27942603085ce028fbaab5aade0eff2763b4cc7faca0d111380572651f1ba2fc6049dec9a9d0d72311073f0d8c8d5cf
diff --git a/dev-python/jsonpickle/jsonpickle-0.9.3.ebuild b/dev-python/jsonpickle/jsonpickle-0.9.3.ebuild
new file mode 100644
index 000000000000..c08f5614e2d2
--- /dev/null
+++ b/dev-python/jsonpickle/jsonpickle-0.9.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for serializing any arbitrary object graph into JSON"
+HOMEPAGE="https://github.com/jsonpickle/jsonpickle/ https://pypi.python.org/pypi/jsonpickle"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+# There are optional json backends serializer/deserializers in addition to those selected here
+# jsonlib, yajl. demjson added
+RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/feedparser[${PYTHON_USEDEP}]
+ dev-python/ujson[${PYTHON_USEDEP}]
+ dev-python/demjson[${PYTHON_USEDEP}]
+ "
+DEPEND="test? ( ${RDEPEND} )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/sphinxtogithub[${PYTHON_USEDEP}]' python2_7) )"
+
+python_prepare_all() {
+ # Prevent un-needed d'loading during doc build
+ sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/source/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && sphinx-build -b html -c docs/source/ docs/source/ docs/source/html
+}
+
+python_test() {
+ # An apparent regression in tests
+ # https://github.com/jsonpickle/jsonpickle/issues/124
+ einfo "testsuite has optional tests for package demjson"
+ ${PYTHON} tests/runtests.py || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/source/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/jsonpickle/metadata.xml b/dev-python/jsonpickle/metadata.xml
new file mode 100644
index 000000000000..6ee6ba05b2b7
--- /dev/null
+++ b/dev-python/jsonpickle/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">jsonpickle</remote-id>
+ <remote-id type="github">jsonpickle/jsonpickle</remote-id>
+ </upstream>
+</pkgmetadata>