summaryrefslogtreecommitdiff
path: root/dev-python/jsonref/jsonref-0.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-10 13:34:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-10 13:34:01 +0100
commitbba7ed73af4fe3b333cb970dc40a9098e2d1c54b (patch)
tree4a2377c9096a6e85935bc1b24a50c09537fbb3ca /dev-python/jsonref/jsonref-0.3.0.ebuild
parentf69024d0d689548234c6173dc2d8a5bb466b0525 (diff)
gentoo auto-resync : 10:10:2022 - 13:34:00
Diffstat (limited to 'dev-python/jsonref/jsonref-0.3.0.ebuild')
-rw-r--r--dev-python/jsonref/jsonref-0.3.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/jsonref/jsonref-0.3.0.ebuild b/dev-python/jsonref/jsonref-0.3.0.ebuild
new file mode 100644
index 000000000000..e69ac8248519
--- /dev/null
+++ b/dev-python/jsonref/jsonref-0.3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of JSON Reference for Python"
+HOMEPAGE="
+ https://github.com/gazpachoking/jsonref/
+ https://pypi.org/project/jsonref/
+"
+SRC_URI="
+ https://github.com/gazpachoking/jsonref/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests.py
+}