summaryrefslogtreecommitdiff
path: root/dev-python/jsonschema
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-02 00:00:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-02 00:00:17 +0100
commitf5ef7f2371babf22c2c3fad17108692b09e4c98e (patch)
tree7f195ab30a74fa23e6dd24307d67d0890714d093 /dev-python/jsonschema
parent3d12b65aa1b4bb8b02b1f8d3e77bccf230b79a09 (diff)
gentoo auto-resync : 02:05:2024 - 00:00:17
Diffstat (limited to 'dev-python/jsonschema')
-rw-r--r--dev-python/jsonschema/Manifest2
-rw-r--r--dev-python/jsonschema/jsonschema-4.22.0.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/jsonschema/Manifest b/dev-python/jsonschema/Manifest
index 26d645fa8f20..1974eda27ee9 100644
--- a/dev-python/jsonschema/Manifest
+++ b/dev-python/jsonschema/Manifest
@@ -1,3 +1,5 @@
DIST jsonschema-4.21.1.tar.gz 321491 BLAKE2B 5c8fad04bf62af3f9204818cc5cff88dcc492b7957439be2a2fd8c0731a986c223d1612ab79d47696fa5695224fceacea35b5e699466f14393adc2cf9d89c83f SHA512 b0744a80d64572307860c9238ff5048e062b7665d9ed97dd390bae0b168ab96497f359ddc4e95f052d8b177161e5b808ee432bd9fe182c1ea39cbad417db9278
+DIST jsonschema-4.22.0.tar.gz 325490 BLAKE2B aa0fcd9cb35ffe93d9e7ae940f9fbfc6e20656b09bdec91163ee7120b3495210522c2354dd3e74b33274f61bd9364b6b33f9e6482bac58b2ee0c6dd4bba3658e SHA512 72c9ffd1edf8820696d831062cfae2d38729935b32d12b7fa5171fefa3d38d495b588152c07224a5c9d1f4b9f97bd9b2aa7919d3d4ecdae0ba396e60e954b1c5
EBUILD jsonschema-4.21.1.ebuild 1571 BLAKE2B d4c04d6131971a768aedec321c7dab2c322ad7c752ab3a4f518fd56cad4c3abddc0ed898eb1aaf4cd3b63dd2575acd52084b0e41982fb12f4513280dbfb10ae5 SHA512 c90efb16899cef8ca3ca427bfc9a84f22976520de1a4489f6604c67663ae90a48ba769bbb9733ea320e33b4bb6788c12b05667af5e1eff74634c5a1457df3b96
+EBUILD jsonschema-4.22.0.ebuild 1578 BLAKE2B 6a39cab87c3d90f6573da1e159cb31c4d9d14587f87f36c7e770291a7c9a18593793219f893adf2a9ece090a2d27db8ddf806abde2e90892a7c8836344e5108e SHA512 5cc10b381618249e6d93bedcbba724854d7f41a415e64c40d8d921b58911632ea1c328510e00b86f3baac09175778b1686f26602fa2f3588353a04badf56faca
MISC metadata.xml 705 BLAKE2B 731159cc340e6cbb15fe5a8d374188c8df685e8f8294d19af54ca3d209beb8c273b6e901b6b7fe75401324b8512ffb7f1870aefa8d4a139d1e3b84147d993af6 SHA512 1069fb33b2cf47d3dfd5e825b23ba1efa7d764d0d23aa009db522d04bc08362f5ca646411ec405cd33152a65ea8de2ea90d3dd6d4d4bf1a947ae7943e9d4c727
diff --git a/dev-python/jsonschema/jsonschema-4.22.0.ebuild b/dev-python/jsonschema/jsonschema-4.22.0.ebuild
new file mode 100644
index 000000000000..a7d67335f628
--- /dev/null
+++ b/dev-python/jsonschema/jsonschema-4.22.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="An implementation of JSON-Schema validation for Python"
+HOMEPAGE="
+ https://pypi.org/project/jsonschema/
+ https://github.com/python-jsonschema/jsonschema/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-specifications-2023.03.6[${PYTHON_USEDEP}]
+ >=dev-python/referencing-0.28.4[${PYTHON_USEDEP}]
+ >=dev-python/rpds-py-0.7.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
+ test? (
+ !!dev-python/shiboken6
+ )
+"
+
+# formatter deps
+RDEPEND+="
+ dev-python/fqdn[${PYTHON_USEDEP}]
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/isoduration[${PYTHON_USEDEP}]
+ >=dev-python/jsonpointer-1.13[${PYTHON_USEDEP}]
+ dev-python/rfc3339-validator[${PYTHON_USEDEP}]
+ dev-python/rfc3986-validator[${PYTHON_USEDEP}]
+ dev-python/rfc3987[${PYTHON_USEDEP}]
+ dev-python/uri-template[${PYTHON_USEDEP}]
+ >=dev-python/webcolors-1.11[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires pip, does not make much sense for the users
+ jsonschema/tests/test_cli.py::TestCLIIntegration::test_license
+ # fragile warning tests
+ jsonschema/tests/test_deprecations.py
+ # wtf?
+ jsonschema/tests/test_jsonschema_test_suite.py::test_suite_bug
+)